source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 1446

Revision 1446, 14.7 KB checked in by inagaki, 14 years ago (diff)

NEW: orc
updated: gstreamer, gstreamer-plugins-base, gstreamer-plugins-good

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.20.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.30
18Release:        1%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34Requires:       glib2 >= %{_glib2_ver}
35Requires:       libxml2 >= %{_libxml2_ver}
36Obsoletes:      gstreamer-tools
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       inagaki
41
42%description
43GStreamer is a streaming-media framework, based on graphs of filters which
44operate on media data. Applications using this library can do anything
45from real-time sound processing to playing videos, and just about anything
46else media-related.  Its plugin-based architecture means that new data
47types or processing capabilities can be added simply by installing new
48plugins.
49
50%package devel
51Summary:        Libraries/header files for GStreamer streaming media framework.
52Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
53Group:          Development/Libraries
54Requires:       %{name} = %{version}-%{release}
55Requires:       glib2-devel >= %{_glib2_ver}
56Requires:       libxml2-devel >= %{_libxml2_ver}
57
58%description devel
59GStreamer is a streaming-media framework, based on graphs of filters which
60operate on media data. Applications using this library can do anything
61from real-time sound processing to playing videos, and just about anything
62else media-related.  Its plugin-based architecture means that new data
63types or processing capabilities can be added simply by installing new   
64plugins.
65
66This package contains the libraries and includes files necessary to develop
67applications and plugins for GStreamer.
68
69# compat32
70%package -n compat32-%{name}
71Summary:        GStreamer streaming media framework runtime.
72Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
73Group:          System Environment/Libraries
74
75%description -n compat32-%{name}
76GStreamer is a streaming-media framework, based on graphs of filters which
77operate on media data. Applications using this library can do anything
78from real-time sound processing to playing videos, and just about anything
79else media-related.  Its plugin-based architecture means that new data
80types or processing capabilities can be added simply by installing new
81plugins.
82
83%package -n compat32-%{name}-devel
84Summary:        Libraries/header files for GStreamer streaming media framework.
85Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
86Group:          Development/Libraries
87Requires:       compat32-%{name} = %{version}-%{release}
88Requires:       %{name}-devel = %{version}-%{release}
89Requires:       compat32-glib2-devel >= %{_glib2_ver}
90Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
91
92%description -n compat32-%{name}-devel
93GStreamer is a streaming-media framework, based on graphs of filters which
94operate on media data. Applications using this library can do anything
95from real-time sound processing to playing videos, and just about anything
96else media-related.  Its plugin-based architecture means that new data
97types or processing capabilities can be added simply by installing new   
98plugins.
99
100This package contains the libraries and includes files necessary to develop
101applications and plugins for GStreamer.
102
103%prep
104%setup -q
105
106%build
107%configure \
108        --with-package-name='Vine Linux gstreamer package' \
109        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
110        --disable-docbook --enable-gtk-doc \
111        --disable-static --disable-examples \
112        --disable-tests --disable-debug
113
114make %{?_smp_mflags}
115
116%install
117[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
118
119make install DESTDIR=$RPM_BUILD_ROOT
120
121mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
122
123rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
125#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
126
127%find_lang %{po_package}
128
129%clean
130[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136%post -n compat32-%{name} -p /sbin/ldconfig
137
138%postun -n compat32-%{name} -p /sbin/ldconfig
139
140%files -f %{po_package}.lang
141%defattr(-, root, root)
142%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
143%doc TODO ABOUT-NLS
144%{_bindir}/*
145%dir %{_libdir}/gstreamer-%{major}
146%{_libdir}/gstreamer-%{major}/*.so*
147%{_libdir}/*.so.*
148%dir %{_libexecdir}/gstreamer-%{major}
149%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
150%{_mandir}/man1/*
151%dir %{_var}/cache/gstreamer-%{major}
152
153%files devel
154%defattr(-, root, root)
155%dir %{_includedir}/%{name}-%{major}
156%{_includedir}/%{name}-%{major}/*
157#{_libdir}/*.a
158%{_libdir}/*.so
159%{_libdir}/pkgconfig/gstreamer*.pc
160%{_datadir}/aclocal/*.m4
161%{_datadir}/gtk-doc/html/gstreamer-%{major}
162%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
163%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
164
165# compat32
166%if %{build_compat32}
167%files -n compat32-%{name}
168%defattr(-, root, root)
169%dir %{_libdir}/gstreamer-%{major}
170%{_libdir}/gstreamer-%{major}/*.so*
171%{_libdir}/*.so.*
172
173%files -n compat32-%{name}-devel
174%defattr(-, root, root)
175#{_libdir}/*.a
176%{_libdir}/*.so
177%{_libdir}/pkgconfig/gstreamer*.pc
178%endif
179
180%changelog
181* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
182- new upstream release
183
184* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
185- new upstream release
186
187* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
188- new upstream release
189- used make install instead of %%makeinstall
190
191* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
192- new upstream release
193- built with new toolchain
194
195* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
196- new upstream release
197
198* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
199- new upstream release
200
201* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
202- added compat32 package for x86_64 arch support
203
204* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
205- new upstream release
206- removed static librairies from devel package
207- added Packager tag
208
209* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
210- new upstream release
211- changed Group to System Environment/Libraries
212
213* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
214- new upstream release
215- spec in UTF-8
216
217* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
218- new upstream release
219
220* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
221- new upstream release
222
223* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
224- new upstream release
225
226* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
227- new upstream release
228
229* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
230- new upstream release
231
232* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
233- new upstream release
234
235* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
236- new upstream release
237- add Vendor/Distribution tag
238- add '-with-package-name' option to %%configure
239- use more macros
240
241* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
242- new upstream release
243
244* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
245- new upstream release
246
247* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
248- new upstream release
249
250* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
251- new upstream release
252
253* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
254- new upstream release
255
256* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
257- new upstream release
258
259* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
260- new upstream release
261
262* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
263- new upstream release
264
265* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
266- new upstream release
267
268* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
269- new upstream release
270  - change major to 0.10
271- update URLs
272- update versions: glibc >= 2.8, gtk-doc >= 1.3
273- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
274- remove from BuildRequires: popt, zlib-devel
275- remove obsolete options from %%configure
276- add --enable-gtk-doc to %%configure
277- add gtk-doc/html/gstreamer-* to gstreamer-devel package
278- add RELEASE to %%doc
279- remove REQUIREMENTS DOCBUILDING from %%doc
280- not exec gst-register-%%{major} at %%post
281
282* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
283- new upstream release
284
285* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
286- new upstream release
287
288* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
289- new upstream release
290- removed dependancy related to documentaion build
291
292* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
293- new upstream release
294
295* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
296- new upstream release
297
298* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
299- update alpha-noWerror patch (Patch10)
300
301* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
302- new upstream release
303
304* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
305- new upstream release
306
307* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
308- new upstream release
309
310* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
311- build without -Werror on alpha (Patch10)
312
313* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
314- new upstream release
315
316* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
317- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
318
319* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
320- fix broken %files entries..
321
322* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
323- new upstream release
324
325* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
326- build for Vine Linux
327
328* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
329- Add patch1 to fix C++ plugins on ia64
330
331* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
332- %post -p was wrong
333
334* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
335- explicitly add %{_libdir}/libgstreamer-{major}.so
336- explicitly add %{_libdir}/libgstcontrol-{major}.so
337
338* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
339- bump release
340
341* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
342- move .so files out of -devel
343
344* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
345- new version 0.5.0
346- require docbook-style-xsl
347- add gstreamer-tools package too
348- New patch to use the right docbook prefix.
349
350* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
351- downgrade to a release candidate.  Should work better on other arches
352- build without Werror
353
354* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
355- update to new version.  Remove ExcludeArch
356
357* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
358- excludearch some arches
359
360* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
361- import into CVS and build "officially"
362- use smp_mflags
363- temporarily disable docs build, doesn't seem to work
364
365* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
366- 0.4.2
367
368* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
369- 0.4.1
370
371* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
372- minor cleanups
373
374* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
375- moved header location
376
377* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
378- added popt
379- removed .la
380
381* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
382- added release of gstreamer to req of gstreamer-devel
383- changed location of API docs to be in gtk-doc like other gtk-doc stuff
384- reordered SPEC file
385
386* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
387- moved html docs to gtk-doc standard directory
388
389* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
390- move version defines of glib2 and libxml2 to configure.ac
391- add BuildRequires for these two libs
392
393* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
394- put html docs in canonical place, avoiding %doc erasure
395- added devhelp support, current install of it is hackish
396
397* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
398- Added documentation to build
399
400* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
401- added libgstbasicscheduler
402- renamed libgst to libgstreamer
403
404* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
405- Added configdir parameter as it seems the configdir gets weird otherwise
406
407* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
408- split off gstreamer-editor from core
409- removed gstreamer-gnome-apps
410
411* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
412- Cleaned up the spec file for the gstreamer core/plug-ins split
413- Improve spec file
414
415* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
416- Split of more plugins from the core and put them into their own modules
417- Includes colorspace, xfree and wav
418- Improved package Require lines
419- Added mp3encode (lame based) to the SPEC
420
421* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
422- Thomas merged mpeg plugins into one
423* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
424- More minor cleanups including some fixed descriptions from Andrew Mitchell
425
426* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
427- Added logging to the make statement
428
429* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
430- Updated in preparation for 0.3.0 release
431
432* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
433- Updated for 0.2.1 release
434- Split out the GUI packages into their own RPM
435- added new plugins (FLAC, festival, quicktime etc.)
436
437* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
438- Visualisation plugins bundled out togheter
439- Moved files sections up close to their respective descriptions
440
441* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
442- Split the package into separate RPMS,
443  putting most plugins out by themselves.
444
445* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
446- Updated with change suggestions from Dennis Bjorklund
447
448* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
449- updated to build -devel package as well
450
451* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
452- first draft of spec file
453
Note: See TracBrowser for help on using the repository browser.