source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 926

Revision 926, 14.6 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release (gnome packages)

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.8.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Version:        0.10.29
16Release:        1%{?_dist_release}
17Summary:        GStreamer streaming media framework runtime.
18Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
19Group:          System Environment/Libraries
20License:        LGPL
21URL:            http://gstreamer.freedesktop.org/
22Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  glib2-devel >= %{_glib2_ver}
26BuildRequires:  libxml2-devel >= %{_libxml2_ver}
27BuildRequires:  bison
28BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
29BuildRequires:  flex
30BuildRequires:  ghostscript
31BuildRequires:  check >= %{_check_ver}
32BuildRequires:  python >= %{_python_ver}, python-pyxml
33Requires:       glib2 >= %{_glib2_ver}
34Requires:       libxml2 >= %{_libxml2_ver}
35Obsoletes:      gstreamer-tools
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       inagaki
40
41%description
42GStreamer is a streaming-media framework, based on graphs of filters which
43operate on media data. Applications using this library can do anything
44from real-time sound processing to playing videos, and just about anything
45else media-related.  Its plugin-based architecture means that new data
46types or processing capabilities can be added simply by installing new
47plugins.
48
49%package devel
50Summary:        Libraries/header files for GStreamer streaming media framework.
51Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       glib2-devel >= %{_glib2_ver}
55Requires:       libxml2-devel >= %{_libxml2_ver}
56
57%description devel
58GStreamer is a streaming-media framework, based on graphs of filters which
59operate on media data. Applications using this library can do anything
60from real-time sound processing to playing videos, and just about anything
61else media-related.  Its plugin-based architecture means that new data
62types or processing capabilities can be added simply by installing new   
63plugins.
64
65This package contains the libraries and includes files necessary to develop
66applications and plugins for GStreamer.
67
68# compat32
69%package -n compat32-%{name}
70Summary:        GStreamer streaming media framework runtime.
71Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
72Group:          System Environment/Libraries
73
74%description -n compat32-%{name}
75GStreamer is a streaming-media framework, based on graphs of filters which
76operate on media data. Applications using this library can do anything
77from real-time sound processing to playing videos, and just about anything
78else media-related.  Its plugin-based architecture means that new data
79types or processing capabilities can be added simply by installing new
80plugins.
81
82%package -n compat32-%{name}-devel
83Summary:        Libraries/header files for GStreamer streaming media framework.
84Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
85Group:          Development/Libraries
86Requires:       compat32-%{name} = %{version}-%{release}
87Requires:       %{name}-devel = %{version}-%{release}
88Requires:       compat32-glib2-devel >= %{_glib2_ver}
89Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
90
91%description -n compat32-%{name}-devel
92GStreamer is a streaming-media framework, based on graphs of filters which
93operate on media data. Applications using this library can do anything
94from real-time sound processing to playing videos, and just about anything
95else media-related.  Its plugin-based architecture means that new data
96types or processing capabilities can be added simply by installing new   
97plugins.
98
99This package contains the libraries and includes files necessary to develop
100applications and plugins for GStreamer.
101
102%prep
103%setup -q
104
105%build
106%configure \
107        --with-package-name='Vine Linux gstreamer package' \
108        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
109        --disable-docbook --enable-gtk-doc \
110        --disable-static --disable-examples \
111        --disable-tests --disable-debug
112
113make %{?_smp_mflags}
114
115%install
116[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
117
118make install DESTDIR=$RPM_BUILD_ROOT
119
120mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
121
122rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
123rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
124#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
125
126%find_lang %{po_package}
127
128%clean
129[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132
133%postun -p /sbin/ldconfig
134
135%post -n compat32-%{name} -p /sbin/ldconfig
136
137%postun -n compat32-%{name} -p /sbin/ldconfig
138
139%files -f %{po_package}.lang
140%defattr(-, root, root)
141%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
142%doc TODO ABOUT-NLS
143%{_bindir}/*
144%dir %{_libdir}/gstreamer-%{major}
145%{_libdir}/gstreamer-%{major}/*.so*
146%{_libdir}/*.so.*
147%dir %{_libexecdir}/gstreamer-%{major}
148%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
149%{_mandir}/man1/*
150%dir %{_var}/cache/gstreamer-%{major}
151
152%files devel
153%defattr(-, root, root)
154%dir %{_includedir}/%{name}-%{major}
155%{_includedir}/%{name}-%{major}/*
156#{_libdir}/*.a
157%{_libdir}/*.so
158%{_libdir}/pkgconfig/gstreamer*.pc
159%{_datadir}/aclocal/*.m4
160%{_datadir}/gtk-doc/html/gstreamer-%{major}
161%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
162%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
163
164# compat32
165%if %{build_compat32}
166%files -n compat32-%{name}
167%defattr(-, root, root)
168%dir %{_libdir}/gstreamer-%{major}
169%{_libdir}/gstreamer-%{major}/*.so*
170%{_libdir}/*.so.*
171
172%files -n compat32-%{name}-devel
173%defattr(-, root, root)
174#{_libdir}/*.a
175%{_libdir}/*.so
176%{_libdir}/pkgconfig/gstreamer*.pc
177%endif
178
179%changelog
180* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
181- new upstream release
182
183* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
184- new upstream release
185- used make install instead of %%makeinstall
186
187* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
188- new upstream release
189- built with new toolchain
190
191* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
192- new upstream release
193
194* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
195- new upstream release
196
197* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
198- added compat32 package for x86_64 arch support
199
200* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
201- new upstream release
202- removed static librairies from devel package
203- added Packager tag
204
205* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
206- new upstream release
207- changed Group to System Environment/Libraries
208
209* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
210- new upstream release
211- spec in UTF-8
212
213* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
214- new upstream release
215
216* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
217- new upstream release
218
219* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
220- new upstream release
221
222* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
223- new upstream release
224
225* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
226- new upstream release
227
228* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
229- new upstream release
230
231* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
232- new upstream release
233- add Vendor/Distribution tag
234- add '-with-package-name' option to %%configure
235- use more macros
236
237* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
238- new upstream release
239
240* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
241- new upstream release
242
243* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
244- new upstream release
245
246* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
247- new upstream release
248
249* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
250- new upstream release
251
252* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
253- new upstream release
254
255* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
256- new upstream release
257
258* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
259- new upstream release
260
261* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
262- new upstream release
263
264* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
265- new upstream release
266  - change major to 0.10
267- update URLs
268- update versions: glibc >= 2.8, gtk-doc >= 1.3
269- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
270- remove from BuildRequires: popt, zlib-devel
271- remove obsolete options from %%configure
272- add --enable-gtk-doc to %%configure
273- add gtk-doc/html/gstreamer-* to gstreamer-devel package
274- add RELEASE to %%doc
275- remove REQUIREMENTS DOCBUILDING from %%doc
276- not exec gst-register-%%{major} at %%post
277
278* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
279- new upstream release
280
281* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
282- new upstream release
283
284* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
285- new upstream release
286- removed dependancy related to documentaion build
287
288* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
289- new upstream release
290
291* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
292- new upstream release
293
294* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
295- update alpha-noWerror patch (Patch10)
296
297* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
298- new upstream release
299
300* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
301- new upstream release
302
303* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
304- new upstream release
305
306* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
307- build without -Werror on alpha (Patch10)
308
309* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
310- new upstream release
311
312* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
313- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
314
315* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
316- fix broken %files entries..
317
318* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
319- new upstream release
320
321* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
322- build for Vine Linux
323
324* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
325- Add patch1 to fix C++ plugins on ia64
326
327* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
328- %post -p was wrong
329
330* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
331- explicitly add %{_libdir}/libgstreamer-{major}.so
332- explicitly add %{_libdir}/libgstcontrol-{major}.so
333
334* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
335- bump release
336
337* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
338- move .so files out of -devel
339
340* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
341- new version 0.5.0
342- require docbook-style-xsl
343- add gstreamer-tools package too
344- New patch to use the right docbook prefix.
345
346* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
347- downgrade to a release candidate.  Should work better on other arches
348- build without Werror
349
350* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
351- update to new version.  Remove ExcludeArch
352
353* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
354- excludearch some arches
355
356* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
357- import into CVS and build "officially"
358- use smp_mflags
359- temporarily disable docs build, doesn't seem to work
360
361* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
362- 0.4.2
363
364* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
365- 0.4.1
366
367* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
368- minor cleanups
369
370* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
371- moved header location
372
373* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
374- added popt
375- removed .la
376
377* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
378- added release of gstreamer to req of gstreamer-devel
379- changed location of API docs to be in gtk-doc like other gtk-doc stuff
380- reordered SPEC file
381
382* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
383- moved html docs to gtk-doc standard directory
384
385* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
386- move version defines of glib2 and libxml2 to configure.ac
387- add BuildRequires for these two libs
388
389* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
390- put html docs in canonical place, avoiding %doc erasure
391- added devhelp support, current install of it is hackish
392
393* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
394- Added documentation to build
395
396* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
397- added libgstbasicscheduler
398- renamed libgst to libgstreamer
399
400* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
401- Added configdir parameter as it seems the configdir gets weird otherwise
402
403* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
404- split off gstreamer-editor from core
405- removed gstreamer-gnome-apps
406
407* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
408- Cleaned up the spec file for the gstreamer core/plug-ins split
409- Improve spec file
410
411* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
412- Split of more plugins from the core and put them into their own modules
413- Includes colorspace, xfree and wav
414- Improved package Require lines
415- Added mp3encode (lame based) to the SPEC
416
417* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
418- Thomas merged mpeg plugins into one
419* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
420- More minor cleanups including some fixed descriptions from Andrew Mitchell
421
422* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
423- Added logging to the make statement
424
425* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
426- Updated in preparation for 0.3.0 release
427
428* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
429- Updated for 0.2.1 release
430- Split out the GUI packages into their own RPM
431- added new plugins (FLAC, festival, quicktime etc.)
432
433* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
434- Visualisation plugins bundled out togheter
435- Moved files sections up close to their respective descriptions
436
437* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
438- Split the package into separate RPMS,
439  putting most plugins out by themselves.
440
441* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
442- Updated with change suggestions from Dennis Bjorklund
443
444* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
445- updated to build -devel package as well
446
447* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
448- first draft of spec file
449
Note: See TracBrowser for help on using the repository browser.