source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 521

Revision 521, 14.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.8.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Version:        0.10.26
16Release:        1%{?_dist_release}
17Summary:        GStreamer streaming media framework runtime.
18Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
19Group:          System Environment/Libraries
20License:        LGPL
21URL:            http://gstreamer.freedesktop.org/
22Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  glib2-devel >= %{_glib2_ver}
26BuildRequires:  libxml2-devel >= %{_libxml2_ver}
27BuildRequires:  bison
28BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
29BuildRequires:  flex
30BuildRequires:  ghostscript
31BuildRequires:  check >= %{_check_ver}
32BuildRequires:  python >= %{_python_ver}, python-pyxml
33Requires:       glib2 >= %{_glib2_ver}
34Requires:       libxml2 >= %{_libxml2_ver}
35Obsoletes:      gstreamer-tools
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       inagaki
40
41%description
42GStreamer is a streaming-media framework, based on graphs of filters which
43operate on media data. Applications using this library can do anything
44from real-time sound processing to playing videos, and just about anything
45else media-related.  Its plugin-based architecture means that new data
46types or processing capabilities can be added simply by installing new
47plugins.
48
49%package devel
50Summary:        Libraries/header files for GStreamer streaming media framework.
51Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       glib2-devel >= %{_glib2_ver}
55Requires:       libxml2-devel >= %{_libxml2_ver}
56
57%description devel
58GStreamer is a streaming-media framework, based on graphs of filters which
59operate on media data. Applications using this library can do anything
60from real-time sound processing to playing videos, and just about anything
61else media-related.  Its plugin-based architecture means that new data
62types or processing capabilities can be added simply by installing new   
63plugins.
64
65This package contains the libraries and includes files necessary to develop
66applications and plugins for GStreamer.
67
68# compat32
69%package -n compat32-%{name}
70Summary:        GStreamer streaming media framework runtime.
71Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
72Group:          System Environment/Libraries
73
74%description -n compat32-%{name}
75GStreamer is a streaming-media framework, based on graphs of filters which
76operate on media data. Applications using this library can do anything
77from real-time sound processing to playing videos, and just about anything
78else media-related.  Its plugin-based architecture means that new data
79types or processing capabilities can be added simply by installing new
80plugins.
81
82%package -n compat32-%{name}-devel
83Summary:        Libraries/header files for GStreamer streaming media framework.
84Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
85Group:          Development/Libraries
86Requires:       compat32-%{name} = %{version}-%{release}
87Requires:       %{name}-devel = %{version}-%{release}
88Requires:       compat32-glib2-devel >= %{_glib2_ver}
89Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
90
91%description -n compat32-%{name}-devel
92GStreamer is a streaming-media framework, based on graphs of filters which
93operate on media data. Applications using this library can do anything
94from real-time sound processing to playing videos, and just about anything
95else media-related.  Its plugin-based architecture means that new data
96types or processing capabilities can be added simply by installing new   
97plugins.
98
99This package contains the libraries and includes files necessary to develop
100applications and plugins for GStreamer.
101
102%prep
103%setup -q
104
105%build
106%configure \
107        --with-package-name='Vine Linux gstreamer package' \
108        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
109        --disable-docbook --enable-gtk-doc \
110        --disable-static --disable-examples \
111        --disable-tests --disable-debug
112
113%__make %{?_smp_mflags}
114
115%install
116[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
117
118%makeinstall
119
120%__mkdir_p %{buildroot}%{_var}/cache/gstreamer-%{major}
121
122#__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.a
123%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.la
124%__rm -f %{buildroot}%{_libdir}/*.la
125#__rm -f %{buildroot}%{_libdir}/libgstmedia-info*.so.0.0.0
126
127%find_lang %{po_package}
128
129%clean
130[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136%post -n compat32-%{name} -p /sbin/ldconfig
137
138%postun -n compat32-%{name} -p /sbin/ldconfig
139
140%files -f %{po_package}.lang
141%defattr(-, root, root)
142%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
143%doc TODO ABOUT-NLS
144%{_bindir}/*
145%dir %{_libdir}/gstreamer-%{major}
146%{_libdir}/gstreamer-%{major}/*.so*
147%{_libdir}/*.so.*
148%dir %{_libexecdir}/gstreamer-%{major}
149%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
150%{_mandir}/man1/*
151%dir %{_var}/cache/gstreamer-%{major}
152
153%files devel
154%defattr(-, root, root)
155%dir %{_includedir}/%{name}-%{major}
156%{_includedir}/%{name}-%{major}/*
157#{_libdir}/*.a
158%{_libdir}/*.so
159%{_libdir}/pkgconfig/gstreamer*.pc
160%{_datadir}/aclocal/*.m4
161%{_datadir}/gtk-doc/html/gstreamer-%{major}
162%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
163%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
164
165# compat32
166%if %{build_compat32}
167%files -n compat32-%{name}
168%defattr(-, root, root)
169%dir %{_libdir}/gstreamer-%{major}
170%{_libdir}/gstreamer-%{major}/*.so*
171%{_libdir}/*.so.*
172
173%files -n compat32-%{name}-devel
174%defattr(-, root, root)
175#{_libdir}/*.a
176%{_libdir}/*.so
177%{_libdir}/pkgconfig/gstreamer*.pc
178%endif
179
180%changelog
181* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
182- new upstream release
183- built with new toolchain
184
185* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
186- new upstream release
187
188* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
189- new upstream release
190
191* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
192- added compat32 package for x86_64 arch support
193
194* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
195- new upstream release
196- removed static librairies from devel package
197- added Packager tag
198
199* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
200- new upstream release
201- changed Group to System Environment/Libraries
202
203* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
204- new upstream release
205- spec in UTF-8
206
207* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
208- new upstream release
209
210* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
211- new upstream release
212
213* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
214- new upstream release
215
216* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
217- new upstream release
218
219* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
220- new upstream release
221
222* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
223- new upstream release
224
225* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
226- new upstream release
227- add Vendor/Distribution tag
228- add '-with-package-name' option to %%configure
229- use more macros
230
231* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
232- new upstream release
233
234* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
235- new upstream release
236
237* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
238- new upstream release
239
240* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
241- new upstream release
242
243* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
244- new upstream release
245
246* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
247- new upstream release
248
249* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
250- new upstream release
251
252* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
253- new upstream release
254
255* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
256- new upstream release
257
258* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
259- new upstream release
260  - change major to 0.10
261- update URLs
262- update versions: glibc >= 2.8, gtk-doc >= 1.3
263- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
264- remove from BuildRequires: popt, zlib-devel
265- remove obsolete options from %%configure
266- add --enable-gtk-doc to %%configure
267- add gtk-doc/html/gstreamer-* to gstreamer-devel package
268- add RELEASE to %%doc
269- remove REQUIREMENTS DOCBUILDING from %%doc
270- not exec gst-register-%%{major} at %%post
271
272* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
273- new upstream release
274
275* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
276- new upstream release
277
278* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
279- new upstream release
280- removed dependancy related to documentaion build
281
282* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
283- new upstream release
284
285* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
286- new upstream release
287
288* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
289- update alpha-noWerror patch (Patch10)
290
291* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
292- new upstream release
293
294* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
295- new upstream release
296
297* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
298- new upstream release
299
300* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
301- build without -Werror on alpha (Patch10)
302
303* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
304- new upstream release
305
306* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
307- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
308
309* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
310- fix broken %files entries..
311
312* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
313- new upstream release
314
315* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
316- build for Vine Linux
317
318* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
319- Add patch1 to fix C++ plugins on ia64
320
321* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
322- %post -p was wrong
323
324* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
325- explicitly add %{_libdir}/libgstreamer-{major}.so
326- explicitly add %{_libdir}/libgstcontrol-{major}.so
327
328* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
329- bump release
330
331* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
332- move .so files out of -devel
333
334* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
335- new version 0.5.0
336- require docbook-style-xsl
337- add gstreamer-tools package too
338- New patch to use the right docbook prefix.
339
340* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
341- downgrade to a release candidate.  Should work better on other arches
342- build without Werror
343
344* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
345- update to new version.  Remove ExcludeArch
346
347* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
348- excludearch some arches
349
350* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
351- import into CVS and build "officially"
352- use smp_mflags
353- temporarily disable docs build, doesn't seem to work
354
355* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
356- 0.4.2
357
358* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
359- 0.4.1
360
361* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
362- minor cleanups
363
364* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
365- moved header location
366
367* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
368- added popt
369- removed .la
370
371* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
372- added release of gstreamer to req of gstreamer-devel
373- changed location of API docs to be in gtk-doc like other gtk-doc stuff
374- reordered SPEC file
375
376* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
377- moved html docs to gtk-doc standard directory
378
379* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
380- move version defines of glib2 and libxml2 to configure.ac
381- add BuildRequires for these two libs
382
383* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
384- put html docs in canonical place, avoiding %doc erasure
385- added devhelp support, current install of it is hackish
386
387* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
388- Added documentation to build
389
390* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
391- added libgstbasicscheduler
392- renamed libgst to libgstreamer
393
394* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
395- Added configdir parameter as it seems the configdir gets weird otherwise
396
397* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
398- split off gstreamer-editor from core
399- removed gstreamer-gnome-apps
400
401* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
402- Cleaned up the spec file for the gstreamer core/plug-ins split
403- Improve spec file
404
405* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
406- Split of more plugins from the core and put them into their own modules
407- Includes colorspace, xfree and wav
408- Improved package Require lines
409- Added mp3encode (lame based) to the SPEC
410
411* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
412- Thomas merged mpeg plugins into one
413* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
414- More minor cleanups including some fixed descriptions from Andrew Mitchell
415
416* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
417- Added logging to the make statement
418
419* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
420- Updated in preparation for 0.3.0 release
421
422* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
423- Updated for 0.2.1 release
424- Split out the GUI packages into their own RPM
425- added new plugins (FLAC, festival, quicktime etc.)
426
427* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
428- Visualisation plugins bundled out togheter
429- Moved files sections up close to their respective descriptions
430
431* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
432- Split the package into separate RPMS,
433  putting most plugins out by themselves.
434
435* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
436- Updated with change suggestions from Dennis Bjorklund
437
438* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
439- updated to build -devel package as well
440
441* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
442- first draft of spec file
443
Note: See TracBrowser for help on using the repository browser.