source: projects/specs/trunk/g/gstreamer-plugins-base/gstreamer-plugins-base-vl.spec @ 5394

Revision 5394, 16.1 KB checked in by Takemikaduchi, 12 years ago (diff)

slocate: fix BTS:1176
qt4: fix compat32-qt4-devel
others: create compat32 sub packages

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define major 0.10
4
5%define _gst_ver        0.10.35
6%define _glib2_ver      2.28.8
7%define _gtk2_ver       2.24.5
8%define _gtk_doc_ver    1.3
9%define _check_ver      0.9.2
10%define _python_ver     2.6
11%define _alsa_lib_ver   0.9.1
12%define _libogg_ver     1.0
13%define _libvorbis_ver  1.0
14%define _freetype2_ver  2.0.9
15
16%define po_package      gst-plugins-base-%{major}
17
18Summary:        GStreamer Streaming-media framework base plugins
19Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
20Name:           gstreamer-plugins-base
21Version:        0.10.35
22Release:        2%{?_dist_release}
23License:        LGPL
24Group:          System Environment/Libraries
25URL:            http://gstreamer.freedesktop.org/
26Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.bz2
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29Requires:       gstreamer >= %{_gst_ver}
30Requires:       glib2 >= %{_glib2_ver}
31Requires:       alsa-lib >= %{_alsa_lib_ver}
32Requires:       pango
33Requires:       gnome-vfs2
34Requires:       libogg >= %{_libogg_ver}
35Requires:       libvorbis, libtheora >= %{_libvorbis_ver}
36
37BuildRequires:  gstreamer-devel >= %{_gst_ver}
38BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
39BuildRequires:  python >= %{_python_ver}, python-pyxml
40BuildRequires:  glib2-devel >= %{_glib2_ver}
41BuildRequires:  check >= %{_check_ver}
42BuildRequires:  gtk2-devel >= %{_gtk2_ver}
43BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
44BuildRequires:  cdparanoia-devel
45BuildRequires:  gnome-vfs2-devel
46BuildRequires:  libogg-devel >= %{_libogg_ver}
47BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
48BuildRequires:  pango-devel
49BuildRequires:  freetype2-devel >= %{_freetype2_ver}
50BuildRequires:  fontconfig-devel
51BuildRequires:  libX11-devel
52BuildRequires:  libXv-devel
53BuildRequires:  libvisual-devel
54BuildRequires:  orc-devel
55BuildRequires:  libgudev1-devel
56BuildRequires:  gobject-introspection-devel
57
58Obsoletes:      %{name}-gnomevfs < 0.10.5
59Obsoletes:      %{name}-ogg < 0.10.5
60
61Vendor:         Project Vine
62Distribution:   Vine Linux
63Packager:       inagaki
64
65%description
66GStreamer is a streaming-media framework, based on graphs of filters which
67operate on media data. Applications using this library can do anything
68from real-time sound processing to playing videos, and just about anything
69else media-related.  Its plugin-based architecture means that new data
70types or processing capabilities can be added simply by installing new
71plugins.
72
73This package contains a set of well-maintained base plugins.
74
75%package devel
76Summary:        Libraries/include files for GStreamer base plugins
77Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
78Group:          Development/Libraries
79Requires:       %{name} = %{version}-%{release}
80Requires:       gstreamer-devel >= %{_gst_ver}
81
82%description devel
83GStreamer is a streaming-media framework, based on graphs of filters which
84operate on media data. Applications using this library can do anything
85from real-time sound processing to playing videos, and just about anything
86else media-related.  Its plugin-based architecture means that new data
87types or processing capabilities can be added simply by installing new
88plugins.
89
90This package contains GStreamer base plugins library depvelopment and header
91files.
92
93# compat32
94%package -n compat32-%{name}
95Summary:        GStreamer Streaming-media framework base plugins
96Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
97Group:          System Environment/Libraries
98Requires:       %{name} = %{version}-%{release}
99
100%description -n compat32-%{name}
101GStreamer is a streaming-media framework, based on graphs of filters which
102operate on media data. Applications using this library can do anything
103from real-time sound processing to playing videos, and just about anything
104else media-related.  Its plugin-based architecture means that new data
105types or processing capabilities can be added simply by installing new
106plugins.
107
108This package contains a set of well-maintained base plugins.
109
110%package -n compat32-%{name}-devel
111Summary:        Libraries/include files for GStreamer base plugins
112Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
113Group:          Development/Libraries
114Requires:       compat32-%{name} = %{version}-%{release}
115Requires:       %{name}-devel = %{version}-%{release}
116Requires:       compat32-gstreamer-devel >= %{_gst_ver}
117
118%description -n compat32-%{name}-devel
119GStreamer is a streaming-media framework, based on graphs of filters which
120operate on media data. Applications using this library can do anything
121from real-time sound processing to playing videos, and just about anything
122else media-related.  Its plugin-based architecture means that new data
123types or processing capabilities can be added simply by installing new
124plugins.
125
126This package contains GStreamer base plugins library depvelopment and header
127files.
128
129
130%prep
131%setup -q -n gst-plugins-base-%{version}
132
133%build
134%ifarch alpha
135%define optflags -O2 -mieee -fPIC
136%endif
137
138%configure \
139        --with-package-name='Vine Linux gstreamer-plugins-base package' \
140        --enable-gtk-doc \
141        --disable-static \
142        --disable-debug \
143        --enable-orc \
144        --with-gudev \
145        --enable-introspection=yes
146
147make %{?_smp_mflags}
148
149%install
150[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
151make install DESTDIR=$RPM_BUILD_ROOT
152
153# Clean out files that should not be part of the rpm.
154rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
155rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
156
157%find_lang %{po_package}
158
159%clean
160[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
161
162%post -p /sbin/ldconfig
163
164%postun -p /sbin/ldconfig
165
166%post -n compat32-%{name} -p /sbin/ldconfig
167
168%postun -n compat32-%{name} -p /sbin/ldconfig
169
170%files -f %{po_package}.lang
171%defattr(-,root,root)
172%doc AUTHORS ChangeLog COPYING* NEWS README RELEASE REQUIREMENTS
173
174# helper programs
175%{_bindir}/gst-*
176%{_mandir}/man1/gst-*
177
178# libraries
179%{_libdir}/libgst*-%{major}.so.*
180%{_libdir}/girepository-1.0/*.typelib
181
182# base plugins without external dependencies
183%{_libdir}/gstreamer-%{major}/libgstadder.so
184%{_libdir}/gstreamer-%{major}/libgstaudioconvert.so
185%{_libdir}/gstreamer-%{major}/libgstaudiorate.so
186%{_libdir}/gstreamer-%{major}/libgstaudioresample.so
187%{_libdir}/gstreamer-%{major}/libgstaudiotestsrc.so
188%{_libdir}/gstreamer-%{major}/libgstapp.so
189%{_libdir}/gstreamer-%{major}/libgstcdparanoia.so
190%{_libdir}/gstreamer-%{major}/libgstdecodebin.so
191%{_libdir}/gstreamer-%{major}/libgstdecodebin2.so
192%{_libdir}/gstreamer-%{major}/libgstencodebin.so
193%{_libdir}/gstreamer-%{major}/libgstffmpegcolorspace.so
194%{_libdir}/gstreamer-%{major}/libgstgdp.so
195%{_libdir}/gstreamer-%{major}/libgstgio.so
196%{_libdir}/gstreamer-%{major}/libgstplaybin.so
197#{_libdir}/gstreamer-%{major}/libgstqueue2.so
198%{_libdir}/gstreamer-%{major}/libgstsubparse.so
199%{_libdir}/gstreamer-%{major}/libgsttcp.so
200%{_libdir}/gstreamer-%{major}/libgsttypefindfunctions.so
201#{_libdir}/gstreamer-%{major}/libgsturidecodebin.so
202#%{_libdir}/gstreamer-%{major}/libgstvideo4linux.so
203%{_libdir}/gstreamer-%{major}/libgstvideorate.so
204%{_libdir}/gstreamer-%{major}/libgstvideoscale.so
205%{_libdir}/gstreamer-%{major}/libgstvideotestsrc.so
206%{_libdir}/gstreamer-%{major}/libgstvolume.so
207%{_libdir}/gstreamer-%{major}/libgstximagesink.so
208%{_libdir}/gstreamer-%{major}/libgstxvimagesink.so
209
210# base plugins with external dependencies, but in the main package
211%{_libdir}/gstreamer-%{major}/libgstalsa.so
212%{_libdir}/gstreamer-%{major}/libgstpango.so
213%{_libdir}/gstreamer-%{major}/libgstgnomevfs.so
214%{_libdir}/gstreamer-%{major}/libgstlibvisual.so
215%{_libdir}/gstreamer-%{major}/libgstogg.so
216%{_libdir}/gstreamer-%{major}/libgsttheora.so
217%{_libdir}/gstreamer-%{major}/libgstvorbis.so
218
219%files devel
220%defattr(-,root,root)
221%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
222%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
223%{_datadir}/gir-1.0/*.gir
224%{_includedir}/gstreamer-%{major}/gst/*
225%{_libdir}/pkgconfig/*.pc
226%{_libdir}/libgst*-%{major}.so
227
228# compat32
229%if %{build_compat32}
230%files -n compat32-%{name}
231%defattr(-,root,root)
232%{_libdir}/libgst*-%{major}.so.*
233%{_libdir}/gstreamer-%{major}/*.so
234
235%files -n compat32-%{name}-devel
236%defattr(-,root,root)
237%{_libdir}/libgst*-%{major}.so
238%{_libdir}/pkgconfig/*.pc
239%endif
240
241
242%changelog
243* Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-2
244- create compat32 sub packages
245
246* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
247- new upstream release
248
249* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
250- new upstream release
251
252* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
253- new upstream release
254
255* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
256- new upstream release
257- change BuildRequires: gobject-introspection-devel instead of gir-repository-devel
258- add configure option (--enable-introspection=yes)
259
260* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
261- build with rpm-4.8.1-1 for pkg-config file
262- add BuildRequires: gir-repository-devel
263
264* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
265- new upstream release
266- added BR: orc-devel, libgudev1-devel
267- removed liboil dependency
268
269* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.29-1
270- new upstream release
271
272* Wed Mar 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
273- new upstream release
274
275* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
276- new upstream release
277- built with new toolchain
278
279* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
280- new upstream release
281
282* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
283- new upstream release
284
285* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
286- new upstream release
287- added BR: libvisual-devel
288- added Packager tag
289
290* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
291- new upstream release
292
293* Mon Dec 29 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.21-1
294- add configure option --enable-experimental to enable giosink
295
296* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1
297- new upstream release
298- spec in UTF-8
299
300* Sun Jun 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1
301- new upstream release
302- updated build dependancies
303
304* Tue Apr 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.19-2
305- build with xorg-x11-7.3
306  - remove XOrg/XOrg-devel deps
307  - add BuildRequires: libXv-devel, fontconfig-devel
308
309* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
310- new upstream release
311
312* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
313- new upstream release
314
315* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
316- new upstream release
317
318* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
319- new upstream release
320
321* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
322- new upstream release
323
324* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
325- new upstream release
326- update %%_gst_ver
327- add Vendor/Distribution tag
328- add '-with-package-name' option to %%configure
329- use more macros
330
331* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
332- new upstream release
333- update %%_gst_ver
334- update required version of liboil
335- add new plugin: libgstdecodebin2.so
336
337* Sat Nov 25 2006 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
338- new upstream release
339- update %%_gst_ver
340- changed Group to Applications/Multimedia
341
342* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
343- new upstream release
344- update %%_gst_ver
345
346* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
347- new upstream release
348- update %%_gst_ver
349
350* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.7-0vl1
351- new upstream release
352- update %%_gst_ver
353
354* Mon May  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.6-0vl1
355- new upstream release
356
357* Sun Mar 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl2
358- remove Obsoletes: gstreamer-plugins
359
360* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
361- new upstream release
362- update %%_gst_ver and liboil version
363- merge -gnomevfs,ogg into main package
364- add Obsoletes: %%{name}-gnomevfs, %%{name}-ogg < 0.10.5
365
366* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
367- new upstream release
368- update %%_gst_ver
369
370* Sun Jan 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl2
371- add Obsoletes: gstreamer-plugins < 0.9
372
373* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
374- initial package based on gstreamer-plugins
375- new upstream release
376  - change major to 0.10
377- update dependencies
378- update %%configure options
379- add subpackage: -gnomevfs, -ogg
380
381* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
382- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
383
384* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
385- added missing alsa plugin
386
387* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
388- new upstream release
389- added alsa and cairo plugins
390
391* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
392- new upstream release
393
394* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
395- new upstream release
396
397* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
398- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
399
400* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
401- added libgstcdparania.so for gnome-cd (gnome-media)
402- BuildRequires: cdparanoia-devel
403
404* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
405- drop BuildRequires: xmms-devel, Requires: xmms
406
407* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
408- libgstvideo4linux2.so temoporally omitted for ppc
409  (will be back later, I hope)
410
411* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
412- new upstream release
413- s/Copyright/License/
414- includes plugins depend on main package libraries only
415
416* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
417- new upstream release
418
419* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
420- new upstream release
421
422* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
423- new upstream release
424
425* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
426- new upstream release
427
428* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
429- build with -fPIC on alpha
430
431* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
432- modified scripts
433
434* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
435- new upstream release
436
437* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
438- disable some plugins.
439
440* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
441- new upstream release
442- initial build for Vine Linux
443
444* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
445- Include ia64
446- Add BuildRequires: autoconf automake
447
448* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
449- rebuild
450
451* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
452- rebuild
453
454* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
455- rebuild
456- disable tests
457
458* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
459- rebuild
460
461* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
462- fix libdir for ia64.
463
464* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
465- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
466- Add devel package
467
468* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
469- 0.5.0
470- apparently, festival-devel isn't needed.
471
472* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
473- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
474
475* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
476- excludearch the arches that can't build gstreamer cothreads
477- well it isn't really SMP-safe
478- add patch for including pthread.h when required
479- prereq gconftool
480- fix typo that broke schema installation in post
481
482* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
483- initial "official" import
484- munge tarball for legal cleanliness
485
486* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
487- 0.4.2
488
489* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
490- 0.4.1
491- install the gconf schema
492- use %%configure
493
494* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
495- update to 0.4.0
496- give explicit vorbis include path, don't run vorbis test
497
498* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
499- collapse into one package to preserve some sanity
500
501* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
502- added more BuildRequires and Requires
503- rearranged some plugins
504- added changelog ;)
Note: See TracBrowser for help on using the repository browser.