source: projects/specs/trunk/g/gstreamer-plugins-base/gstreamer-plugins-base-vl.spec @ 4616

Revision 4616, 14.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define major 0.10
2
3%define _gst_ver        0.10.35
4%define _glib2_ver      2.28.8
5%define _gtk2_ver       2.24.5
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.6
9%define _alsa_lib_ver   0.9.1
10%define _libogg_ver     1.0
11%define _libvorbis_ver  1.0
12%define _freetype2_ver  2.0.9
13
14%define po_package      gst-plugins-base-%{major}
15
16Summary:        GStreamer Streaming-media framework base plugins
17Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
18Name:           gstreamer-plugins-base
19Version:        0.10.35
20Release:        1%{?_dist_release}
21License:        LGPL
22Group:          System Environment/Libraries
23URL:            http://gstreamer.freedesktop.org/
24Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.bz2
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Requires:       gstreamer >= %{_gst_ver}
28Requires:       glib2 >= %{_glib2_ver}
29Requires:       alsa-lib >= %{_alsa_lib_ver}
30Requires:       pango
31Requires:       gnome-vfs2
32Requires:       libogg >= %{_libogg_ver}
33Requires:       libvorbis, libtheora >= %{_libvorbis_ver}
34
35BuildRequires:  gstreamer-devel >= %{_gst_ver}
36BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
37BuildRequires:  python >= %{_python_ver}, python-pyxml
38BuildRequires:  glib2-devel >= %{_glib2_ver}
39BuildRequires:  check >= %{_check_ver}
40BuildRequires:  gtk2-devel >= %{_gtk2_ver}
41BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
42BuildRequires:  cdparanoia-devel
43BuildRequires:  gnome-vfs2-devel
44BuildRequires:  libogg-devel >= %{_libogg_ver}
45BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
46BuildRequires:  pango-devel
47BuildRequires:  freetype2-devel >= %{_freetype2_ver}
48BuildRequires:  fontconfig-devel
49BuildRequires:  libX11-devel
50BuildRequires:  libXv-devel
51BuildRequires:  libvisual-devel
52BuildRequires:  orc-devel
53BuildRequires:  libgudev1-devel
54BuildRequires:  gobject-introspection-devel
55
56Obsoletes:      %{name}-gnomevfs < 0.10.5
57Obsoletes:      %{name}-ogg < 0.10.5
58
59Vendor:         Project Vine
60Distribution:   Vine Linux
61Packager:       inagaki
62
63%description
64GStreamer is a streaming-media framework, based on graphs of filters which
65operate on media data. Applications using this library can do anything
66from real-time sound processing to playing videos, and just about anything
67else media-related.  Its plugin-based architecture means that new data
68types or processing capabilities can be added simply by installing new
69plugins.
70
71This package contains a set of well-maintained base plugins.
72
73%package devel
74Summary:        Libraries/include files for GStreamer base plugins
75Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
76Group:          Development/Libraries
77Requires:       %{name} = %{version}-%{release}
78Requires:       gstreamer-devel >= %{_gst_ver}
79
80%description devel
81GStreamer is a streaming-media framework, based on graphs of filters which
82operate on media data. Applications using this library can do anything
83from real-time sound processing to playing videos, and just about anything
84else media-related.  Its plugin-based architecture means that new data
85types or processing capabilities can be added simply by installing new
86plugins.
87
88This package contains GStreamer base plugins library depvelopment and header
89files.
90
91
92%prep
93%setup -q -n gst-plugins-base-%{version}
94
95%build
96%ifarch alpha
97%define optflags -O2 -mieee -fPIC
98%endif
99
100%configure \
101        --with-package-name='Vine Linux gstreamer-plugins-base package' \
102        --enable-gtk-doc \
103        --disable-static \
104        --disable-debug \
105        --enable-orc \
106        --with-gudev \
107        --enable-introspection=yes
108
109make %{?_smp_mflags}
110
111%install
112[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
113make install DESTDIR=$RPM_BUILD_ROOT
114
115# Clean out files that should not be part of the rpm.
116rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
118
119%find_lang %{po_package}
120
121%clean
122[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%files -f %{po_package}.lang
129%defattr(-,root,root)
130%doc AUTHORS ChangeLog COPYING* NEWS README RELEASE REQUIREMENTS
131
132# helper programs
133%{_bindir}/gst-*
134%{_mandir}/man1/gst-*
135
136# libraries
137%{_libdir}/libgst*-%{major}.so.*
138%{_libdir}/girepository-1.0/*.typelib
139
140# base plugins without external dependencies
141%{_libdir}/gstreamer-%{major}/libgstadder.so
142%{_libdir}/gstreamer-%{major}/libgstaudioconvert.so
143%{_libdir}/gstreamer-%{major}/libgstaudiorate.so
144%{_libdir}/gstreamer-%{major}/libgstaudioresample.so
145%{_libdir}/gstreamer-%{major}/libgstaudiotestsrc.so
146%{_libdir}/gstreamer-%{major}/libgstapp.so
147%{_libdir}/gstreamer-%{major}/libgstcdparanoia.so
148%{_libdir}/gstreamer-%{major}/libgstdecodebin.so
149%{_libdir}/gstreamer-%{major}/libgstdecodebin2.so
150%{_libdir}/gstreamer-%{major}/libgstencodebin.so
151%{_libdir}/gstreamer-%{major}/libgstffmpegcolorspace.so
152%{_libdir}/gstreamer-%{major}/libgstgdp.so
153%{_libdir}/gstreamer-%{major}/libgstgio.so
154%{_libdir}/gstreamer-%{major}/libgstplaybin.so
155#{_libdir}/gstreamer-%{major}/libgstqueue2.so
156%{_libdir}/gstreamer-%{major}/libgstsubparse.so
157%{_libdir}/gstreamer-%{major}/libgsttcp.so
158%{_libdir}/gstreamer-%{major}/libgsttypefindfunctions.so
159#{_libdir}/gstreamer-%{major}/libgsturidecodebin.so
160%{_libdir}/gstreamer-%{major}/libgstvideo4linux.so
161%{_libdir}/gstreamer-%{major}/libgstvideorate.so
162%{_libdir}/gstreamer-%{major}/libgstvideoscale.so
163%{_libdir}/gstreamer-%{major}/libgstvideotestsrc.so
164%{_libdir}/gstreamer-%{major}/libgstvolume.so
165%{_libdir}/gstreamer-%{major}/libgstximagesink.so
166%{_libdir}/gstreamer-%{major}/libgstxvimagesink.so
167
168# base plugins with external dependencies, but in the main package
169%{_libdir}/gstreamer-%{major}/libgstalsa.so
170%{_libdir}/gstreamer-%{major}/libgstpango.so
171%{_libdir}/gstreamer-%{major}/libgstgnomevfs.so
172%{_libdir}/gstreamer-%{major}/libgstlibvisual.so
173%{_libdir}/gstreamer-%{major}/libgstogg.so
174%{_libdir}/gstreamer-%{major}/libgsttheora.so
175%{_libdir}/gstreamer-%{major}/libgstvorbis.so
176
177%files devel
178%defattr(-,root,root)
179%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
180%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
181%{_datadir}/gir-1.0/*.gir
182%{_includedir}/gstreamer-%{major}/gst/*
183%{_libdir}/pkgconfig/*.pc
184%{_libdir}/libgst*-%{major}.so
185
186%changelog
187* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
188- new upstream release
189
190* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
191- new upstream release
192
193* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
194- new upstream release
195
196* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
197- new upstream release
198- change BuildRequires: gobject-introspection-devel instead of gir-repository-devel
199- add configure option (--enable-introspection=yes)
200
201* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
202- build with rpm-4.8.1-1 for pkg-config file
203- add BuildRequires: gir-repository-devel
204
205* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
206- new upstream release
207- added BR: orc-devel, libgudev1-devel
208- removed liboil dependency
209
210* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.29-1
211- new upstream release
212
213* Wed Mar 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
214- new upstream release
215
216* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
217- new upstream release
218- built with new toolchain
219
220* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
221- new upstream release
222
223* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
224- new upstream release
225
226* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
227- new upstream release
228- added BR: libvisual-devel
229- added Packager tag
230
231* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
232- new upstream release
233
234* Mon Dec 29 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.21-1
235- add configure option --enable-experimental to enable giosink
236
237* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1
238- new upstream release
239- spec in UTF-8
240
241* Sun Jun 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1
242- new upstream release
243- updated build dependancies
244
245* Tue Apr 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.19-2
246- build with xorg-x11-7.3
247  - remove XOrg/XOrg-devel deps
248  - add BuildRequires: libXv-devel, fontconfig-devel
249
250* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
251- new upstream release
252
253* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
254- new upstream release
255
256* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
257- new upstream release
258
259* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
260- new upstream release
261
262* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
263- new upstream release
264
265* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
266- new upstream release
267- update %%_gst_ver
268- add Vendor/Distribution tag
269- add '-with-package-name' option to %%configure
270- use more macros
271
272* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
273- new upstream release
274- update %%_gst_ver
275- update required version of liboil
276- add new plugin: libgstdecodebin2.so
277
278* Sat Nov 25 2006 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
279- new upstream release
280- update %%_gst_ver
281- changed Group to Applications/Multimedia
282
283* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
284- new upstream release
285- update %%_gst_ver
286
287* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
288- new upstream release
289- update %%_gst_ver
290
291* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.7-0vl1
292- new upstream release
293- update %%_gst_ver
294
295* Mon May  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.6-0vl1
296- new upstream release
297
298* Sun Mar 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl2
299- remove Obsoletes: gstreamer-plugins
300
301* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
302- new upstream release
303- update %%_gst_ver and liboil version
304- merge -gnomevfs,ogg into main package
305- add Obsoletes: %%{name}-gnomevfs, %%{name}-ogg < 0.10.5
306
307* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
308- new upstream release
309- update %%_gst_ver
310
311* Sun Jan 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl2
312- add Obsoletes: gstreamer-plugins < 0.9
313
314* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
315- initial package based on gstreamer-plugins
316- new upstream release
317  - change major to 0.10
318- update dependencies
319- update %%configure options
320- add subpackage: -gnomevfs, -ogg
321
322* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
323- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
324
325* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
326- added missing alsa plugin
327
328* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
329- new upstream release
330- added alsa and cairo plugins
331
332* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
333- new upstream release
334
335* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
336- new upstream release
337
338* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
339- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
340
341* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
342- added libgstcdparania.so for gnome-cd (gnome-media)
343- BuildRequires: cdparanoia-devel
344
345* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
346- drop BuildRequires: xmms-devel, Requires: xmms
347
348* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
349- libgstvideo4linux2.so temoporally omitted for ppc
350  (will be back later, I hope)
351
352* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
353- new upstream release
354- s/Copyright/License/
355- includes plugins depend on main package libraries only
356
357* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
358- new upstream release
359
360* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
361- new upstream release
362
363* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
364- new upstream release
365
366* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
367- new upstream release
368
369* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
370- build with -fPIC on alpha
371
372* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
373- modified scripts
374
375* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
376- new upstream release
377
378* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
379- disable some plugins.
380
381* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
382- new upstream release
383- initial build for Vine Linux
384
385* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
386- Include ia64
387- Add BuildRequires: autoconf automake
388
389* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
390- rebuild
391
392* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
393- rebuild
394
395* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
396- rebuild
397- disable tests
398
399* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
400- rebuild
401
402* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
403- fix libdir for ia64.
404
405* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
406- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
407- Add devel package
408
409* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
410- 0.5.0
411- apparently, festival-devel isn't needed.
412
413* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
414- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
415
416* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
417- excludearch the arches that can't build gstreamer cothreads
418- well it isn't really SMP-safe
419- add patch for including pthread.h when required
420- prereq gconftool
421- fix typo that broke schema installation in post
422
423* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
424- initial "official" import
425- munge tarball for legal cleanliness
426
427* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
428- 0.4.2
429
430* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
431- 0.4.1
432- install the gconf schema
433- use %%configure
434
435* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
436- update to 0.4.0
437- give explicit vorbis include path, don't run vorbis test
438
439* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
440- collapse into one package to preserve some sanity
441
442* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
443- added more BuildRequires and Requires
444- rearranged some plugins
445- added changelog ;)
Note: See TracBrowser for help on using the repository browser.