source: projects/specs/trunk/g/gsm/gsm-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Shared libraries for GSM speech compressor
2
3Name:           gsm
4Version:        1.0.12
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        MIT
9URL:            http://kbs.cs.tu-berlin.de/~jutta/toast.html
10Source:         http://kbs.cs.tu-berlin.de/~jutta/gsm/%{name}-%{version}.tar.gz
11Patch0:         %{name}-makefile.patch
12Patch1:         %{name}-warnings.patch
13Patch2:         %{name}-64bit.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16%define srcver 1.0-pl12
17
18%description
19Contains runtime shared libraries for libgsm, an implementation of
20the European GSM 06.10 provisional standard for full-rate speech
21transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
22excitation/long term prediction) coding at 13 kbit/s.
23
24GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
25rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
26with typical UNIX applications, our implementation turns frames of 160
2716-bit linear samples into 33-byte frames (1650 Bytes/s).
28The quality of the algorithm is good enough for reliable speaker
29recognition; even music often survives transcoding in recognizable
30form (given the bandwidth limitations of 8 kHz sampling rate).
31
32The interfaces offered are a front end modelled after compress(1), and
33a library API.  Compression and decompression run faster than realtime
34on most SPARCstations.  The implementation has been verified against the
35ETSI standard test patterns.
36
37%package        tools
38Summary:        GSM speech compressor tools
39Group:          Applications/Multimedia
40
41%description    tools
42Contains command line utilities for libgsm, an implementation of
43the European GSM 06.10 provisional standard for full-rate speech
44transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
45excitation/long term prediction) coding at 13 kbit/s.
46
47%package        devel
48Summary:        Header files and development libraries for libgsm
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51
52%description    devel
53Contains header files and development libraries for libgsm, an
54implementation of the European GSM 06.10 provisional standard for
55full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
56(residual pulse excitation/long term prediction) coding at 13 kbit/s.
57
58%prep
59%setup -n gsm-%{srcver} -q
60%patch0 -p1 -b .mk
61%patch1 -p1 -b .warn
62%patch2 -p1 -b .64bit
63
64%build
65export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
66make %{?_smp_mflags} all
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71mkdir -p $RPM_BUILD_ROOT%{_bindir}
72mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
73mkdir -p $RPM_BUILD_ROOT%{_libdir}
74mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
75
76make install \
77        INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
78        GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
79        GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
80
81cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}
82ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
83ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
84
85# some apps look for this in /usr/include
86ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
87
88rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
89
90
91%check
92# This is to ensure that the patch creates the proper library version.
93[ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{version} ]
94make addtst
95
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(-,root,root,-)
106%doc ChangeLog COPYRIGHT MACHINES README
107%{_libdir}/libgsm.so.*
108
109%files tools
110%{_bindir}/tcat
111%{_bindir}/toast
112%{_bindir}/untoast
113%{_mandir}/man1/toast.1*
114
115%files devel
116%defattr(-,root,root,-)
117%dir %{_includedir}/gsm
118%{_includedir}/gsm/gsm.h
119%{_includedir}/gsm.h
120%{_libdir}/libgsm.so
121%{_mandir}/man3/*
122
123%changelog
124* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
125- initial build for Vine Linux
126
127* Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
128- Rebuild for GCC 4.3
129
130* Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
131- install symlinks instead of binaries in -devel
132
133* Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
134- rebuild for BuildID
135- specfile cleanups
136
137* Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
138- fix parallel make
139
140* Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
141- fix some warnings
142- fix 64bit testsuite issue as described at gsm homepage
143- add compatibility header symlink
144- split off binaries into a separate package
145
146* Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
147- Update to Release 1.0 Patchlevel 12.
148- Build with -fPIC not just for non-ix86.
149- Add check section to ensure proper library version.
150- Remove static library.
151
152* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
153- rebuilt for unwind info generation, broken in gcc-4.1.1-21
154
155* Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
156- 1.0.10-11
157- rebuild for FC6
158
159* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
160- switch to new release field
161
162* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
163- add dist
164
165* Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
166- 1.0.10-0.lvn.10: Clean up installation
167
168* Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
169- 1.0.10-0.lvn.9: mv libgsm.a only when needed
170
171* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
172- 1.0.10-0.lvn.8: Use -fPIC on non ix86
173
174* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
175- 1.0.10-0.lvn.7: moved to rpm.livna.org
176
177* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
178- 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
179
180* Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
181- 0:1.0.10-0.fdr.6: remove second makeinstall
182
183* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
184- 0:1.0.10-0.fdr.5
185- added back epochs, I surrender
186- fix RPM_OPT_FLAGS hackery
187
188* Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
189- 1.0.10-0.fdr.4: remove epoch mentions
190
191* Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
192- 1.0.10-0.fdr.3
193- pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
194- fix group
195- -p'ize ldconfig
196
197* Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
198- 1.0.10-0.fdr.2
199- Fix libgsm.so.* being files instead of symlinks
200
201* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
202- 0:1.0.10-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.