source: projects/specs/trunk/g/grub/grub-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%ifarch %{ix86}
2%define _host_cpu i386
3%else
4%define _host_cpu %{_arch}
5%endif
6
7%define defshell defaultmenu.sh
8
9Summary: grub - a Multiboot boot loader.
10Summary(ja): grub - マルチブートローダ
11Name: grub
12Version: 0.97
13Release: 2%{?_dist_release}
14License: GPL
15Group: System Environment/Base
16URL: http://www.gnu.org/software/grub/
17
18Source0: ftp://alpha.gnu.org/gnu/grub/%{name}-%{version}.tar.gz
19Source1: %{defshell}
20
21Patch10: grub-0.97-prototypes.patch
22Patch100: ext3_256byte_inode.diff
23
24ExclusiveArch: %{ix86} x86_64
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26PreReq: install-info, sed, grep
27Requires: mktemp
28BuildRequires: ncurses-devel
29%ifarch x86_64
30BuildRequires: compat32-glibc-devel
31%endif
32
33%description
34GNU GRUB is a Multiboot boot loader.
35It was derived from GRUB, GRand Unified Bootloader, which was
36originally designed and implemented by Erich Stefan Boleyn.
37
38Briefly, bootloader is the first software program that runs when
39a computer starts. It is responsible for loading and transferring
40control to the operating system kernel software (such as the Hurd
41or the Linux). The kernel, in turn, initializes the rest of the
42operating system (usually GNU).
43
44%description -l ja
45GNU GRUB はマルチブートローダです。
46この名前は GRand Unified Bootloader (壮大な 統一されたブート
47ローダ) に由来し、元来は Erich Stefan Boleyn によって、設計・
48実装されたものです。
49
50手短に言えば、ブートローダとはコンピュータが起動する際に最初
51に実行されるプログラムで、(Hurd や Linux のような) オペレー
52ティングシステムのカーネルをディスクから読み込んで制御を渡す
53作業を担当します。カーネルは、それを受けて、オペレーティング
54システムの他の部分 (通常は GNU) を初期化します。
55
56%prep
57%setup -q
58%patch10 -p1 -b .prototypes
59%patch100 -p1 -b .ext3_256byte_inode
60
61%build
62GCCVERS=$(gcc --version | head -1 | cut -d\  -f3 | cut -d. -f1)
63CFLAGS="-Os"
64if [ "$GCCVERS" == "4" ]; then
65  CFLAGS="$CFLAGS -Wno-pointer-sign"
66fi
67%ifarch x86_64
68CFLAGS="$CFLAGS -static"
69%endif
70export CFLAGS
71%configure --disable-auto-linux-mem-opt
72%__make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76%makeinstall
77%{__install} -p -m 644 docs/menu.lst %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
78%{__install} -p -m 744 %{SOURCE1} %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post
84/sbin/install-info %{_infodir}/grub.info.gz %{_infodir}/dir
85/sbin/install-info %{_infodir}/multiboot.info.gz %{_infodir}/dir
86%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}/%{defshell}
87
88%preun
89if [ $1 = 0 ]; then
90        /sbin/install-info --delete %{_infodir}/grub.info.gz %{_infodir}/dir
91        /sbin/install-info --delete %{_infodir}/multiboot.info.gz %{_infodir}/dir
92fi
93
94%files
95%defattr(-,root,root)
96%doc COPYING INSTALL README AUTHORS BUGS ChangeLog NEWS THANKS TODO MAINTENANCE
97%{_bindir}/*
98%{_sbindir}/*
99%{_libdir}/grub
100%{_infodir}/*.info*
101%{_mandir}/man*/*
102
103%changelog
104* Wed Jan 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-2
105- add patch100 to support newer e2fsprogs
106
107* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.97-1vl5
108- applied new versioning policy, spec in utf-8
109
110* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl8
111- fix _host_cpu trick
112
113* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl7
114- add x86_64 to ExclusiveArch:
115- add BuildRequires: compat32-glibc-devel for x86_64
116- add "-static" to CFLAGS for x86_64
117- use special CFLAGS
118- add Patch10 to run configure with new binutils
119
120* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl6
121- add PreReq: grep, sed for defaultmenu.sh
122
123* Tue Sep 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl5
124- add initrd in menu.lst file created by defaultmenu.sh
125
126* Thu Jun 26 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl4
127- fix date of previous changelog entry
128- escape macro of past changelog entries
129- change Source1: menu.lst.vine to defautmenu.sh
130- invoke defaultmenu.sh on %%post scriptlet
131
132* Thu Jun 21 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl3
133- remove Requires: ncurses, gpm, bash
134
135* Thu May 12 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl2
136- upstream release
137- add MAINTENANCE to %%doc
138- drop Patch0 (merged in upstream source)
139
140* Sun Mar 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl3
141- savedefault patch from upstream CVS: http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/stage2/stage2.c.diff?r1=1.45&r2=1.46&diff_format=u
142  stage2/stage2.c (cmain): Initialize DEFAULT_FILE to an empty
143  string. Reported by NATORI Shin <natori@adm.s.u-tokyo.ac.jp>.
144
145* Sun Feb 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl2
146- upstream release
147- drop Patch0 (merged)
148- added sample file /usr/lib/grub/i386-pc/menu.lst.vine
149- change installation destination of menu.lst from %%datadir to %%libdir
150
151* Wed Jan 19 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl3
152- applied Patch0 from upstream CVS:
153  http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/util/grub-install.in.diff?r1=1.46&r2=1.47&diff_format=u
154  util/grub-install.in (convert): Fix the sed statement for
155  Linux. The expression was ambigious in some cases.
156
157* Wed Aug 18 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl2
158- catch up to upstream release
159- delete %%_target_platform macro
160- delete gzip info files from %%install macro
161- add BuildRequires: ncurses-devel
162- add Requires: ncurses, gpm, mktemp, bash
163- add PreReq: install-info
164- %%configure with --disable-auto-linux-mem-opt option
165
166* Thu Jul 12 2001 <sagami@vinelinux.org>
167- 0.90-0vl1: %%configure with a trick for _host_cpu, %%makeinstall
168
169* Tue Apr 24 2001 <sagami@vinelinux.org>
170- 0.5.96-0vl1: use some macros
171
172* Wed Oct 11 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl2]
173- build for Vine 2.1beta
174
175* Tue Oct 10 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl1]
176- update to 0.5.95 and build for Vine 2.0
177- add Japanese summary and description
178- based on grub-0.5.94-2, Kondara Zoo
179
180* Sun Jun  4 2000 AYUHANA Tomonori <l@kondara.org>
181* /usr/doc/grub-*/menu.lst -> /usr/share/grub/i386-pc/menu.lst
182
183* Thu May 18 2000 AYUHANA Tomonori <l@kondara.org>
184- upgrade to 0.5.93.1 to 0.5.94
Note: See TracBrowser for help on using the repository browser.