source: projects/specs/trunk/g/grub/grub-vl.spec @ 3083

Revision 3083, 6.7 KB checked in by daisuke, 13 years ago (diff)

grub:

  • add Patch110 to support ext4 filesystem
  • add Patch120 to build with current binutils
  • add Patch130 to build with ncurses-5.6
  • add R(post): install-info, grep, sed, coreutils
  • add R(preun): install-info
  • add BR: compat32-glibc-{devel,static} for x86_64
  • add BR: glibc-static
Line 
1%ifarch %{ix86}
2%define _host_cpu i386
3%else
4%define _host_cpu %{_arch}
5%endif
6
7%define defshell defaultmenu.sh
8
9Summary: grub - a Multiboot boot loader.
10Summary(ja): grub - マルチブートローダ
11Name: grub
12Version: 0.97
13Release: 3%{?_dist_release}
14License: GPL
15Group: System Environment/Base
16URL: http://www.gnu.org/software/grub/
17
18Source0: ftp://alpha.gnu.org/gnu/grub/%{name}-%{version}.tar.gz
19Source1: %{defshell}
20
21Patch10: grub-0.97-prototypes.patch
22Patch100: ext3_256byte_inode.diff
23Patch110: grub-0.97-ext4-support.patch
24Patch120: grub-0.97-build-id=none.patch
25Patch130: grub-0.97-tinfo.patch
26
27ExclusiveArch: %{ix86} x86_64
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29Requires(post): install-info, sed, grep, coreutils
30Requires(preun): install-info
31Requires: mktemp
32BuildRequires: ncurses-devel >= 5.6
33BuildRequires: glibc-static
34%ifarch x86_64
35BuildRequires: compat32-glibc-devel
36BuildRequires: compat32-glibc-static
37%endif
38
39%description
40GNU GRUB is a Multiboot boot loader.
41It was derived from GRUB, GRand Unified Bootloader, which was
42originally designed and implemented by Erich Stefan Boleyn.
43
44Briefly, bootloader is the first software program that runs when
45a computer starts. It is responsible for loading and transferring
46control to the operating system kernel software (such as the Hurd
47or the Linux). The kernel, in turn, initializes the rest of the
48operating system (usually GNU).
49
50%description -l ja
51GNU GRUB はマルチブートローダです。
52この名前は GRand Unified Bootloader (壮大な 統一されたブート
53ローダ) に由来し、元来は Erich Stefan Boleyn によって、設計・
54実装されたものです。
55
56手短に言えば、ブートローダとはコンピュータが起動する際に最初
57に実行されるプログラムで、(Hurd や Linux のような) オペレー
58ティングシステムのカーネルをディスクから読み込んで制御を渡す
59作業を担当します。カーネルは、それを受けて、オペレーティング
60システムの他の部分 (通常は GNU) を初期化します。
61
62%prep
63%setup -q
64%patch10 -p1 -b .prototypes
65%patch100 -p1 -b .ext3_256byte_inode
66%patch110 -p1 -b .ext4
67%patch120 -p1 -b .build-id
68%patch130 -p1 -b .ncurses5
69aclocal
70autoconf
71
72%build
73GCCVERS=$(gcc --version | head -1 | cut -d\  -f3 | cut -d. -f1)
74CFLAGS="-Os"
75if [ "$GCCVERS" == "4" ]; then
76  CFLAGS="$CFLAGS -Wno-pointer-sign"
77fi
78%ifarch x86_64
79CFLAGS="$CFLAGS -static"
80%endif
81export CFLAGS
82%configure --disable-auto-linux-mem-opt
83%__make
84
85%install
86rm -rf $RPM_BUILD_ROOT
87%makeinstall
88%{__install} -p -m 644 docs/menu.lst %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
89%{__install} -p -m 744 %{SOURCE1} %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post
95/sbin/install-info %{_infodir}/grub.info.gz %{_infodir}/dir
96/sbin/install-info %{_infodir}/multiboot.info.gz %{_infodir}/dir
97%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}/%{defshell}
98
99%preun
100if [ $1 = 0 ]; then
101        /sbin/install-info --delete %{_infodir}/grub.info.gz %{_infodir}/dir
102        /sbin/install-info --delete %{_infodir}/multiboot.info.gz %{_infodir}/dir
103fi
104
105%files
106%defattr(-,root,root)
107%doc COPYING INSTALL README AUTHORS BUGS ChangeLog NEWS THANKS TODO MAINTENANCE
108%{_bindir}/*
109%{_sbindir}/*
110%{_libdir}/grub
111%{_infodir}/*.info*
112%{_mandir}/man*/*
113
114%changelog
115* Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-3
116- add Patch110 to support ext4 filesystem
117- add Patch120 to build with current binutils
118- add Patch130 to build with ncurses-5.6
119- add R(post): install-info, grep, sed, coreutils
120- add R(preun): install-info
121- add BR: compat32-glibc-{devel,static} for x86_64
122- add BR: glibc-static
123
124* Wed Jan 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-2
125- add patch100 to support newer e2fsprogs
126
127* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.97-1vl5
128- applied new versioning policy, spec in utf-8
129
130* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl8
131- fix _host_cpu trick
132
133* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl7
134- add x86_64 to ExclusiveArch:
135- add BuildRequires: compat32-glibc-devel for x86_64
136- add "-static" to CFLAGS for x86_64
137- use special CFLAGS
138- add Patch10 to run configure with new binutils
139
140* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl6
141- add PreReq: grep, sed for defaultmenu.sh
142
143* Tue Sep 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl5
144- add initrd in menu.lst file created by defaultmenu.sh
145
146* Thu Jun 26 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl4
147- fix date of previous changelog entry
148- escape macro of past changelog entries
149- change Source1: menu.lst.vine to defautmenu.sh
150- invoke defaultmenu.sh on %%post scriptlet
151
152* Thu Jun 21 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl3
153- remove Requires: ncurses, gpm, bash
154
155* Thu May 12 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl2
156- upstream release
157- add MAINTENANCE to %%doc
158- drop Patch0 (merged in upstream source)
159
160* Sun Mar 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl3
161- savedefault patch from upstream CVS: http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/stage2/stage2.c.diff?r1=1.45&r2=1.46&diff_format=u
162  stage2/stage2.c (cmain): Initialize DEFAULT_FILE to an empty
163  string. Reported by NATORI Shin <natori@adm.s.u-tokyo.ac.jp>.
164
165* Sun Feb 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl2
166- upstream release
167- drop Patch0 (merged)
168- added sample file /usr/lib/grub/i386-pc/menu.lst.vine
169- change installation destination of menu.lst from %%datadir to %%libdir
170
171* Wed Jan 19 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl3
172- applied Patch0 from upstream CVS:
173  http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/util/grub-install.in.diff?r1=1.46&r2=1.47&diff_format=u
174  util/grub-install.in (convert): Fix the sed statement for
175  Linux. The expression was ambigious in some cases.
176
177* Wed Aug 18 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl2
178- catch up to upstream release
179- delete %%_target_platform macro
180- delete gzip info files from %%install macro
181- add BuildRequires: ncurses-devel
182- add Requires: ncurses, gpm, mktemp, bash
183- add PreReq: install-info
184- %%configure with --disable-auto-linux-mem-opt option
185
186* Thu Jul 12 2001 <sagami@vinelinux.org>
187- 0.90-0vl1: %%configure with a trick for _host_cpu, %%makeinstall
188
189* Tue Apr 24 2001 <sagami@vinelinux.org>
190- 0.5.96-0vl1: use some macros
191
192* Wed Oct 11 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl2]
193- build for Vine 2.1beta
194
195* Tue Oct 10 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl1]
196- update to 0.5.95 and build for Vine 2.0
197- add Japanese summary and description
198- based on grub-0.5.94-2, Kondara Zoo
199
200* Sun Jun  4 2000 AYUHANA Tomonori <l@kondara.org>
201* /usr/doc/grub-*/menu.lst -> /usr/share/grub/i386-pc/menu.lst
202
203* Thu May 18 2000 AYUHANA Tomonori <l@kondara.org>
204- upgrade to 0.5.93.1 to 0.5.94
Note: See TracBrowser for help on using the repository browser.