source: projects/specs/trunk/g/groff/groff-vl.spec @ 521

Revision 521, 9.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver 1.18.1
2
3Summary: A document formatting system.
4Summary(ja): GNU groff 日本語対応版
5Name: groff
6Version: 1.18.1.1
7Release: 3%{?_dist_release}
8License: GPL
9Group: Applications/Publishing
10
11Vendor: Project Vine
12Distribution: Vine Linux
13
14Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
15Source1: troff-to-ps.fpi
16Source2: groff-tmac-ja.tar.gz
17# Japanese Patch from Debian
18Patch1: groff_1.18.1.1-20.diff.gz
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: libX11-devel, libICE-devel, libSM-devel, libXext-devel
22BuildRequires: libXmu-devel, libXpm-devel, libXt-devel
23BuildRequires: libXaw-devel >= 1.0.5
24Requires(post,preun): install-info
25Obsoletes: groff-tools
26
27
28%description
29Groff is a document formatting system.  Groff takes standard text and
30formatting commands as input and produces formatted output.  The
31created documents can be shown on a display or printed on a printer.
32Groff's formatting commands allow you to specify font type and size, bold
33type, italic type, the number and size of columns on a page, and more.
34
35You should install groff if you want to use it as a document formatting
36system.  Groff can also be used to format man pages. If you are going
37to use groff with the X Window System, you'll also need to install the
38groff-gxditview package.
39
40%description -l ja
41GNU roff (groff) 日本語対応版です。日本語で書かれたマニュアルを表示す
42るのに必要です.
43
44
45%package perl
46Summary: Parts of the groff formatting system that require Perl.
47Group: Applications/Publishing
48Requires: %{name} = %{version}
49Requires: mktemp
50
51%description perl
52The groff-perl package contains the parts of the groff text processor
53package that require Perl. These include the afmtodit font processor
54for creating PostScript font files, the grog utility that can be used
55to automatically determine groff command-line options, and the
56troff-to-ps print filter.
57
58
59%package gxditview
60Summary: An X previewer for groff text processor output.
61Group: Applications/Publishing
62Requires: %{name} = %{version}
63
64%description gxditview
65Gxditview displays the groff text processor's output on an X Window
66System display.
67
68If you are going to use groff as a text processor, you should install
69gxditview so that you preview your processed text files in X.  You'll also
70need to install the groff package and the X Window System.
71
72
73%prep
74%setup -q -n groff-%{version}
75%patch1 -p1 -b .debian
76
77
78%build
79PATH=$PATH:/usr/X11R6/bin
80#autoconf
81#configure --enable-japanese
82%configure --enable-multibyte
83make
84
85cd src/xditview
86xmkmf
87make
88cd ../..
89
90
91%install
92[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
93PATH=$PATH:/usr/X11R6/bin
94mkdir -p $RPM_BUILD_ROOT%{_prefix}
95mkdir -p $RPM_BUILD_ROOT%{_mandir}
96%makeinstall manroot=$RPM_BUILD_ROOT%{_mandir}
97
98# install xditview
99cd src/xditview
100make install DESTDIR=$RPM_BUILD_ROOT
101cd ../..
102
103# for groff-ja
104#mkdir -p $RPM_BUILD_ROOT%{_datadir}/groff/%{ver}
105#tar xzf %{SOURCE2} -C $RPM_BUILD_ROOT%{_datadir}/groff/%{ver}
106
107ln -s s.tmac    $RPM_BUILD_ROOT%{_datadir}/groff/%{ver}/tmac/tmac.gs
108ln -s mse.tmac  $RPM_BUILD_ROOT%{_datadir}/groff/%{ver}/tmac/tmac.gmse
109ln -s m.tmac    $RPM_BUILD_ROOT%{_datadir}/groff/%{ver}/tmac/tmac.gm
110ln -s troff     $RPM_BUILD_ROOT%{_bindir}/gtroff
111ln -s tbl       $RPM_BUILD_ROOT%{_bindir}/gtbl
112ln -s pic       $RPM_BUILD_ROOT%{_bindir}/gpic
113ln -s eqn       $RPM_BUILD_ROOT%{_bindir}/geqn
114ln -s neqn      $RPM_BUILD_ROOT%{_bindir}/gneqn
115ln -s refer     $RPM_BUILD_ROOT%{_bindir}/grefer
116ln -s lookbib   $RPM_BUILD_ROOT%{_bindir}/glookbib
117ln -s indxbib   $RPM_BUILD_ROOT%{_bindir}/gindxbib
118ln -s soelim    $RPM_BUILD_ROOT%{_bindir}/gsoelim
119ln -s soelim    $RPM_BUILD_ROOT%{_bindir}/zsoelim
120ln -s nroff     $RPM_BUILD_ROOT%{_bindir}/gnroff
121
122# whether or not build system is compressing man-pages
123ln -s eqn.1     %{buildroot}%{_mandir}/man1/geqn.1
124ln -s indxbib.1 %{buildroot}%{_mandir}/man1/gindxbib.1
125ln -s lookbib.1 %{buildroot}%{_mandir}/man1/glookbib.1
126ln -s neqn.1    %{buildroot}%{_mandir}/man1/gneqn.1
127ln -s nroff.1   %{buildroot}%{_mandir}/man1/gnroff.1
128ln -s pic.1     %{buildroot}%{_mandir}/man1/gpic.1
129ln -s refer.1   %{buildroot}%{_mandir}/man1/grefer.1
130ln -s soelim.1  %{buildroot}%{_mandir}/man1/gsoelim.1
131ln -s soelim.1  %{buildroot}%{_mandir}/man1/zsoelim.1
132ln -s tbl.1     %{buildroot}%{_mandir}/man1/gtbl.1
133ln -s troff.1   %{buildroot}%{_mandir}/man1/gtroff.1
134
135mkdir -p $RPM_BUILD_ROOT%{_libdir}/rhs/rhs-printfilters
136install -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_libdir}/rhs/rhs-printfilters
137
138# document files
139mkdir -p docs-to-install
140cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/%{name}/%{ver}/* docs-to-install
141rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/%{name}
142
143#
144rm -f $RPM_BUILD_ROOT%{_infodir}/dir
145rm -rf $RPM_BUILD_ROOT/%{_prefix}/lib/X11/app-defaults
146
147%clean
148[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
149
150%post
151/sbin/install-info --info-dir=%{_infodir} %{_infodir}/groff.gz
152
153%preun
154if [ "$1" = 0 ]; then
155    /sbin/install-info --delete \
156        --info-dir=%{_infodir} %{_infodir}/groff.gz
157fi
158
159
160# -f groff-files
161%files
162%defattr(-,root,root)
163%doc BUG-REPORT COPYING ChangeLog NEWS PROBLEMS README TODO
164%doc README.jp ChangeLog.jp docs-to-install/*
165%{_bindir}/*
166%exclude %{_bindir}/gxditview
167%{_datadir}/groff
168%{_libdir}/rhs/*/*
169%{_mandir}/man?/*
170%{_infodir}/*
171%exclude %{_bindir}/afmtodit
172%exclude %{_bindir}/grog
173%exclude %{_bindir}/mmroff
174%exclude %{_mandir}/man1/afmtodit.*
175%exclude %{_mandir}/man1/grog.*
176%exclude %{_mandir}/man1/mmroff.*
177
178
179%files perl
180%defattr(-,root,root)
181%{_bindir}/afmtodit
182%{_bindir}/grog
183%{_bindir}/mmroff
184%{_mandir}/man1/afmtodit.*
185%{_mandir}/man1/grog.*
186%{_mandir}/man1/mmroff.*
187
188
189%files gxditview
190%defattr(-,root,root)
191%{_bindir}/gxditview
192%config %{_sysconfdir}/X11/app-defaults/GXditview
193
194
195%changelog
196* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-3
197- remove gxditview from main package
198
199* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-2
200- rebuild with libXaw.so.7 (libXaw-1.0.5)
201
202* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-1
203- rebuild with new versioning policy
204- update Debian patch
205
206* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.1.1-0vl1
207- rebuilt with new toolchain
208- updated source and Japanese patch based on Debian
209- added BuildRequires: XOrg-devel
210
211* Fri Sep 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.2-0vl7
212- rebuild to add gpg sign
213
214* Tue Apr  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.17.2-0vl6
215- rebuild
216
217* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.17.2-0vl5
218- rebuilt with new toolchain
219
220* Wed Mar 06 2002 Toru Sagami <sagami@vinelinux.org> 1.17.2-0vl4
221- corrected zsoelim.1 symlink in %%{_mandir}
222
223* Mon Feb 11 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl3
224- fixed symlink of *.tmac
225
226* Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl2
227- build on VineSeed
228
229* Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl1
230- updated groff-1.17.2
231    -- security fixed of CAN-2002-0003
232    -- changed japanese patch to debian patch
233    -- modified spec file
234
235* Mon Sep 10 2001 Toru Sagami <sagami@vinelinux.org>
236- 1.16.1-0vl1: split perl components into separate subpackage
237
238* Tue Jul 17 2001 <sagami@vinelinux.org>
239- 1.16.1: version up to 1.16.1
240- add groff-1.16.1-japanese.patch originally taken from Kondara
241- use %%configure after autoconf, %%makeinstall
242
243* Tue Jan 23 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
244- 1.15_jp-7
245- built on egcs-1.1/libstdc++2_9-2.9.0
246- fixed: whether or not build system compress man pages
247
248* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 1.15_jp-6
249- some fixes to handle man pages correctly
250
251* Sat Nov 11 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.15_jp-5
252- build on gcc-2.95.3
253- partially used macros
254
255* Mon Aug  7 2000 Jun Nishii <jun@vinelinux.org>
256- 1.15_jp-4
257- follow up to RHL62 (1.15-8)
258
259* Thu Feb 24 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
260- 1.15_jp-3
261- modified ja patch, namely lib.h
262
263* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
264- groff-tmac-ja was lacked in Source entry(;_;) fixed!
265
266* Tue Jan  4 2000 Jun Nishii <jun@vinelinux.org>
267- build for Vine Linux 2.0 with ja patch
268
269* Wed Dec 29 1999 Bill Nottingham <notting@redhat.com>
270- update to 1.15
271
272* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
273- auto rebuild in the new build environment (release 9)
274
275* Tue Feb 16 1999 Cristian Gafton <gafton@redhat.com>
276- glibc 2.1 patch for xditview (#992)
277
278* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
279- build for Raw Hide
280
281* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
282- fix makefiles to work with bash2
283
284* Fri May 08 1998 Prospector System <bugs@redhat.com>
285- translations modified for de, fr, tr
286
287* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
288- use g++ for C++ code
289
290* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
291- manhattan and buildroot
292
293* Mon Nov  3 1997 Michael Fulbright <msf@redhat.com>
294- made xdefaults file a config file
295
296* Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
297- split perl components into separate subpackage
298
299* Tue Oct 21 1997 Michael Fulbright <msf@redhat.com>
300- updated to 1.11a
301- added safe troff-to-ps.fpi
302
303* Tue Oct 14 1997 Michael Fulbright <msf@redhat.com>
304- removed troff-to-ps.fpi for security reasons.
305
306* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
307- built against glibc
308
Note: See TracBrowser for help on using the repository browser.