source: projects/specs/trunk/g/groff/groff-vl.spec @ 12092

Revision 12092, 11.2 KB checked in by tomop, 5 years ago (diff)

groff-1.22.4-1

Line 
1# clean old caches when groff =< %{cache_clean_ver}
2# is uninstalled.
3%define cache_clean_ver 1.18.1.1-4%{?_dist_release}
4
5%global _pkgdocdir %{_docdir}/%{name}-%{version}
6%global __requires_exclude perl\\(.*\\.pl\\)$
7
8Summary: A document formatting system.
9Summary(ja): GNU groff 日本語対応版
10Name: groff
11Version: 1.22.4
12Release: 1%{?_dist_release}
13License: GPL
14Group: Applications/Publishing
15URL: http://groff.ffii.org
16
17Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
18
19# resolves: #530788
20Patch0: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch
21Patch1: 0002-load-site-font-and-site-tmac-from-etc-groff.patch
22# resolves: #987069
23Patch3: 0004-don-t-use-usr-bin-env-in-shebang.patch
24
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: libX11-devel, libICE-devel, libSM-devel, libXext-devel
27BuildRequires: libXmu-devel, libXpm-devel, libXt-devel
28BuildRequires: libXaw-devel >= 1.0.5
29BuildRequires: psutils, byacc, imake, netpbm-progs, ghostscript
30BuildRequires: texinfo
31Requires(post): install-info
32Requires(preun): install-info
33Requires(postun): findutils
34Obsoletes: groff-tools
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: daisuke
39
40%description
41Groff is a document formatting system.  Groff takes standard text and
42formatting commands as input and produces formatted output.  The
43created documents can be shown on a display or printed on a printer.
44Groff's formatting commands allow you to specify font type and size, bold
45type, italic type, the number and size of columns on a page, and more.
46
47You should install groff if you want to use it as a document formatting
48system.  Groff can also be used to format man pages. If you are going
49to use groff with the X Window System, you'll also need to install the
50groff-gxditview package.
51
52%description -l ja
53GNU roff (groff) 日本語対応版です。日本語で書かれたマニュアルを表示す
54るのに必要です.
55
56
57%package perl
58Summary: Parts of the groff formatting system that require Perl.
59Group: Applications/Publishing
60Requires: %{name} = %{version}
61Requires: mktemp
62
63%description perl
64The groff-perl package contains the parts of the groff text processor
65package that require Perl. These include the afmtodit font processor
66for creating PostScript font files, the grog utility that can be used
67to automatically determine groff command-line options, and the
68troff-to-ps print filter.
69
70
71%package gxditview
72Summary: An X previewer for groff text processor output.
73Group: Applications/Publishing
74Requires: %{name} = %{version}
75
76%description gxditview
77Gxditview displays the groff text processor's output on an X Window
78System display.
79
80If you are going to use groff as a text processor, you should install
81gxditview so that you preview your processed text files in X.  You'll also
82need to install the groff package and the X Window System.
83
84
85%prep
86%setup -q
87
88%patch0 -p1
89%patch1 -p1
90%patch3 -p1
91
92for file in NEWS src/devices/grolbp/grolbp.1.man doc/{groff.texi*,webpage.ms} \
93            contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom}
94do
95    iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
96    mv "${file}_" "$file"
97done
98
99
100%build
101export PAGE=A4
102export YACC='bison -y'
103%configure \
104        --with-appresdir=%{_datadir}/X11/app-defaults \
105        --with-grofferdir=%{_datadir}/%{name}/%{version}/groffer
106
107make %{?_smp_mflags}
108
109%install
110[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
111
112%{__make} install DESTDIR=%{buildroot} \
113                  docdir=%{_docdir}/%{name}-%{version}
114
115# some binaries need alias with 'g' or 'z' prefix
116
117for file in g{nroff,troff,tbl,pic,eqn,neqn,refer,lookbib,indxbib,soelim} ; do
118        ln -s ${file#?} %{buildroot}%{_bindir}/${file}
119        ln -s ${file#?}.1.gz %{buildroot}%{_mandir}/man1/${file}.1.gz
120done
121
122# fix absolute symlink to relative symlink
123rm -f %{buildroot}%{_pkgdocdir}/pdf/mom-pdf.pdf
124ln -s ../examples/mom/mom-pdf.pdf %{buildroot}%{_pkgdocdir}/pdf/mom-pdf.pdf
125
126# rename groff downloadable postscript fonts to meet Fedora Font Packaging guidelines,
127# as these files are more PS instructions, than general-purpose fonts (bz #477394)
128for file in $(find %{buildroot}%{_datadir}/%{name}/%{version}/font/devps -name "*.pfa"); do
129    mv ${file} ${file}_
130done
131sed --in-place 's/\.pfa$/.pfa_/' %{buildroot}%{_datadir}/%{name}/%{version}/font/devps/download
132
133
134# perl dependent files in /usr/bin will be in separate package
135
136rm -f files-perl files-nonperl
137for file in %{buildroot}%{_bindir}/*; do
138        # package selection
139        if grep -q -m1 '^#!.*\<perl\>' $file; then
140                output_file=files-perl
141        else
142                output_file=files-nonperl
143        fi
144
145        echo %{_bindir}/$(basename $file) >> $output_file
146
147        # manpage availability
148        manfile=%{buildroot}%{_mandir}/man1/$(basename $file).\*
149        if [ -f $manfile -o -L $manfile ]; then
150                echo %{_mandir}/man1/$(basename $file).\* >> $output_file
151        fi
152done
153
154# install info
155install -d $RPM_BUILD_ROOT%{_infodir}
156install -m644 doc/groff.info* $RPM_BUILD_ROOT%{_infodir}
157
158# remove unnecessary files and fix privileges
159rm -f %{buildroot}%{_infodir}/dir
160
161# fix privileges
162chmod 755 %{buildroot}%{_datadir}/groff/%{version}/groffer/version.sh
163chmod 755 %{buildroot}%{_datadir}/groff/%{version}/font/devlj4/generate/special.awk
164
165# remove CreationDate from documentation
166pushd %{buildroot}%{_pkgdocdir}
167    find -name "*.html" | xargs sed -i "/^<!-- CreationDate: /d"
168    find -name "*.ps"   | xargs sed -i "/^%%%%CreationDate: /d"
169popd
170
171%clean
172[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
173
174
175%post
176/sbin/install-info --info-dir=%{_infodir} %{_infodir}/groff.info.gz ||:
177
178
179%preun
180if [ "$1" = 0 ]; then
181    /sbin/install-info --delete \
182        --info-dir=%{_infodir} %{_infodir}/groff.info.gz ||:
183fi
184
185%triggerpostun -- %{name} <= %{cache_clean_ver}
186find %{_var}/cache/man -type f -name "*.bz2" -exec %{__rm} -f {} \;
187
188%files -f files-nonperl
189%defattr(-,root,root)
190%license COPYING FDL LICENSES
191%doc BUG-REPORT MORE.STUFF NEWS PROBLEMS
192%doc doc/*.html doc/*.css doc/*xpm doc/img
193%dir %{_sysconfdir}/groff/
194%dir %{_sysconfdir}/groff/site-font
195%dir %{_sysconfdir}/groff/site-tmac
196%config(noreplace) %{_sysconfdir}/groff/site-tmac/*
197%dir %{_libdir}/groff
198%{_libdir}/groff/groff_opts_no_arg.txt
199%{_libdir}/groff/groff_opts_with_arg.txt
200%{_datadir}/groff/
201# manpages for binaries are covered by -f
202%{_mandir}/man1/grohtml.*
203%{_mandir}/man5/*
204%{_mandir}/man7/*
205%{_infodir}/groff.info*
206%exclude %{_datadir}/groff/%{version}/groffer
207%exclude %{_bindir}/gxditview
208%exclude %{_bindir}/xtotroff
209%exclude %{_mandir}/man1/gxditview.*
210%exclude %{_mandir}/man1/xtotroff.*
211
212
213%files perl -f files-perl
214%defattr(-,root,root)
215%{_datadir}/groff/%{version}/groffer/
216%{_libdir}/groff/glilypond
217%{_libdir}/groff/gpinyin
218%{_libdir}/groff/grog
219
220
221%files gxditview
222%defattr(-,root,root)
223%{_bindir}/gxditview
224%{_bindir}/xtotroff
225%{_datadir}/X11/app-defaults/GXditview
226%{_datadir}/X11/app-defaults/GXditview-color
227%{_mandir}/man1/gxditview.*
228%{_mandir}/man1/xtotroff.*
229
230
231%changelog
232* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.4-1
233- new upstream release.
234- dropped all patches.
235- imported patches from rawhide.
236
237* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
238- rebuild with gcc-5.4.0
239
240* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-2
241- rebuild with VineSeed environment
242
243* Thu Mar 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
244- new upstream release
245- drop all cjk patch
246- add patch2,3 to fix typo
247
248* Fri Apr 02 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.18.1.1-5
249- add %posttriggerun to clean old caches (<BTS:VineLinux:960>)
250
251* Tue Mar 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.18.1.1-4
252- add Patch2 to fix minus/hyphen character width (<BTS:VineLinux:960>)
253- add BuildRequires: psutils, byacc, imake, netpbm-progs, ghostscript
254
255* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-3
256- remove gxditview from main package
257
258* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-2
259- rebuild with libXaw.so.7 (libXaw-1.0.5)
260
261* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-1
262- rebuild with new versioning policy
263- update Debian patch
264
265* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.1.1-0vl1
266- rebuilt with new toolchain
267- updated source and Japanese patch based on Debian
268- added BuildRequires: XOrg-devel
269
270* Fri Sep 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.2-0vl7
271- rebuild to add gpg sign
272
273* Tue Apr  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.17.2-0vl6
274- rebuild
275
276* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.17.2-0vl5
277- rebuilt with new toolchain
278
279* Wed Mar 06 2002 Toru Sagami <sagami@vinelinux.org> 1.17.2-0vl4
280- corrected zsoelim.1 symlink in %%{_mandir}
281
282* Mon Feb 11 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl3
283- fixed symlink of *.tmac
284
285* Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl2
286- build on VineSeed
287
288* Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl1
289- updated groff-1.17.2
290    -- security fixed of CAN-2002-0003
291    -- changed japanese patch to debian patch
292    -- modified spec file
293
294* Mon Sep 10 2001 Toru Sagami <sagami@vinelinux.org>
295- 1.16.1-0vl1: split perl components into separate subpackage
296
297* Tue Jul 17 2001 <sagami@vinelinux.org>
298- 1.16.1: version up to 1.16.1
299- add groff-1.16.1-japanese.patch originally taken from Kondara
300- use %%configure after autoconf, %%makeinstall
301
302* Tue Jan 23 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
303- 1.15_jp-7
304- built on egcs-1.1/libstdc++2_9-2.9.0
305- fixed: whether or not build system compress man pages
306
307* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 1.15_jp-6
308- some fixes to handle man pages correctly
309
310* Sat Nov 11 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.15_jp-5
311- build on gcc-2.95.3
312- partially used macros
313
314* Mon Aug  7 2000 Jun Nishii <jun@vinelinux.org>
315- 1.15_jp-4
316- follow up to RHL62 (1.15-8)
317
318* Thu Feb 24 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
319- 1.15_jp-3
320- modified ja patch, namely lib.h
321
322* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
323- groff-tmac-ja was lacked in Source entry(;_;) fixed!
324
325* Tue Jan  4 2000 Jun Nishii <jun@vinelinux.org>
326- build for Vine Linux 2.0 with ja patch
327
328* Wed Dec 29 1999 Bill Nottingham <notting@redhat.com>
329- update to 1.15
330
331* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
332- auto rebuild in the new build environment (release 9)
333
334* Tue Feb 16 1999 Cristian Gafton <gafton@redhat.com>
335- glibc 2.1 patch for xditview (#992)
336
337* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
338- build for Raw Hide
339
340* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
341- fix makefiles to work with bash2
342
343* Fri May 08 1998 Prospector System <bugs@redhat.com>
344- translations modified for de, fr, tr
345
346* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
347- use g++ for C++ code
348
349* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
350- manhattan and buildroot
351
352* Mon Nov  3 1997 Michael Fulbright <msf@redhat.com>
353- made xdefaults file a config file
354
355* Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
356- split perl components into separate subpackage
357
358* Tue Oct 21 1997 Michael Fulbright <msf@redhat.com>
359- updated to 1.11a
360- added safe troff-to-ps.fpi
361
362* Tue Oct 14 1997 Michael Fulbright <msf@redhat.com>
363- removed troff-to-ps.fpi for security reasons.
364
365* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
366- built against glibc
367
Note: See TracBrowser for help on using the repository browser.