source: projects/specs/trunk/g/groff/groff-vl.spec @ 10549

Revision 10549, 10.1 KB checked in by Takemikaduchi, 8 years ago (diff)

systemtap: new upstream release
others: rebuild with gcc-5.4.0

Line 
1# clean old caches when groff =< %{cache_clean_ver}
2# is uninstalled.
3%define cache_clean_ver 1.18.1.1-4%{?_dist_release}
4
5Summary: A document formatting system.
6Summary(ja): GNU groff 日本語対応版
7Name: groff
8Version: 1.21
9Release: 3%{?_dist_release}
10License: GPL
11Group: Applications/Publishing
12URL: http://groff.ffii.org
13
14Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
15
16#
17Patch2: groff-makefile-typo.patch
18Patch3: groff-manpages-typos.patch
19#
20Patch5: groff-1.21-pic-eqn-warnings.patch
21Patch6: groff-1.21-grotty-no-sgr.patch
22Patch7: groff-1.21-m-syntax.patch
23
24# Japanese Patch from Debian
25Patch10: groff-1.18.1.1-fix-minus-char.patch
26
27#
28Patch20: groff-1.21-no-doc.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: libX11-devel, libICE-devel, libSM-devel, libXext-devel
32BuildRequires: libXmu-devel, libXpm-devel, libXt-devel
33BuildRequires: libXaw-devel >= 1.0.5
34BuildRequires: psutils, byacc, imake, netpbm-progs, ghostscript
35Requires(post): install-info
36Requires(preun): install-info
37Requires(postun): findutils
38Obsoletes: groff-tools
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: daisuke
43
44%description
45Groff is a document formatting system.  Groff takes standard text and
46formatting commands as input and produces formatted output.  The
47created documents can be shown on a display or printed on a printer.
48Groff's formatting commands allow you to specify font type and size, bold
49type, italic type, the number and size of columns on a page, and more.
50
51You should install groff if you want to use it as a document formatting
52system.  Groff can also be used to format man pages. If you are going
53to use groff with the X Window System, you'll also need to install the
54groff-gxditview package.
55
56%description -l ja
57GNU roff (groff) 日本語対応版です。日本語で書かれたマニュアルを表示す
58るのに必要です.
59
60
61%package perl
62Summary: Parts of the groff formatting system that require Perl.
63Group: Applications/Publishing
64Requires: %{name} = %{version}
65Requires: mktemp
66
67%description perl
68The groff-perl package contains the parts of the groff text processor
69package that require Perl. These include the afmtodit font processor
70for creating PostScript font files, the grog utility that can be used
71to automatically determine groff command-line options, and the
72troff-to-ps print filter.
73
74
75%package gxditview
76Summary: An X previewer for groff text processor output.
77Group: Applications/Publishing
78Requires: %{name} = %{version}
79
80%description gxditview
81Gxditview displays the groff text processor's output on an X Window
82System display.
83
84If you are going to use groff as a text processor, you should install
85gxditview so that you preview your processed text files in X.  You'll also
86need to install the groff package and the X Window System.
87
88
89%prep
90%setup -q
91
92%patch2 -p1 -b .makefile-typo
93%patch3 -p1 -b .manpages-typos
94
95%patch5 -p1 -b .pic-eqn-warnings
96%patch6 -p1 -b .grotty-no-sgr
97%patch7 -p1 -b .m-syntax
98
99%patch10 -p0 -b .fix-minus
100
101%patch20 -p1 -b .no-doc
102
103for file in NEWS src/devices/grolbp/grolbp.man doc/{groff.info*,webpage.ms} \
104            contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom}
105do
106    iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
107    mv "${file}_" "$file"
108done
109
110
111%build
112export PAGE=A4
113export YACC='bison -y'
114%configure --with-appresdir=%{_datadir}/X11/app-defaults
115%{__make}
116
117GROFF_NO_SGR=1 %{__make} -C doc meintro.txt meref.txt pic.txt
118
119%install
120[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
121
122%{__make} install DESTDIR=%{buildroot} \
123                  docdir=%{_docdir}/%{name}-%{version} \
124                  groffer_dir=%{_datadir}/%{name}/%{version}/groffer
125
126# some binaries need alias with 'g' or 'z' prefix
127
128for file in g{nroff,troff,tbl,pic,eqn,neqn,refer,lookbib,indxbib,soelim} ; do
129        ln -s ${file#?} %{buildroot}%{_bindir}/${file}
130        ln -s ${file#?}.1.gz %{buildroot}%{_mandir}/man1/${file}.1.gz
131done
132               
133# perl dependent files in /usr/bin will be in separate package
134
135rm -f files-perl files-nonperl
136for file in %{buildroot}%{_bindir}/*; do
137        # package selection
138        if grep -q -m1 '^#!.*\<perl\>' $file; then
139                output_file=files-perl
140        else
141                output_file=files-nonperl
142        fi
143
144        echo %{_bindir}/$(basename $file) >> $output_file
145
146        # manpage availability
147        manfile=%{buildroot}%{_mandir}/man1/$(basename $file).\*
148        if [ -f $manfile -o -L $manfile ]; then
149                echo %{_mandir}/man1/$(basename $file).\* >> $output_file
150        fi
151done
152
153# install info
154install -d $RPM_BUILD_ROOT%{_infodir}
155install -m644 doc/groff.info* $RPM_BUILD_ROOT%{_infodir}
156
157# remove unnecessary files and fix privileges
158rm -f %{buildroot}%{_infodir}/dir
159
160chmod 755 %{buildroot}%{_datadir}/groff/%{version}/groffer/version.sh
161chmod 755 %{buildroot}%{_datadir}/groff/%{version}/font/devlj4/generate/special.awk
162
163rm -f %{buildroot}%{_bindir}/zsoelim
164rm -f %{buildroot}%{_mandir}/man1/zsoelim.1*
165
166%clean
167[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
168
169
170%post
171/sbin/install-info --info-dir=%{_infodir} %{_infodir}/groff.info.gz ||:
172
173
174%preun
175if [ "$1" = 0 ]; then
176    /sbin/install-info --delete \
177        --info-dir=%{_infodir} %{_infodir}/groff.info.gz ||:
178fi
179
180%triggerpostun -- %{name} <= %{cache_clean_ver}
181find %{_var}/cache/man -type f -name "*.bz2" -exec %{__rm} -f {} \;
182
183%files -f files-nonperl
184%defattr(-,root,root)
185%doc BUG-REPORT COPYING FDL LICENSES MORE.STUFF NEWS PROBLEMS
186%doc doc/*.txt
187%{_datadir}/groff/
188# manpages for binaries are covered by -f
189%{_mandir}/man1/grohtml.*
190%{_mandir}/man5/*
191%{_mandir}/man7/*
192%{_infodir}/groff.info*
193%exclude %{_datadir}/groff/%{version}/groffer
194%exclude %{_bindir}/gxditview
195%exclude %{_bindir}/xtotroff
196%exclude %{_mandir}/man1/gxditview.*
197%exclude %{_mandir}/man1/xtotroff.*
198
199
200%files perl -f files-perl
201%defattr(-,root,root)
202%{_datadir}/groff/%{version}/groffer/
203
204
205%files gxditview
206%defattr(-,root,root)
207%{_bindir}/gxditview
208%{_bindir}/xtotroff
209%{_datadir}/X11/app-defaults/GXditview
210%{_datadir}/X11/app-defaults/GXditview-color
211%{_mandir}/man1/gxditview.*
212%{_mandir}/man1/xtotroff.*
213
214
215%changelog
216* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
217- rebuild with gcc-5.4.0
218
219* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-2
220- rebuild with VineSeed environment
221
222* Thu Mar 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
223- new upstream release
224- drop all cjk patch
225- add patch2,3 to fix typo
226
227* Fri Apr 02 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.18.1.1-5
228- add %posttriggerun to clean old caches (<BTS:VineLinux:960>)
229
230* Tue Mar 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.18.1.1-4
231- add Patch2 to fix minus/hyphen character width (<BTS:VineLinux:960>)
232- add BuildRequires: psutils, byacc, imake, netpbm-progs, ghostscript
233
234* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-3
235- remove gxditview from main package
236
237* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-2
238- rebuild with libXaw.so.7 (libXaw-1.0.5)
239
240* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-1
241- rebuild with new versioning policy
242- update Debian patch
243
244* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.1.1-0vl1
245- rebuilt with new toolchain
246- updated source and Japanese patch based on Debian
247- added BuildRequires: XOrg-devel
248
249* Fri Sep 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.2-0vl7
250- rebuild to add gpg sign
251
252* Tue Apr  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.17.2-0vl6
253- rebuild
254
255* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.17.2-0vl5
256- rebuilt with new toolchain
257
258* Wed Mar 06 2002 Toru Sagami <sagami@vinelinux.org> 1.17.2-0vl4
259- corrected zsoelim.1 symlink in %%{_mandir}
260
261* Mon Feb 11 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl3
262- fixed symlink of *.tmac
263
264* Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl2
265- build on VineSeed
266
267* Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl1
268- updated groff-1.17.2
269    -- security fixed of CAN-2002-0003
270    -- changed japanese patch to debian patch
271    -- modified spec file
272
273* Mon Sep 10 2001 Toru Sagami <sagami@vinelinux.org>
274- 1.16.1-0vl1: split perl components into separate subpackage
275
276* Tue Jul 17 2001 <sagami@vinelinux.org>
277- 1.16.1: version up to 1.16.1
278- add groff-1.16.1-japanese.patch originally taken from Kondara
279- use %%configure after autoconf, %%makeinstall
280
281* Tue Jan 23 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
282- 1.15_jp-7
283- built on egcs-1.1/libstdc++2_9-2.9.0
284- fixed: whether or not build system compress man pages
285
286* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 1.15_jp-6
287- some fixes to handle man pages correctly
288
289* Sat Nov 11 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.15_jp-5
290- build on gcc-2.95.3
291- partially used macros
292
293* Mon Aug  7 2000 Jun Nishii <jun@vinelinux.org>
294- 1.15_jp-4
295- follow up to RHL62 (1.15-8)
296
297* Thu Feb 24 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
298- 1.15_jp-3
299- modified ja patch, namely lib.h
300
301* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
302- groff-tmac-ja was lacked in Source entry(;_;) fixed!
303
304* Tue Jan  4 2000 Jun Nishii <jun@vinelinux.org>
305- build for Vine Linux 2.0 with ja patch
306
307* Wed Dec 29 1999 Bill Nottingham <notting@redhat.com>
308- update to 1.15
309
310* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
311- auto rebuild in the new build environment (release 9)
312
313* Tue Feb 16 1999 Cristian Gafton <gafton@redhat.com>
314- glibc 2.1 patch for xditview (#992)
315
316* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
317- build for Raw Hide
318
319* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
320- fix makefiles to work with bash2
321
322* Fri May 08 1998 Prospector System <bugs@redhat.com>
323- translations modified for de, fr, tr
324
325* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
326- use g++ for C++ code
327
328* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
329- manhattan and buildroot
330
331* Mon Nov  3 1997 Michael Fulbright <msf@redhat.com>
332- made xdefaults file a config file
333
334* Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
335- split perl components into separate subpackage
336
337* Tue Oct 21 1997 Michael Fulbright <msf@redhat.com>
338- updated to 1.11a
339- added safe troff-to-ps.fpi
340
341* Tue Oct 14 1997 Michael Fulbright <msf@redhat.com>
342- removed troff-to-ps.fpi for security reasons.
343
344* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
345- built against glibc
346
Note: See TracBrowser for help on using the repository browser.