source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 7304

Revision 7304, 8.7 KB checked in by iwaim, 11 years ago (diff)

graphviz 2.28.0-3

Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Version:        2.28.0
4Release:        3%{?_dist_release}
5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
8
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  bison
14BuildRequires:  cairo-devel
15BuildRequires:  expat-devel
16BuildRequires:  flex
17BuildRequires:  fontconfig-devel
18BuildRequires:  freetype2-devel
19BuildRequires:  gd-devel
20BuildRequires:  gtk2-devel
21BuildRequires:  guile-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libpng-devel
24BuildRequires:  libSM-devel
25BuildRequires:  libtool-ltdl-devel >= 2.2.6a
26BuildRequires:  libXaw-devel
27BuildRequires:  libXext-devel
28BuildRequires:  librsvg2-devel
29BuildRequires:  m4
30BuildRequires:  perl
31BuildRequires:  python-devel
32BuildRequires:  ruby-devel
33BuildRequires:  swig
34BuildRequires:  tcl >= 8.4
35BuildRequires:  tk >= 8.4
36BuildRequires:  zlib-devel
37Requires:       urw-fonts
38
39# only for this release
40BuildConflicts: graphviz-devel
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44
45%description
46A collection of tools and tcl packages for the manipulation and layout
47of graphs (as in nodes and edges, not as in barcharts).
48
49%package devel
50Group:          Development/Libraries
51Summary:        Development tools for version %{version} of %{name}
52Requires:       %{name} = %{version}
53
54%description devel
55The %{name}-devel package contains the header files
56and man3 pages necessary for developing programs
57using version %{version} of the %{name} libraries.
58
59%package doc
60Summary: PDF and HTML documents for graphviz
61Group:   Applications/Documentation
62
63%description doc
64Provides some additional PDF and HTML documentation for graphviz.
65
66%package guile
67Group:          Applications/Graphics
68Summary:        Guile extension for graphviz
69Requires:       %{name} = %{version}-%{release}, guile
70
71%description guile
72Guile extension for graphviz.
73
74%package perl
75Group:    Applications/Graphics
76Summary:  Perl extension for graphviz
77Requires: %{name} = %{version}-%{release}
78Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
79
80%description perl
81Perl extension for graphviz.
82
83%package python
84Group:    Applications/Graphics
85Summary:  Python extension for graphviz
86Requires: %{name} = %{version}-%{release}
87Requires: python
88
89%description python
90Python extension for graphviz.
91
92%package ruby
93Group:    Applications/Multimedia
94Summary:  Ruby extension for graphviz
95Requires: %{name} = %{version}-%{release}
96Requires: ruby
97
98%description ruby
99Ruby extension for graphviz.
100
101%package tcl
102Group:    Applications/Graphics
103Summary:  Tcl extension & tools for graphviz
104Requires: tcl >= 8.4, tk >= 8.4
105Requires: %{name} = %{version}
106
107%description tcl
108Various tcl packages (extensions) for the graphviz tools.
109
110
111%prep
112%setup -q
113
114# using archdir instead of sitearchdir for Vine
115sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
116
117%build
118# Rewrite config_ruby.rb to work with Ruby 1.9
119sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
120sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
121export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
122
123# XXX ix86 only used to have -ffast-math, let's use everywhere
124%{expand: %%define optflags %{optflags} -ffast-math}
125
126%configure \
127    --with-x \
128    --disable-static \
129    --with-mylibgd \
130    --with-ipsepcola \
131    --with-pangocairo \
132    --with-gdk-pixbuf \
133    --without-mylibgd \
134    --without-ming \
135    --disable-sharp \
136    --enable-guile \
137    --enable-io \
138    --disable-java \
139    --disable-lua \
140    --disable-ocaml \
141    --enable-perl \
142    --disable-php \
143    --enable-python \
144    --disable-r \
145    --enable-ruby \
146    --enable-tcl
147
148make %{?_smp_mflags}
149
150%install
151rm -rf $RPM_BUILD_ROOT __doc
152make DESTDIR=$RPM_BUILD_ROOT \
153    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
154    pkgconfigdir=%{_libdir}/pkgconfig \
155    install
156
157find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
158chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
159cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
160rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
166%post
167/sbin/ldconfig
168%{_bindir}/dot -c
169
170# if there is no dot after everything else is done, then remove config
171%postun
172if [ $1 -eq 0 ]; then
173    rm -f %{_libdir}/graphviz/config || :
174fi
175/sbin/ldconfig
176
177
178%files
179%defattr(-,root,root)
180%doc AUTHORS COPYING ChangeLog NEWS README
181%{_bindir}/*
182%dir %{_datadir}/%{name}
183%{_datadir}/%{name}/lefty
184%{_mandir}/man1/*
185%{_mandir}/man7/*
186%dir %{_libdir}/%{name}
187%{_libdir}/*.so.*
188%{_libdir}/%{name}/*.so.*
189%exclude %{_libdir}/graphviz/*/*
190
191%files devel
192%defattr(-,root,root)
193%{_includedir}/%{name}
194%{_libdir}/*.so
195%{_libdir}/%{name}/*.so
196%{_libdir}/pkgconfig/*.pc
197%{_datadir}/%{name}/graphs
198%{_mandir}/man3/*.3.gz
199
200%files doc
201%defattr(-,root,root,-)
202%doc __doc/*
203
204%files guile
205%defattr(-,root,root,-)
206%{_libdir}/graphviz/guile/
207%{_mandir}/man3/gv.3guile*
208
209%files perl
210%defattr(-,root,root,-)
211%{_libdir}/graphviz/perl/
212%{perl_vendorarch}/*
213%{_mandir}/man3/gv.3perl*
214
215%files python
216%defattr(-,root,root,-)
217%{_libdir}/graphviz/python/
218%{_libdir}/python*/*
219%{_mandir}/man3/gv.3python*
220
221%files ruby
222%defattr(-,root,root,-)
223%{_libdir}/graphviz/ruby/
224%{_libdir}/*ruby*/*
225%{_mandir}/man3/gv.3ruby*
226
227%files tcl
228%defattr(-,root,root)
229%{_libdir}/%{name}/tcl/*
230%{_libdir}/tcl*/*
231%{_datadir}/%{name}/demo
232# hack to include gv.3tcl only if available
233#  always includes tcldot.3tcl, gdtclft.3tcl
234%{_mandir}/man3/*.3tcl*
235%{_mandir}/man3/tkspline.3tk*
236
237
238%changelog
239* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
240- build with Tcl/Tk 8.5.7-1
241- stop running autoreconf
242- add Vendor and Distribution tags
243
244* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
245- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
246  - rewrite config_ruby.rb to build with ruby-1.9.3
247  - add search path for ruby/config.h to CPPFLAGS for configure
248
249* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
250- new upstream release
251- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
252- add BuildRequires: librsvg2-devel
253
254* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
255- add Patch10 to avoid build failure on ppc
256
257* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
258- new upstream release
259- built with rpm-4.8.1
260- split doc, guile, perl, python, ruby subpackage
261
262* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
263- rebuild with libtool-2.2.6a
264
265* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
266- new upstream release
267
268* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
269- rebuild with libXaw.so.7 (libXaw-1.0.5)
270
271* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
272- new upstream release
273
274* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
275- new upstream release
276- build with expat-2.0.1
277- add man7
278
279* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
280- rebuild with tcl/tk-8.4.16
281
282* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
283- new upstream release
284- add BuildPrereq: swig
285- delete BuildPrereq: gd-progs gd-devel
286- add --with-mylibgd and --disable-FEATURE to configure option
287- update %%files
288
289* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
290- added BuildPrereq: ruby-devel
291
292* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
293- new upstream release
294- add BuildPrereq: libtool-ltdl-devel
295- move pkgconfig files to %%{_libdir}/pkgconfig
296- add --disable-rpath --disable-static to configure option
297- add %%post to every package
298
299* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
300- new upstream release
301- BuildPrereq: tcl >= 8.4, tk >= 8.4
302- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
303- update %%files
304- remove lines about Vine2.6
305- change License to CPL
306
307* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
308- source upgrade
309- remove patch0 and commented lines
310
311* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
312- build for VineSeed
313
314* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
315- source upgrade
316- change spec to build both VineSeed and Vine2.5/2.6
317- add BuildPrereq: expat-devel and Requires: libexpat
318- add patch0 to build against freetype2-2.1.7
319- stop using autogen.sh script
320- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
321- add graphviz-tcl package (VineSeed)
322
323* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
324- rebuild for new Vine
325
326* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
327- import from offical site (src.rpm)
328
Note: See TracBrowser for help on using the repository browser.