source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           graphviz
2Version:        2.20.3
3Release:        2%{?_dist_release}
4Group:          Applications/Graphics
5License:        CPL
6URL:            http://www.graphviz.org/
7Summary:        Graph Visualization Tools
8Source:         http://www.graphviz.org/pub/%{name}/ARCHIVE/%{name}-%{version}.tar.gz
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12BuildRequires:  freetype2-devel libjpeg-devel libpng-devel zlib-devel
13BuildRequires:  expat-devel flex bison pkgconfig
14BuildRequires:  swig ruby-devel
15BuildRequires:  tcl >= 8.4, tk >= 8.4
16BuildRequires:  libtool-ltdl-devel >= 2.2.6a
17Requires:       freetype2 libjpeg libpng zlib libexpat
18
19%description
20A collection of tools and tcl packages for the manipulation and layout
21of graphs (as in nodes and edges, not as in barcharts).
22
23%package tcl
24Group:          Applications/Graphics
25Summary:        Tcl extension tools for version %{version} of %{name}
26Requires:       tcl >= 8.4, tk >= 8.4
27Requires:       %{name} = %{version}
28Provides:       %{name}-tcl = %{version}
29
30%description tcl
31The %{name}-tcl package contains the various tcl packages (extensions)
32for version %{version} of the %{name} tools.
33
34%package devel
35Group:          Development/Libraries
36Summary:        Development tools for version %{version} of %{name}
37Requires:       %{name} = %{version}
38Provides:       %{name}-devel = %{version}
39
40%description devel
41The %{name}-devel package contains the header files
42and man3 pages necessary for developing programs
43using version %{version} of the %{name} libraries.
44
45%prep
46%setup -q
47
48%build
49CFLAGS=${CFLAGS-"$RPM_OPT_FLAGS"}
50CXXFLAGS=${CXXFLAGS-"$CFLAGS"}
51export CFLAGS CXXFLAGS
52./configure \
53      --prefix=%{_prefix} \
54      --bindir=%{_bindir} \
55      --libdir=%{_libdir} \
56      --includedir=%{_includedir} \
57      --datadir=%{_datadir} \
58      --mandir=%{_mandir} \
59      --disable-rpath \
60      --disable-static \
61      --without-ipsepcola \
62      --with-mylibgd \
63      --without-ming \
64      --disable-sharp \
65      --disable-guile \
66      --disable-io \
67      --disable-java \
68      --disable-lua \
69      --disable-ocaml \
70      --disable-perl \
71      --disable-php \
72      --disable-python \
73      --disable-ruby
74
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make DESTDIR=$RPM_BUILD_ROOT install
80
81find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
82chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
83cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
84rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
85
86# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
87%post
88%{_bindir}/dot -c
89
90%post tcl
91%{_bindir}/dot -c
92
93%post devel
94%{_bindir}/dot -c
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(-,root,root)
101%doc README __doc/*
102%{_bindir}/*
103%dir %{_datadir}/%{name}
104%{_datadir}/%{name}/lefty
105%{_mandir}/man1/*
106%{_mandir}/man7/*
107%dir %{_libdir}/%{name}
108%{_libdir}/*.so.*
109%{_libdir}/%{name}/*.so.*
110%exclude %{_libdir}/graphviz/*/*
111
112%files tcl
113%defattr(-,root,root)
114%doc AUTHORS COPYING ChangeLog README
115%{_libdir}/%{name}/tcl/*
116%{_libdir}/tcl8.4/graphviz
117%{_datadir}/%{name}/demo
118%{_mandir}/mann/*
119
120%files devel
121%defattr(-,root,root)
122%{_includedir}/%{name}
123%{_libdir}/*.so
124%{_libdir}/%{name}/*.so
125%{_libdir}/pkgconfig/*.pc
126%{_datadir}/%{name}/graphs
127%{_mandir}/man3/*
128
129%changelog
130* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
131- rebuild with libtool-2.2.6a
132
133* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
134- new upstream release
135
136* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
137- rebuild with libXaw.so.7 (libXaw-1.0.5)
138
139* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
140- new upstream release
141
142* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
143- new upstream release
144- build with expat-2.0.1
145- add man7
146
147* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
148- rebuild with tcl/tk-8.4.16
149
150* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
151- new upstream release
152- add BuildPrereq: swig
153- delete BuildPrereq: gd-progs gd-devel
154- add --with-mylibgd and --disable-FEATURE to configure option
155- update %%files
156
157* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
158- added BuildPrereq: ruby-devel
159
160* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
161- new upstream release
162- add BuildPrereq: libtool-ltdl-devel
163- move pkgconfig files to %%{_libdir}/pkgconfig
164- add --disable-rpath --disable-static to configure option
165- add %%post to every package
166
167* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
168- new upstream release
169- BuildPrereq: tcl >= 8.4, tk >= 8.4
170- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
171- update %%files
172- remove lines about Vine2.6
173- change License to CPL
174
175* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
176- source upgrade
177- remove patch0 and commented lines
178
179* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
180- build for VineSeed
181
182* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
183- source upgrade
184- change spec to build both VineSeed and Vine2.5/2.6
185- add BuildPrereq: expat-devel and Requires: libexpat
186- add patch0 to build against freetype2-2.1.7
187- stop using autogen.sh script
188- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
189- add graphviz-tcl package (VineSeed)
190
191* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
192- rebuild for new Vine
193
194* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
195- import from offical site (src.rpm)
196
Note: See TracBrowser for help on using the repository browser.