source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 12333

Revision 12333, 11.4 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

graphviz-2.42.2-1

rrdtool-1.7.2-1

ruby-2.6.5-1

subversion-1.13.0-1

vim-8.2.0390-1

Line 
1%define _unpackaged_files_terminate_build 1
2
3Name:           graphviz
4Summary:        Graph Visualization Tools
5Summary(ja):    グラフ可視化ツール
6Version:        2.42.2
7Release:        1%{?_dist_release}
8Group:          Applications/Graphics
9License:        EPL
10URL:            http://www.graphviz.org/
11
12Source0:        http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
13# rhbz#1505230
14Patch0:                 graphviz-2.42.2-dotty-menu-fix.patch
15Patch1:                 graphviz-2.42.2-coverity-scan-fixes.patch
16# Workaround for some const casting badness in the OCaml bindings.
17# Real fix will need a fix to SWIG.
18Patch2:                 graphviz-2.42.2-ocaml-allow-const-cast.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  bison
22BuildRequires:  cairo-devel
23BuildRequires:  expat-devel
24BuildRequires:  flex
25BuildRequires:  fontconfig-devel
26BuildRequires:  freetype2-devel
27BuildRequires:  gd-devel
28BuildRequires:  gmp-devel
29BuildRequires:  gtk2-devel
30BuildRequires:  guile-devel
31BuildRequires:  libjpeg-turbo-devel
32BuildRequires:  libpng-devel
33BuildRequires:  libSM-devel
34BuildRequires:  libtool-ltdl-devel >= 2.2.6a
35BuildRequires:  libXaw-devel
36BuildRequires:  libXext-devel
37BuildRequires:  librsvg2-devel
38BuildRequires:  lua-devel
39BuildRequires:  m4
40BuildRequires:  perl
41BuildRequires:  python-devel
42BuildRequires:  python3-devel
43BuildRequires:  python3-rpm-macros
44BuildRequires:  python3-setuptools
45BuildRequires:  ruby-devel
46BuildRequires:  swig
47BuildRequires:  tcl-devel >= 8.4
48BuildRequires:  tk-devel >= 8.4
49BuildRequires:  zlib-devel
50Requires:       urw-fonts
51
52# only for this release
53# BuildConflicts: graphviz-devel
54
55Vendor:         Project Vine
56Distribution:   Vine Linux
57Packager:       daisuke
58
59%description
60A collection of tools and tcl packages for the manipulation and layout
61of graphs (as in nodes and edges, not as in barcharts).
62
63%package devel
64Summary:        Development tools for version %{version} of %{name}
65Group:          Development/Libraries
66Requires:       %{name} = %{version}
67
68%description devel
69The %{name}-devel package contains the header files
70and man3 pages necessary for developing programs
71using version %{version} of the %{name} libraries.
72
73%package doc
74Summary: PDF and HTML documents for graphviz
75Group:   Applications/Documentation
76
77%description doc
78Provides some additional PDF and HTML documentation for graphviz.
79
80%package guile
81Group:          Applications/Graphics
82Summary:        Guile extension for graphviz
83Requires:       %{name} = %{version}-%{release}, guile
84
85%description guile
86Guile extension for graphviz.
87
88%package lua
89Group:          Applications/Graphics
90Summary:        Lua extension for graphviz
91Requires:       %{name} = %{version}-%{release}, lua
92
93%description lua
94Lua extension for graphviz.
95
96%package perl
97Group:    Applications/Graphics
98Summary:  Perl extension for graphviz
99Requires: %{name} = %{version}-%{release}
100Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
101
102%description perl
103Perl extension for graphviz.
104
105%package python
106Group:    Applications/Graphics
107Summary:  Python extension for graphviz
108Requires: %{name} = %{version}-%{release}
109Requires: python
110
111%description python
112Python extension for graphviz.
113
114%package python3
115Group:    Applications/Graphics
116Summary:  Python3 extension for graphviz
117Requires: %{name} = %{version}-%{release}
118Requires: python3
119
120%description python3
121Python3 extension for graphviz.
122
123%package ruby
124Group:    Applications/Graphics
125Summary:  Ruby extension for graphviz
126Requires: %{name} = %{version}-%{release}
127Requires: ruby
128
129%description ruby
130Ruby extension for graphviz.
131
132%package tcl
133Group:    Applications/Graphics
134Summary:  Tcl extension & tools for graphviz
135Requires: tcl >= 8.4, tk >= 8.4
136Requires: %{name} = %{version}
137
138%description tcl
139Various tcl packages (extensions) for the graphviz tools.
140
141
142%prep
143%setup -q -n graphviz-stable_release_%{version}
144%patch0 -p1 -b .dotty-menu-fix
145%patch1 -p1 -b .coverity-scan-fixes
146%patch2 -p1
147
148# Attempt to fix rpmlint warnings about executable sources
149find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
150
151%build
152./autogen.sh
153
154# using archdir instead of sitearchdir for Vine
155sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
156# Rewrite config_ruby.rb to work with Ruby 2.1
157sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
158sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
159
160# get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
161export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
162# XXX ix86 only used to have -ffast-math, let's use everywhere
163%{expand: %%define optflags %{optflags} -ffast-math}
164
165%configure \
166    --with-x \
167    --disable-static \
168    --with-mylibgd \
169    --with-ipsepcola \
170    --with-pangocairo \
171    --with-gdk-pixbuf \
172    --without-mylibgd \
173    --without-ming \
174    --without-qt \
175    --disable-sharp \
176    --enable-guile \
177    --disable-java \
178    --enable-lua \
179    --disable-ocaml \
180    --enable-perl \
181    --disable-php \
182    --enable-python \
183    --enable-python3 \
184    --disable-r \
185    --enable-ruby \
186    --enable-swig \
187    --enable-tcl \
188    --with-visio
189
190make %{?_smp_mflags}
191
192%install
193rm -rf $RPM_BUILD_ROOT __doc
194make DESTDIR=$RPM_BUILD_ROOT \
195    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
196    pkgconfigdir=%{_libdir}/pkgconfig \
197    install
198
199find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
200chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
201cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
202rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
203
204rm -rf %{buildroot}%{_libdir}/graphviz/python2
205
206%clean
207rm -rf $RPM_BUILD_ROOT
208
209# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
210%post
211/sbin/ldconfig
212%{_bindir}/dot -c
213
214# if there is no dot after everything else is done, then remove config
215%postun
216if [ $1 -eq 0 ]; then
217    rm -f %{_libdir}/graphviz/config || :
218fi
219/sbin/ldconfig
220
221
222%files
223%defattr(-,root,root)
224%license COPYING
225%doc AUTHORS ChangeLog NEWS README
226%{_bindir}/*
227%dir %{_datadir}/%{name}
228%{_datadir}/%{name}/gvpr
229%{_datadir}/%{name}/lefty
230%{_mandir}/man1/*
231%{_mandir}/man7/*
232%dir %{_libdir}/%{name}
233%{_libdir}/*.so.*
234%{_libdir}/%{name}/*.so.*
235%exclude %{_libdir}/graphviz/*/*
236
237%files devel
238%defattr(-,root,root)
239%{_includedir}/%{name}
240%{_libdir}/*.so
241%{_libdir}/%{name}/*.so
242%{_libdir}/pkgconfig/*.pc
243%{_datadir}/%{name}/graphs
244%{_mandir}/man3/*.3.gz
245
246%files doc
247%defattr(-,root,root,-)
248%doc __doc/*
249
250%files guile
251%defattr(-,root,root,-)
252%{_libdir}/graphviz/guile/
253%{_mandir}/man3/gv.3guile*
254
255%files lua
256%defattr(-,root,root,-)
257%{_libdir}/graphviz/lua/
258%{_libdir}/lua*/*
259%{_mandir}/man3/gv.3lua*
260
261%files perl
262%defattr(-,root,root,-)
263%{_libdir}/graphviz/perl/
264%{perl_vendorarch}/*
265%{_mandir}/man3/gv.3perl*
266
267%files python
268%defattr(-,root,root,-)
269%{_libdir}/graphviz/python/
270%{_libdir}/python2*/*
271
272%files python3
273%defattr(-,root,root,-)
274%{_libdir}/graphviz/python3/
275%{_libdir}/python3*/*
276%{_mandir}/man3/gv.3python*
277
278%files ruby
279%defattr(-,root,root,-)
280%{_libdir}/graphviz/ruby/
281%{_libdir}/*ruby*/*
282%{_mandir}/man3/gv.3ruby*
283
284%files tcl
285%defattr(-,root,root)
286%{_libdir}/%{name}/tcl/*
287%{_libdir}/tcl*/*
288%{_datadir}/%{name}/demo
289# hack to include gv.3tcl only if available
290#  always includes tcldot.3tcl, gdtclft.3tcl
291%{_mandir}/man3/*.3tcl*
292
293
294%changelog
295* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.2-1
296- built with ruby-2.6.5.
297- added python3 support.
298- dropped Patch0.
299- imported Patch0-2 from rawhide.
300
301* Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-2
302- rebuilt with guile-2.2.
303
304* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
305- updated to 2.40.1.
306- dropped all patches.
307- imported Patch0 from rawhide.
308
309* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-4
310- rebuild with gcc-5.4.0
311
312* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
313- rebuild with ruby-2.2.3
314
315* Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
316- added Patch0-5 from Fedora
317- rebuilt with guile 2.0.11
318- changed BR: tcl-devel, tk-devel instead of tcl, tk
319- added lua subpackage
320
321* Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
322- update to 2.38.0
323
324* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
325- new upstream release
326
327* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
328- rebuilt with gd-2.1.0.
329
330* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
331- new upstream release
332
333* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
334- build with Tcl/Tk 8.5.7-1
335- stop running autoreconf
336- add Vendor and Distribution tags
337
338* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
339- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
340  - rewrite config_ruby.rb to build with ruby-1.9.3
341  - add search path for ruby/config.h to CPPFLAGS for configure
342
343* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
344- new upstream release
345- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
346- add BuildRequires: librsvg2-devel
347
348* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
349- add Patch10 to avoid build failure on ppc
350
351* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
352- new upstream release
353- built with rpm-4.8.1
354- split doc, guile, perl, python, ruby subpackage
355
356* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
357- rebuild with libtool-2.2.6a
358
359* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
360- new upstream release
361
362* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
363- rebuild with libXaw.so.7 (libXaw-1.0.5)
364
365* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
366- new upstream release
367
368* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
369- new upstream release
370- build with expat-2.0.1
371- add man7
372
373* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
374- rebuild with tcl/tk-8.4.16
375
376* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
377- new upstream release
378- add BuildPrereq: swig
379- delete BuildPrereq: gd-progs gd-devel
380- add --with-mylibgd and --disable-FEATURE to configure option
381- update %%files
382
383* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
384- added BuildPrereq: ruby-devel
385
386* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
387- new upstream release
388- add BuildPrereq: libtool-ltdl-devel
389- move pkgconfig files to %%{_libdir}/pkgconfig
390- add --disable-rpath --disable-static to configure option
391- add %%post to every package
392
393* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
394- new upstream release
395- BuildPrereq: tcl >= 8.4, tk >= 8.4
396- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
397- update %%files
398- remove lines about Vine2.6
399- change License to CPL
400
401* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
402- source upgrade
403- remove patch0 and commented lines
404
405* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
406- build for VineSeed
407
408* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
409- source upgrade
410- change spec to build both VineSeed and Vine2.5/2.6
411- add BuildPrereq: expat-devel and Requires: libexpat
412- add patch0 to build against freetype2-2.1.7
413- stop using autogen.sh script
414- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
415- add graphviz-tcl package (VineSeed)
416
417* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
418- rebuild for new Vine
419
420* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
421- import from offical site (src.rpm)
422
Note: See TracBrowser for help on using the repository browser.