source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 12199

Revision 12199, 10.2 KB checked in by tomop, 5 years ago (diff)

updated guile and pkgs depends on guile

Line 
1%define _unpackaged_files_terminate_build 1
2
3Name:           graphviz
4Summary:        Graph Visualization Tools
5Summary(ja):    グラフ可視化ツール
6Version:        2.40.1
7Release:        2%{?_dist_release}
8Group:          Applications/Graphics
9License:        EPL
10URL:            http://www.graphviz.org/
11
12Source0:        http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
13Patch0:         graphviz-2.40.1-visio.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  bison
17BuildRequires:  cairo-devel
18BuildRequires:  expat-devel
19BuildRequires:  flex
20BuildRequires:  fontconfig-devel
21BuildRequires:  freetype2-devel
22BuildRequires:  gd-devel
23BuildRequires:  gmp-devel
24BuildRequires:  gtk2-devel
25BuildRequires:  guile-devel
26BuildRequires:  libjpeg-turbo-devel
27BuildRequires:  libpng-devel
28BuildRequires:  libSM-devel
29BuildRequires:  libtool-ltdl-devel >= 2.2.6a
30BuildRequires:  libXaw-devel
31BuildRequires:  libXext-devel
32BuildRequires:  librsvg2-devel
33BuildRequires:  lua-devel
34BuildRequires:  m4
35BuildRequires:  perl
36BuildRequires:  python-devel
37BuildRequires:  ruby-devel
38BuildRequires:  swig
39BuildRequires:  tcl-devel >= 8.4
40BuildRequires:  tk-devel >= 8.4
41BuildRequires:  zlib-devel
42Requires:       urw-fonts
43
44# only for this release
45# BuildConflicts: graphviz-devel
46
47Vendor:         Project Vine
48Distribution:   Vine Linux
49Packager:       daisuke
50
51%description
52A collection of tools and tcl packages for the manipulation and layout
53of graphs (as in nodes and edges, not as in barcharts).
54
55%package devel
56Summary:        Development tools for version %{version} of %{name}
57Group:          Development/Libraries
58Requires:       %{name} = %{version}
59
60%description devel
61The %{name}-devel package contains the header files
62and man3 pages necessary for developing programs
63using version %{version} of the %{name} libraries.
64
65%package doc
66Summary: PDF and HTML documents for graphviz
67Group:   Applications/Documentation
68
69%description doc
70Provides some additional PDF and HTML documentation for graphviz.
71
72%package guile
73Group:          Applications/Graphics
74Summary:        Guile extension for graphviz
75Requires:       %{name} = %{version}-%{release}, guile
76
77%description guile
78Guile extension for graphviz.
79
80%package lua
81Group:          Applications/Graphics
82Summary:        Lua extension for graphviz
83Requires:       %{name} = %{version}-%{release}, lua
84
85%description lua
86Lua extension for graphviz.
87
88%package perl
89Group:    Applications/Graphics
90Summary:  Perl extension for graphviz
91Requires: %{name} = %{version}-%{release}
92Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
93
94%description perl
95Perl extension for graphviz.
96
97%package python
98Group:    Applications/Graphics
99Summary:  Python extension for graphviz
100Requires: %{name} = %{version}-%{release}
101Requires: python
102
103%description python
104Python extension for graphviz.
105
106%package ruby
107Group:    Applications/Graphics
108Summary:  Ruby extension for graphviz
109Requires: %{name} = %{version}-%{release}
110Requires: ruby
111
112%description ruby
113Ruby extension for graphviz.
114
115%package tcl
116Group:    Applications/Graphics
117Summary:  Tcl extension & tools for graphviz
118Requires: tcl >= 8.4, tk >= 8.4
119Requires: %{name} = %{version}
120
121%description tcl
122Various tcl packages (extensions) for the graphviz tools.
123
124
125%prep
126%setup -q
127%patch0 -p1 -b .visio
128
129%build
130autoreconf -if
131
132# using archdir instead of sitearchdir for Vine
133sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
134# Rewrite config_ruby.rb to work with Ruby 2.1
135sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
136sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
137
138# get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
139export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
140# XXX ix86 only used to have -ffast-math, let's use everywhere
141%{expand: %%define optflags %{optflags} -ffast-math}
142
143%configure \
144    --with-x \
145    --disable-static \
146    --with-mylibgd \
147    --with-ipsepcola \
148    --with-pangocairo \
149    --with-gdk-pixbuf \
150    --without-mylibgd \
151    --without-ming \
152    --without-qt \
153    --disable-sharp \
154    --enable-guile \
155    --disable-java \
156    --enable-lua \
157    --disable-ocaml \
158    --enable-perl \
159    --disable-php \
160    --enable-python \
161    --disable-r \
162    --enable-ruby \
163    --enable-swig \
164    --enable-tcl
165
166make %{?_smp_mflags}
167
168%install
169rm -rf $RPM_BUILD_ROOT __doc
170make DESTDIR=$RPM_BUILD_ROOT \
171    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
172    pkgconfigdir=%{_libdir}/pkgconfig \
173    install
174
175find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
176chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
177cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
178rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
184%post
185/sbin/ldconfig
186%{_bindir}/dot -c
187
188# if there is no dot after everything else is done, then remove config
189%postun
190if [ $1 -eq 0 ]; then
191    rm -f %{_libdir}/graphviz/config || :
192fi
193/sbin/ldconfig
194
195
196%files
197%defattr(-,root,root)
198%license COPYING
199%doc AUTHORS ChangeLog NEWS README
200%{_bindir}/*
201%dir %{_datadir}/%{name}
202%{_datadir}/%{name}/gvpr
203%{_datadir}/%{name}/lefty
204%{_mandir}/man1/*
205%{_mandir}/man7/*
206%dir %{_libdir}/%{name}
207%{_libdir}/*.so.*
208%{_libdir}/%{name}/*.so.*
209%exclude %{_libdir}/graphviz/*/*
210
211%files devel
212%defattr(-,root,root)
213%{_includedir}/%{name}
214%{_libdir}/*.so
215%{_libdir}/%{name}/*.so
216%{_libdir}/pkgconfig/*.pc
217%{_datadir}/%{name}/graphs
218%{_mandir}/man3/*.3.gz
219
220%files doc
221%defattr(-,root,root,-)
222%doc __doc/*
223
224%files guile
225%defattr(-,root,root,-)
226%{_libdir}/graphviz/guile/
227%{_mandir}/man3/gv.3guile*
228
229%files lua
230%defattr(-,root,root,-)
231%{_libdir}/graphviz/lua/
232%{_libdir}/lua*/*
233%{_mandir}/man3/gv.3lua*
234
235%files perl
236%defattr(-,root,root,-)
237%{_libdir}/graphviz/perl/
238%{perl_vendorarch}/*
239%{_mandir}/man3/gv.3perl*
240
241%files python
242%defattr(-,root,root,-)
243%{_libdir}/graphviz/python/
244%{_libdir}/python*/*
245%{_mandir}/man3/gv.3python*
246
247%files ruby
248%defattr(-,root,root,-)
249%{_libdir}/graphviz/ruby/
250%{_libdir}/*ruby*/*
251%{_mandir}/man3/gv.3ruby*
252
253%files tcl
254%defattr(-,root,root)
255%{_libdir}/%{name}/tcl/*
256%{_libdir}/tcl*/*
257%{_datadir}/%{name}/demo
258# hack to include gv.3tcl only if available
259#  always includes tcldot.3tcl, gdtclft.3tcl
260%{_mandir}/man3/*.3tcl*
261
262
263%changelog
264* Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-2
265- rebuilt with guile-2.2.
266
267* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
268- updated to 2.40.1.
269- dropped all patches.
270- imported Patch0 from rawhide.
271
272* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-4
273- rebuild with gcc-5.4.0
274
275* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
276- rebuild with ruby-2.2.3
277
278* Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
279- added Patch0-5 from Fedora
280- rebuilt with guile 2.0.11
281- changed BR: tcl-devel, tk-devel instead of tcl, tk
282- added lua subpackage
283
284* Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
285- update to 2.38.0
286
287* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
288- new upstream release
289
290* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
291- rebuilt with gd-2.1.0.
292
293* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
294- new upstream release
295
296* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
297- build with Tcl/Tk 8.5.7-1
298- stop running autoreconf
299- add Vendor and Distribution tags
300
301* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
302- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
303  - rewrite config_ruby.rb to build with ruby-1.9.3
304  - add search path for ruby/config.h to CPPFLAGS for configure
305
306* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
307- new upstream release
308- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
309- add BuildRequires: librsvg2-devel
310
311* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
312- add Patch10 to avoid build failure on ppc
313
314* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
315- new upstream release
316- built with rpm-4.8.1
317- split doc, guile, perl, python, ruby subpackage
318
319* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
320- rebuild with libtool-2.2.6a
321
322* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
323- new upstream release
324
325* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
326- rebuild with libXaw.so.7 (libXaw-1.0.5)
327
328* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
329- new upstream release
330
331* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
332- new upstream release
333- build with expat-2.0.1
334- add man7
335
336* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
337- rebuild with tcl/tk-8.4.16
338
339* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
340- new upstream release
341- add BuildPrereq: swig
342- delete BuildPrereq: gd-progs gd-devel
343- add --with-mylibgd and --disable-FEATURE to configure option
344- update %%files
345
346* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
347- added BuildPrereq: ruby-devel
348
349* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
350- new upstream release
351- add BuildPrereq: libtool-ltdl-devel
352- move pkgconfig files to %%{_libdir}/pkgconfig
353- add --disable-rpath --disable-static to configure option
354- add %%post to every package
355
356* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
357- new upstream release
358- BuildPrereq: tcl >= 8.4, tk >= 8.4
359- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
360- update %%files
361- remove lines about Vine2.6
362- change License to CPL
363
364* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
365- source upgrade
366- remove patch0 and commented lines
367
368* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
369- build for VineSeed
370
371* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
372- source upgrade
373- change spec to build both VineSeed and Vine2.5/2.6
374- add BuildPrereq: expat-devel and Requires: libexpat
375- add patch0 to build against freetype2-2.1.7
376- stop using autogen.sh script
377- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
378- add graphviz-tcl package (VineSeed)
379
380* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
381- rebuild for new Vine
382
383* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
384- import from offical site (src.rpm)
385
Note: See TracBrowser for help on using the repository browser.