source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 11329

Revision 11329, 10.1 KB checked in by tomop, 6 years ago (diff)

graphviz-2.40.1-1

Line 
1%define _unpackaged_files_terminate_build 1
2
3Name:           graphviz
4Summary:        Graph Visualization Tools
5Summary(ja):    グラフ可視化ツール
6Version:        2.40.1
7Release:        1%{?_dist_release}
8Group:          Applications/Graphics
9License:        EPL
10URL:            http://www.graphviz.org/
11
12Source0:        http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
13Patch0:         graphviz-2.40.1-visio.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  bison
17BuildRequires:  cairo-devel
18BuildRequires:  expat-devel
19BuildRequires:  flex
20BuildRequires:  fontconfig-devel
21BuildRequires:  freetype2-devel
22BuildRequires:  gd-devel
23BuildRequires:  gmp-devel
24BuildRequires:  gtk2-devel
25BuildRequires:  guile-devel
26BuildRequires:  libjpeg-turbo-devel
27BuildRequires:  libpng-devel
28BuildRequires:  libSM-devel
29BuildRequires:  libtool-ltdl-devel >= 2.2.6a
30BuildRequires:  libXaw-devel
31BuildRequires:  libXext-devel
32BuildRequires:  librsvg2-devel
33BuildRequires:  lua-devel
34BuildRequires:  m4
35BuildRequires:  perl
36BuildRequires:  python-devel
37BuildRequires:  ruby-devel
38BuildRequires:  swig
39BuildRequires:  tcl-devel >= 8.4
40BuildRequires:  tk-devel >= 8.4
41BuildRequires:  zlib-devel
42Requires:       urw-fonts
43
44# only for this release
45# BuildConflicts: graphviz-devel
46
47Vendor:         Project Vine
48Distribution:   Vine Linux
49Packager:       daisuke
50
51%description
52A collection of tools and tcl packages for the manipulation and layout
53of graphs (as in nodes and edges, not as in barcharts).
54
55%package devel
56Summary:        Development tools for version %{version} of %{name}
57Group:          Development/Libraries
58Requires:       %{name} = %{version}
59
60%description devel
61The %{name}-devel package contains the header files
62and man3 pages necessary for developing programs
63using version %{version} of the %{name} libraries.
64
65%package doc
66Summary: PDF and HTML documents for graphviz
67Group:   Applications/Documentation
68
69%description doc
70Provides some additional PDF and HTML documentation for graphviz.
71
72%package guile
73Group:          Applications/Graphics
74Summary:        Guile extension for graphviz
75Requires:       %{name} = %{version}-%{release}, guile
76
77%description guile
78Guile extension for graphviz.
79
80%package lua
81Group:          Applications/Graphics
82Summary:        Lua extension for graphviz
83Requires:       %{name} = %{version}-%{release}, lua
84
85%description lua
86Lua extension for graphviz.
87
88%package perl
89Group:    Applications/Graphics
90Summary:  Perl extension for graphviz
91Requires: %{name} = %{version}-%{release}
92Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
93
94%description perl
95Perl extension for graphviz.
96
97%package python
98Group:    Applications/Graphics
99Summary:  Python extension for graphviz
100Requires: %{name} = %{version}-%{release}
101Requires: python
102
103%description python
104Python extension for graphviz.
105
106%package ruby
107Group:    Applications/Graphics
108Summary:  Ruby extension for graphviz
109Requires: %{name} = %{version}-%{release}
110Requires: ruby
111
112%description ruby
113Ruby extension for graphviz.
114
115%package tcl
116Group:    Applications/Graphics
117Summary:  Tcl extension & tools for graphviz
118Requires: tcl >= 8.4, tk >= 8.4
119Requires: %{name} = %{version}
120
121%description tcl
122Various tcl packages (extensions) for the graphviz tools.
123
124
125%prep
126%setup -q
127%patch0 -p1 -b .visio
128
129%build
130autoreconf -if
131
132# using archdir instead of sitearchdir for Vine
133sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
134# Rewrite config_ruby.rb to work with Ruby 2.1
135sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
136sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
137
138# get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
139export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
140# XXX ix86 only used to have -ffast-math, let's use everywhere
141%{expand: %%define optflags %{optflags} -ffast-math}
142
143%configure \
144    --with-x \
145    --disable-static \
146    --with-mylibgd \
147    --with-ipsepcola \
148    --with-pangocairo \
149    --with-gdk-pixbuf \
150    --without-mylibgd \
151    --without-ming \
152    --without-qt \
153    --disable-sharp \
154    --enable-guile \
155    --disable-java \
156    --enable-lua \
157    --disable-ocaml \
158    --enable-perl \
159    --disable-php \
160    --enable-python \
161    --disable-r \
162    --enable-ruby \
163    --enable-swig \
164    --enable-tcl
165
166make %{?_smp_mflags}
167
168%install
169rm -rf $RPM_BUILD_ROOT __doc
170make DESTDIR=$RPM_BUILD_ROOT \
171    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
172    pkgconfigdir=%{_libdir}/pkgconfig \
173    install
174
175find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
176chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
177cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
178rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
184%post
185/sbin/ldconfig
186%{_bindir}/dot -c
187
188# if there is no dot after everything else is done, then remove config
189%postun
190if [ $1 -eq 0 ]; then
191    rm -f %{_libdir}/graphviz/config || :
192fi
193/sbin/ldconfig
194
195
196%files
197%defattr(-,root,root)
198%doc AUTHORS COPYING ChangeLog NEWS README
199%{_bindir}/*
200%dir %{_datadir}/%{name}
201%{_datadir}/%{name}/gvpr
202%{_datadir}/%{name}/lefty
203%{_mandir}/man1/*
204%{_mandir}/man7/*
205%dir %{_libdir}/%{name}
206%{_libdir}/*.so.*
207%{_libdir}/%{name}/*.so.*
208%exclude %{_libdir}/graphviz/*/*
209
210%files devel
211%defattr(-,root,root)
212%{_includedir}/%{name}
213%{_libdir}/*.so
214%{_libdir}/%{name}/*.so
215%{_libdir}/pkgconfig/*.pc
216%{_datadir}/%{name}/graphs
217%{_mandir}/man3/*.3.gz
218
219%files doc
220%defattr(-,root,root,-)
221%doc __doc/*
222
223%files guile
224%defattr(-,root,root,-)
225%{_libdir}/graphviz/guile/
226%{_mandir}/man3/gv.3guile*
227
228%files lua
229%defattr(-,root,root,-)
230%{_libdir}/graphviz/lua/
231%{_libdir}/lua*/*
232%{_mandir}/man3/gv.3lua*
233
234%files perl
235%defattr(-,root,root,-)
236%{_libdir}/graphviz/perl/
237%{perl_vendorarch}/*
238%{_mandir}/man3/gv.3perl*
239
240%files python
241%defattr(-,root,root,-)
242%{_libdir}/graphviz/python/
243%{_libdir}/python*/*
244%{_mandir}/man3/gv.3python*
245
246%files ruby
247%defattr(-,root,root,-)
248%{_libdir}/graphviz/ruby/
249%{_libdir}/*ruby*/*
250%{_mandir}/man3/gv.3ruby*
251
252%files tcl
253%defattr(-,root,root)
254%{_libdir}/%{name}/tcl/*
255%{_libdir}/tcl*/*
256%{_datadir}/%{name}/demo
257# hack to include gv.3tcl only if available
258#  always includes tcldot.3tcl, gdtclft.3tcl
259%{_mandir}/man3/*.3tcl*
260
261
262%changelog
263* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
264- updated to 2.40.1.
265- dropped all patches.
266- imported Patch0 from rawhide.
267
268* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-4
269- rebuild with gcc-5.4.0
270
271* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
272- rebuild with ruby-2.2.3
273
274* Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
275- added Patch0-5 from Fedora
276- rebuilt with guile 2.0.11
277- changed BR: tcl-devel, tk-devel instead of tcl, tk
278- added lua subpackage
279
280* Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
281- update to 2.38.0
282
283* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
284- new upstream release
285
286* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
287- rebuilt with gd-2.1.0.
288
289* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
290- new upstream release
291
292* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
293- build with Tcl/Tk 8.5.7-1
294- stop running autoreconf
295- add Vendor and Distribution tags
296
297* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
298- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
299  - rewrite config_ruby.rb to build with ruby-1.9.3
300  - add search path for ruby/config.h to CPPFLAGS for configure
301
302* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
303- new upstream release
304- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
305- add BuildRequires: librsvg2-devel
306
307* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
308- add Patch10 to avoid build failure on ppc
309
310* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
311- new upstream release
312- built with rpm-4.8.1
313- split doc, guile, perl, python, ruby subpackage
314
315* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
316- rebuild with libtool-2.2.6a
317
318* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
319- new upstream release
320
321* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
322- rebuild with libXaw.so.7 (libXaw-1.0.5)
323
324* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
325- new upstream release
326
327* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
328- new upstream release
329- build with expat-2.0.1
330- add man7
331
332* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
333- rebuild with tcl/tk-8.4.16
334
335* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
336- new upstream release
337- add BuildPrereq: swig
338- delete BuildPrereq: gd-progs gd-devel
339- add --with-mylibgd and --disable-FEATURE to configure option
340- update %%files
341
342* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
343- added BuildPrereq: ruby-devel
344
345* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
346- new upstream release
347- add BuildPrereq: libtool-ltdl-devel
348- move pkgconfig files to %%{_libdir}/pkgconfig
349- add --disable-rpath --disable-static to configure option
350- add %%post to every package
351
352* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
353- new upstream release
354- BuildPrereq: tcl >= 8.4, tk >= 8.4
355- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
356- update %%files
357- remove lines about Vine2.6
358- change License to CPL
359
360* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
361- source upgrade
362- remove patch0 and commented lines
363
364* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
365- build for VineSeed
366
367* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
368- source upgrade
369- change spec to build both VineSeed and Vine2.5/2.6
370- add BuildPrereq: expat-devel and Requires: libexpat
371- add patch0 to build against freetype2-2.1.7
372- stop using autogen.sh script
373- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
374- add graphviz-tcl package (VineSeed)
375
376* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
377- rebuild for new Vine
378
379* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
380- import from offical site (src.rpm)
381
Note: See TracBrowser for help on using the repository browser.