source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 9748

Revision 9748, 10.4 KB checked in by Takemikaduchi, 9 years ago (diff)

rebuild with ruby-2.2.3

Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Summary(ja):    グラフ可視化ツール
4Version:        2.38.0
5Release:        3%{?_dist_release}
6Group:          Applications/Graphics
7License:        EPL
8URL:            http://www.graphviz.org/
9
10Source0:        http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
11# Fix typo in testsuite (upstream ticket #2441).
12Patch0:         graphviz-2.38.0-rtest-fix.patch
13Patch1:         graphviz-2.38.0-find-fix.patch
14# Not upstream patch to fix build with OCaml > 4.02.0 (upstream) and Fedora.
15Patch2:         graphviz-2.38.0-ocaml-fix-ints.patch
16# Backported from upstream
17Patch3:         graphviz-2.38.0-format-string.patch
18# Make vimdot to work with vi (upstream ticket #2507)
19Patch4:         graphviz-2.38.0-vimdot-vi.patch
20Patch5:         graphviz-2.38.0-rbconfig.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23BuildRequires:  bison
24BuildRequires:  cairo-devel
25BuildRequires:  expat-devel
26BuildRequires:  flex
27BuildRequires:  fontconfig-devel
28BuildRequires:  freetype2-devel
29BuildRequires:  gd-devel
30BuildRequires:  gmp-devel
31BuildRequires:  gtk2-devel
32BuildRequires:  guile-devel
33BuildRequires:  libjpeg-turbo-devel
34BuildRequires:  libpng-devel
35BuildRequires:  libSM-devel
36BuildRequires:  libtool-ltdl-devel >= 2.2.6a
37BuildRequires:  libXaw-devel
38BuildRequires:  libXext-devel
39BuildRequires:  librsvg2-devel
40BuildRequires:  lua-devel
41BuildRequires:  m4
42BuildRequires:  perl
43BuildRequires:  python-devel
44BuildRequires:  ruby-devel
45BuildRequires:  swig
46BuildRequires:  tcl-devel >= 8.4
47BuildRequires:  tk-devel >= 8.4
48BuildRequires:  zlib-devel
49Requires:       urw-fonts
50
51# only for this release
52# BuildConflicts: graphviz-devel
53
54Vendor:         Project Vine
55Distribution:   Vine Linux
56Packager:       daisuke
57
58%description
59A collection of tools and tcl packages for the manipulation and layout
60of graphs (as in nodes and edges, not as in barcharts).
61
62%package devel
63Summary:        Development tools for version %{version} of %{name}
64Group:          Development/Libraries
65Requires:       %{name} = %{version}
66
67%description devel
68The %{name}-devel package contains the header files
69and man3 pages necessary for developing programs
70using version %{version} of the %{name} libraries.
71
72%package doc
73Summary: PDF and HTML documents for graphviz
74Group:   Applications/Documentation
75
76%description doc
77Provides some additional PDF and HTML documentation for graphviz.
78
79%package guile
80Group:          Applications/Graphics
81Summary:        Guile extension for graphviz
82Requires:       %{name} = %{version}-%{release}, guile
83
84%description guile
85Guile extension for graphviz.
86
87%package lua
88Group:          Applications/Graphics
89Summary:        Lua extension for graphviz
90Requires:       %{name} = %{version}-%{release}, lua
91
92%description lua
93Lua extension for graphviz.
94
95%package perl
96Group:    Applications/Graphics
97Summary:  Perl extension for graphviz
98Requires: %{name} = %{version}-%{release}
99Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
100
101%description perl
102Perl extension for graphviz.
103
104%package python
105Group:    Applications/Graphics
106Summary:  Python extension for graphviz
107Requires: %{name} = %{version}-%{release}
108Requires: python
109
110%description python
111Python extension for graphviz.
112
113%package ruby
114Group:    Applications/Graphics
115Summary:  Ruby extension for graphviz
116Requires: %{name} = %{version}-%{release}
117Requires: ruby
118
119%description ruby
120Ruby extension for graphviz.
121
122%package tcl
123Group:    Applications/Graphics
124Summary:  Tcl extension & tools for graphviz
125Requires: tcl >= 8.4, tk >= 8.4
126Requires: %{name} = %{version}
127
128%description tcl
129Various tcl packages (extensions) for the graphviz tools.
130
131
132%prep
133%setup -q
134%patch0 -p1 -b .rtest-fix
135%patch1 -p1 -b .find-fix
136%patch2 -p1
137%patch3 -p1 -b .format-string
138%patch4 -p1 -b .vimdot-vi
139%patch5 -p1 -b .rbconfig
140
141%build
142autoreconf -if
143
144# using archdir instead of sitearchdir for Vine
145sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
146# Rewrite config_ruby.rb to work with Ruby 2.1
147sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
148sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
149
150# get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
151export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
152# XXX ix86 only used to have -ffast-math, let's use everywhere
153%{expand: %%define optflags %{optflags} -ffast-math}
154
155%configure \
156    --with-x \
157    --disable-static \
158    --with-mylibgd \
159    --with-ipsepcola \
160    --with-pangocairo \
161    --with-gdk-pixbuf \
162    --without-mylibgd \
163    --without-ming \
164    --without-qt \
165    --disable-sharp \
166    --enable-guile \
167    --disable-java \
168    --enable-lua \
169    --disable-ocaml \
170    --enable-perl \
171    --disable-php \
172    --enable-python \
173    --disable-r \
174    --enable-ruby \
175    --enable-swig \
176    --enable-tcl
177
178make %{?_smp_mflags}
179
180%install
181rm -rf $RPM_BUILD_ROOT __doc
182make DESTDIR=$RPM_BUILD_ROOT \
183    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
184    pkgconfigdir=%{_libdir}/pkgconfig \
185    install
186
187find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
188chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
189cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
190rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
191
192%clean
193rm -rf $RPM_BUILD_ROOT
194
195# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
196%post
197/sbin/ldconfig
198%{_bindir}/dot -c
199
200# if there is no dot after everything else is done, then remove config
201%postun
202if [ $1 -eq 0 ]; then
203    rm -f %{_libdir}/graphviz/config || :
204fi
205/sbin/ldconfig
206
207
208%files
209%defattr(-,root,root)
210%doc AUTHORS COPYING ChangeLog NEWS README
211%{_bindir}/*
212%dir %{_datadir}/%{name}
213%{_datadir}/%{name}/gvpr
214%{_datadir}/%{name}/lefty
215%{_mandir}/man1/*
216%{_mandir}/man7/*
217%dir %{_libdir}/%{name}
218%{_libdir}/*.so.*
219%{_libdir}/%{name}/*.so.*
220%exclude %{_libdir}/graphviz/*/*
221
222%files devel
223%defattr(-,root,root)
224%{_includedir}/%{name}
225%{_libdir}/*.so
226%{_libdir}/%{name}/*.so
227%{_libdir}/pkgconfig/*.pc
228%{_datadir}/%{name}/graphs
229%{_mandir}/man3/*.3.gz
230
231%files doc
232%defattr(-,root,root,-)
233%doc __doc/*
234
235%files guile
236%defattr(-,root,root,-)
237%{_libdir}/graphviz/guile/
238%{_mandir}/man3/gv.3guile*
239
240%files lua
241%defattr(-,root,root,-)
242%{_libdir}/graphviz/lua/
243%{_libdir}/lua*/*
244%{_mandir}/man3/gv.3lua*
245
246%files perl
247%defattr(-,root,root,-)
248%{_libdir}/graphviz/perl/
249%{perl_vendorarch}/*
250%{_mandir}/man3/gv.3perl*
251
252%files python
253%defattr(-,root,root,-)
254%{_libdir}/graphviz/python/
255%{_libdir}/python*/*
256%{_mandir}/man3/gv.3python*
257
258%files ruby
259%defattr(-,root,root,-)
260%{_libdir}/graphviz/ruby/
261%{_libdir}/*ruby*/*
262%{_mandir}/man3/gv.3ruby*
263
264%files tcl
265%defattr(-,root,root)
266%{_libdir}/%{name}/tcl/*
267%{_libdir}/tcl*/*
268%{_datadir}/%{name}/demo
269# hack to include gv.3tcl only if available
270#  always includes tcldot.3tcl, gdtclft.3tcl
271%{_mandir}/man3/*.3tcl*
272%{_mandir}/man3/tkspline.3tk*
273
274
275%changelog
276* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
277- rebuild with ruby-2.2.3
278
279* Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
280- added Patch0-5 from Fedora
281- rebuilt with guile 2.0.11
282- changed BR: tcl-devel, tk-devel instead of tcl, tk
283- added lua subpackage
284
285* Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
286- update to 2.38.0
287
288* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
289- new upstream release
290
291* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
292- rebuilt with gd-2.1.0.
293
294* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
295- new upstream release
296
297* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
298- build with Tcl/Tk 8.5.7-1
299- stop running autoreconf
300- add Vendor and Distribution tags
301
302* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
303- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
304  - rewrite config_ruby.rb to build with ruby-1.9.3
305  - add search path for ruby/config.h to CPPFLAGS for configure
306
307* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
308- new upstream release
309- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
310- add BuildRequires: librsvg2-devel
311
312* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
313- add Patch10 to avoid build failure on ppc
314
315* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
316- new upstream release
317- built with rpm-4.8.1
318- split doc, guile, perl, python, ruby subpackage
319
320* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
321- rebuild with libtool-2.2.6a
322
323* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
324- new upstream release
325
326* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
327- rebuild with libXaw.so.7 (libXaw-1.0.5)
328
329* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
330- new upstream release
331
332* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
333- new upstream release
334- build with expat-2.0.1
335- add man7
336
337* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
338- rebuild with tcl/tk-8.4.16
339
340* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
341- new upstream release
342- add BuildPrereq: swig
343- delete BuildPrereq: gd-progs gd-devel
344- add --with-mylibgd and --disable-FEATURE to configure option
345- update %%files
346
347* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
348- added BuildPrereq: ruby-devel
349
350* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
351- new upstream release
352- add BuildPrereq: libtool-ltdl-devel
353- move pkgconfig files to %%{_libdir}/pkgconfig
354- add --disable-rpath --disable-static to configure option
355- add %%post to every package
356
357* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
358- new upstream release
359- BuildPrereq: tcl >= 8.4, tk >= 8.4
360- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
361- update %%files
362- remove lines about Vine2.6
363- change License to CPL
364
365* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
366- source upgrade
367- remove patch0 and commented lines
368
369* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
370- build for VineSeed
371
372* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
373- source upgrade
374- change spec to build both VineSeed and Vine2.5/2.6
375- add BuildPrereq: expat-devel and Requires: libexpat
376- add patch0 to build against freetype2-2.1.7
377- stop using autogen.sh script
378- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
379- add graphviz-tcl package (VineSeed)
380
381* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
382- rebuild for new Vine
383
384* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
385- import from offical site (src.rpm)
386
Note: See TracBrowser for help on using the repository browser.