source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 2015

Revision 2015, 7.6 KB checked in by inagaki, 14 years ago (diff)

update: graphviz, anjuta-extras

Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Version:        2.26.3
4Release:        1%{?_dist_release}
5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
8
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  bison
14BuildRequires:  cairo-devel
15BuildRequires:  expat-devel
16BuildRequires:  flex
17BuildRequires:  fontconfig-devel
18BuildRequires:  freetype2-devel
19BuildRequires:  gd-devel
20BuildRequires:  gtk2-devel
21BuildRequires:  guile-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libpng-devel
24BuildRequires:  libSM-devel
25BuildRequires:  libtool-ltdl-devel >= 2.2.6a
26BuildRequires:  libXaw-devel
27BuildRequires:  libXext-devel
28BuildRequires:  m4
29BuildRequires:  perl
30BuildRequires:  python-devel
31BuildRequires:  ruby-devel
32BuildRequires:  swig
33BuildRequires:  tcl >= 8.4
34BuildRequires:  tk >= 8.4
35BuildRequires:  zlib-devel
36Requires:       urw-fonts
37
38# only for this release
39BuildConflicts: graphviz-devel
40
41%description
42A collection of tools and tcl packages for the manipulation and layout
43of graphs (as in nodes and edges, not as in barcharts).
44
45%package devel
46Group:          Development/Libraries
47Summary:        Development tools for version %{version} of %{name}
48Requires:       %{name} = %{version}
49
50%description devel
51The %{name}-devel package contains the header files
52and man3 pages necessary for developing programs
53using version %{version} of the %{name} libraries.
54
55%package doc
56Summary: PDF and HTML documents for graphviz
57Group:   Applications/Documentation
58
59%description doc
60Provides some additional PDF and HTML documentation for graphviz.
61
62%package guile
63Group:          Applications/Graphics
64Summary:        Guile extension for graphviz
65Requires:       %{name} = %{version}-%{release}, guile
66
67%description guile
68Guile extension for graphviz.
69
70%package perl
71Group:    Applications/Graphics
72Summary:  Perl extension for graphviz
73Requires: %{name} = %{version}-%{release}
74Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
75
76%description perl
77Perl extension for graphviz.
78
79%package python
80Group:    Applications/Graphics
81Summary:  Python extension for graphviz
82Requires: %{name} = %{version}-%{release}
83Requires: python
84
85%description python
86Python extension for graphviz.
87
88%package ruby
89Group:    Applications/Multimedia
90Summary:  Ruby extension for graphviz
91Requires: %{name} = %{version}-%{release}
92Requires: ruby
93
94%description ruby
95Ruby extension for graphviz.
96
97%package tcl
98Group:    Applications/Graphics
99Summary:  Tcl extension & tools for graphviz
100Requires: tcl >= 8.4, tk >= 8.4
101Requires: %{name} = %{version}
102
103%description tcl
104Various tcl packages (extensions) for the graphviz tools.
105
106
107%prep
108%setup -q
109
110# using archdir instead of sitearchdir for Vine
111sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
112
113%build
114# XXX ix86 only used to have -ffast-math, let's use everywhere
115%{expand: %%define optflags %{optflags} -ffast-math}
116
117%configure \
118    --with-x \
119    --disable-static \
120    --with-mylibgd \
121    --with-ipsepcola \
122    --with-pangocairo \
123    --with-gdk-pixbuf \
124    --without-mylibgd \
125    --without-ming \
126    --disable-sharp \
127    --enable-guile \
128    --enable-io \
129    --disable-java \
130    --disable-lua \
131    --disable-ocaml \
132    --enable-perl \
133    --disable-php \
134    --enable-python \
135    --disable-r \
136    --enable-ruby \
137    --enable-tcl
138
139make %{?_smp_mflags}
140
141%install
142rm -rf $RPM_BUILD_ROOT __doc
143make DESTDIR=$RPM_BUILD_ROOT \
144    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
145    pkgconfigdir=%{_libdir}/pkgconfig \
146    install
147
148find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
149chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
150cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
151rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
157%post
158/sbin/ldconfig
159%{_bindir}/dot -c
160
161# if there is no dot after everything else is done, then remove config
162%postun
163if [ $1 -eq 0 ]; then
164    rm -f %{_libdir}/graphviz/config || :
165fi
166/sbin/ldconfig
167
168
169%files
170%defattr(-,root,root)
171%doc AUTHORS COPYING ChangeLog NEWS README
172%{_bindir}/*
173%dir %{_datadir}/%{name}
174%{_datadir}/%{name}/lefty
175%{_mandir}/man1/*
176%{_mandir}/man7/*
177%dir %{_libdir}/%{name}
178%{_libdir}/*.so.*
179%{_libdir}/%{name}/*.so.*
180%exclude %{_libdir}/graphviz/*/*
181
182%files devel
183%defattr(-,root,root)
184%{_includedir}/%{name}
185%{_libdir}/*.so
186%{_libdir}/%{name}/*.so
187%{_libdir}/pkgconfig/*.pc
188%{_datadir}/%{name}/graphs
189%{_mandir}/man3/*.3.gz
190
191%files doc
192%defattr(-,root,root,-)
193%doc __doc/*
194
195%files guile
196%defattr(-,root,root,-)
197%{_libdir}/graphviz/guile/
198%{_mandir}/man3/gv.3guile*
199
200%files perl
201%defattr(-,root,root,-)
202%{_libdir}/graphviz/perl/
203%{perl_vendorarch}/*
204%{_mandir}/man3/gv.3perl*
205
206%files python
207%defattr(-,root,root,-)
208%{_libdir}/graphviz/python/
209%{_libdir}/python*/*
210%{_mandir}/man3/gv.3python*
211
212%files ruby
213%defattr(-,root,root,-)
214%{_libdir}/graphviz/ruby/
215%{rarchdir}/*
216%{_mandir}/man3/gv.3ruby*
217
218%files tcl
219%defattr(-,root,root)
220%{_libdir}/%{name}/tcl/*
221%{_libdir}/tcl*/*
222%{_datadir}/%{name}/demo
223# hack to include gv.3tcl only if available
224#  always includes tcldot.3tcl, gdtclft.3tcl
225%{_mandir}/man3/*.3tcl*
226%{_mandir}/man3/tkspline.3tk*
227
228
229%changelog
230* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
231- new upstream release
232- built with rpm-4.8.1
233- split doc, guile, perl, python, ruby subpackage
234
235* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
236- rebuild with libtool-2.2.6a
237
238* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
239- new upstream release
240
241* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
242- rebuild with libXaw.so.7 (libXaw-1.0.5)
243
244* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
245- new upstream release
246
247* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
248- new upstream release
249- build with expat-2.0.1
250- add man7
251
252* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
253- rebuild with tcl/tk-8.4.16
254
255* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
256- new upstream release
257- add BuildPrereq: swig
258- delete BuildPrereq: gd-progs gd-devel
259- add --with-mylibgd and --disable-FEATURE to configure option
260- update %%files
261
262* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
263- added BuildPrereq: ruby-devel
264
265* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
266- new upstream release
267- add BuildPrereq: libtool-ltdl-devel
268- move pkgconfig files to %%{_libdir}/pkgconfig
269- add --disable-rpath --disable-static to configure option
270- add %%post to every package
271
272* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
273- new upstream release
274- BuildPrereq: tcl >= 8.4, tk >= 8.4
275- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
276- update %%files
277- remove lines about Vine2.6
278- change License to CPL
279
280* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
281- source upgrade
282- remove patch0 and commented lines
283
284* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
285- build for VineSeed
286
287* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
288- source upgrade
289- change spec to build both VineSeed and Vine2.5/2.6
290- add BuildPrereq: expat-devel and Requires: libexpat
291- add patch0 to build against freetype2-2.1.7
292- stop using autogen.sh script
293- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
294- add graphviz-tcl package (VineSeed)
295
296* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
297- rebuild for new Vine
298
299* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
300- import from offical site (src.rpm)
301
Note: See TracBrowser for help on using the repository browser.