source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 7120

Revision 7120, 8.5 KB checked in by daisuke, 12 years ago (diff)

graphviz:

  • re-enable ruby binding, which is accidentally disabled in 2.28.0-1
    • rewrite config_ruby.rb to build with ruby-1.9.3
    • add search path for ruby/config.h to CPPFLAGS for configure
RevLine 
[521]1Name:           graphviz
[2015]2Summary:        Graph Visualization Tools
[7105]3Version:        2.28.0
[7120]4Release:        2%{?_dist_release}
[521]5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
[2015]8
[521]9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
[2015]10
[521]11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
[2015]13BuildRequires:  bison
14BuildRequires:  cairo-devel
15BuildRequires:  expat-devel
16BuildRequires:  flex
17BuildRequires:  fontconfig-devel
18BuildRequires:  freetype2-devel
19BuildRequires:  gd-devel
20BuildRequires:  gtk2-devel
21BuildRequires:  guile-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libpng-devel
24BuildRequires:  libSM-devel
[521]25BuildRequires:  libtool-ltdl-devel >= 2.2.6a
[2015]26BuildRequires:  libXaw-devel
27BuildRequires:  libXext-devel
[7105]28BuildRequires:  librsvg2-devel
[2015]29BuildRequires:  m4
30BuildRequires:  perl
31BuildRequires:  python-devel
32BuildRequires:  ruby-devel
33BuildRequires:  swig
34BuildRequires:  tcl >= 8.4
35BuildRequires:  tk >= 8.4
36BuildRequires:  zlib-devel
37Requires:       urw-fonts
[521]38
[2015]39# only for this release
40BuildConflicts: graphviz-devel
41
[521]42%description
43A collection of tools and tcl packages for the manipulation and layout
44of graphs (as in nodes and edges, not as in barcharts).
45
46%package devel
47Group:          Development/Libraries
48Summary:        Development tools for version %{version} of %{name}
49Requires:       %{name} = %{version}
50
51%description devel
52The %{name}-devel package contains the header files
53and man3 pages necessary for developing programs
54using version %{version} of the %{name} libraries.
55
[2015]56%package doc
57Summary: PDF and HTML documents for graphviz
58Group:   Applications/Documentation
59
60%description doc
61Provides some additional PDF and HTML documentation for graphviz.
62
63%package guile
64Group:          Applications/Graphics
65Summary:        Guile extension for graphviz
66Requires:       %{name} = %{version}-%{release}, guile
67
68%description guile
69Guile extension for graphviz.
70
71%package perl
72Group:    Applications/Graphics
73Summary:  Perl extension for graphviz
74Requires: %{name} = %{version}-%{release}
75Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
76
77%description perl
78Perl extension for graphviz.
79
80%package python
81Group:    Applications/Graphics
82Summary:  Python extension for graphviz
83Requires: %{name} = %{version}-%{release}
84Requires: python
85
86%description python
87Python extension for graphviz.
88
89%package ruby
90Group:    Applications/Multimedia
91Summary:  Ruby extension for graphviz
92Requires: %{name} = %{version}-%{release}
93Requires: ruby
94
95%description ruby
96Ruby extension for graphviz.
97
98%package tcl
99Group:    Applications/Graphics
100Summary:  Tcl extension & tools for graphviz
101Requires: tcl >= 8.4, tk >= 8.4
102Requires: %{name} = %{version}
103
104%description tcl
105Various tcl packages (extensions) for the graphviz tools.
106
107
[521]108%prep
109%setup -q
110
[2015]111# using archdir instead of sitearchdir for Vine
112sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
113
[2021]114autoreconf -f -i
115
[521]116%build
[7120]117# Rewrite config_ruby.rb to work with Ruby 1.9
118sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
119sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
120export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
121
[2015]122# XXX ix86 only used to have -ffast-math, let's use everywhere
123%{expand: %%define optflags %{optflags} -ffast-math}
[521]124
[2015]125%configure \
126    --with-x \
127    --disable-static \
128    --with-mylibgd \
129    --with-ipsepcola \
130    --with-pangocairo \
131    --with-gdk-pixbuf \
132    --without-mylibgd \
133    --without-ming \
134    --disable-sharp \
135    --enable-guile \
136    --enable-io \
137    --disable-java \
138    --disable-lua \
139    --disable-ocaml \
140    --enable-perl \
141    --disable-php \
142    --enable-python \
143    --disable-r \
144    --enable-ruby \
145    --enable-tcl
[521]146
[2015]147make %{?_smp_mflags}
148
[521]149%install
[2015]150rm -rf $RPM_BUILD_ROOT __doc
151make DESTDIR=$RPM_BUILD_ROOT \
152    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
153    pkgconfigdir=%{_libdir}/pkgconfig \
154    install
[521]155
156find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
157chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
158cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
159rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
160
[2015]161%clean
162rm -rf $RPM_BUILD_ROOT
163
[521]164# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
165%post
[2015]166/sbin/ldconfig
[521]167%{_bindir}/dot -c
168
[2015]169# if there is no dot after everything else is done, then remove config
170%postun
171if [ $1 -eq 0 ]; then
172    rm -f %{_libdir}/graphviz/config || :
173fi
174/sbin/ldconfig
[521]175
176
177%files
178%defattr(-,root,root)
[2015]179%doc AUTHORS COPYING ChangeLog NEWS README
[521]180%{_bindir}/*
181%dir %{_datadir}/%{name}
182%{_datadir}/%{name}/lefty
183%{_mandir}/man1/*
184%{_mandir}/man7/*
185%dir %{_libdir}/%{name}
186%{_libdir}/*.so.*
187%{_libdir}/%{name}/*.so.*
188%exclude %{_libdir}/graphviz/*/*
189
190%files devel
191%defattr(-,root,root)
192%{_includedir}/%{name}
193%{_libdir}/*.so
194%{_libdir}/%{name}/*.so
195%{_libdir}/pkgconfig/*.pc
196%{_datadir}/%{name}/graphs
[2015]197%{_mandir}/man3/*.3.gz
[521]198
[2015]199%files doc
200%defattr(-,root,root,-)
201%doc __doc/*
202
203%files guile
204%defattr(-,root,root,-)
205%{_libdir}/graphviz/guile/
206%{_mandir}/man3/gv.3guile*
207
208%files perl
209%defattr(-,root,root,-)
210%{_libdir}/graphviz/perl/
211%{perl_vendorarch}/*
212%{_mandir}/man3/gv.3perl*
213
214%files python
215%defattr(-,root,root,-)
216%{_libdir}/graphviz/python/
217%{_libdir}/python*/*
218%{_mandir}/man3/gv.3python*
219
220%files ruby
221%defattr(-,root,root,-)
222%{_libdir}/graphviz/ruby/
[7120]223%{_libdir}/*ruby*/*
224%{_mandir}/man3/gv.3ruby*
[2015]225
226%files tcl
227%defattr(-,root,root)
228%{_libdir}/%{name}/tcl/*
229%{_libdir}/tcl*/*
230%{_datadir}/%{name}/demo
231# hack to include gv.3tcl only if available
232#  always includes tcldot.3tcl, gdtclft.3tcl
233%{_mandir}/man3/*.3tcl*
234%{_mandir}/man3/tkspline.3tk*
235
236
[521]237%changelog
[7120]238* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
239- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
240  - rewrite config_ruby.rb to build with ruby-1.9.3
241  - add search path for ruby/config.h to CPPFLAGS for configure
242
[7105]243* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
244- new upstream release
245- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
246- add BuildRequires: librsvg2-devel
247
[2021]248* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
249- add Patch10 to avoid build failure on ppc
250
[2015]251* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
252- new upstream release
253- built with rpm-4.8.1
254- split doc, guile, perl, python, ruby subpackage
255
[521]256* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
257- rebuild with libtool-2.2.6a
258
259* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
260- new upstream release
261
262* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
263- rebuild with libXaw.so.7 (libXaw-1.0.5)
264
265* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
266- new upstream release
267
268* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
269- new upstream release
270- build with expat-2.0.1
271- add man7
272
273* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
274- rebuild with tcl/tk-8.4.16
275
276* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
277- new upstream release
278- add BuildPrereq: swig
279- delete BuildPrereq: gd-progs gd-devel
280- add --with-mylibgd and --disable-FEATURE to configure option
281- update %%files
282
283* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
284- added BuildPrereq: ruby-devel
285
286* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
287- new upstream release
288- add BuildPrereq: libtool-ltdl-devel
289- move pkgconfig files to %%{_libdir}/pkgconfig
290- add --disable-rpath --disable-static to configure option
291- add %%post to every package
292
293* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
294- new upstream release
295- BuildPrereq: tcl >= 8.4, tk >= 8.4
296- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
297- update %%files
298- remove lines about Vine2.6
299- change License to CPL
300
301* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
302- source upgrade
303- remove patch0 and commented lines
304
305* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
306- build for VineSeed
307
308* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
309- source upgrade
310- change spec to build both VineSeed and Vine2.5/2.6
311- add BuildPrereq: expat-devel and Requires: libexpat
312- add patch0 to build against freetype2-2.1.7
313- stop using autogen.sh script
314- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
315- add graphviz-tcl package (VineSeed)
316
317* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
318- rebuild for new Vine
319
320* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
321- import from offical site (src.rpm)
322
Note: See TracBrowser for help on using the repository browser.