source: projects/specs/trunk/g/gpsd/gpsd-vl.spec @ 7583

Revision 7583, 9.7 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3
4Summary: Service daemon for mediating access to a GPS
5Summary(ja): GPS にアクセスするためのサービスデーモン
6
7Name: gpsd
8Version: 3.8
9Release: 1%{?_dist_release}
10
11Group: System Environment/Daemons
12License: BSD
13URL: http://developer.berlios.de/projects/gpsd/
14Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
15Source10: gpsd.init
16Source11: gpsd.sysconfig
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19BuildRequires: scons
20BuildRequires: chrpath
21BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
22BuildRequires: libusb1-devel desktop-file-utils
23BuildRequires: libudev-devel
24
25Requires: udev
26Requires(post): /sbin/ldconfig
27Requires(post): /sbin/chkconfig
28Requires(preun): initscripts
29Requires(preun): /sbin/chkconfig
30Requires(postun): /sbin/ldconfig
31
32%description
33gpsd is a service daemon that mediates access to a GPS sensor
34connected to the host computer by serial or USB interface, making its
35data on the location/course/velocity of the sensor available to be
36queried on TCP port 2947 of the host computer.  With gpsd, multiple
37GPS client applications (such as navigational and wardriving software)
38can share access to a GPS without contention or loss of data.  Also,
39gpsd responds to queries with a format that is substantially easier to
40parse than NMEA 0183. 
41
42%package devel
43Summary: Client libraries in C and Python for talking to a running gpsd or GPS
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: pkgconfig
47
48%description devel
49This package provides C header files and python modules for the gpsd shared
50libraries that manage access to a GPS for applications
51
52%package clients
53Summary: Clients for gpsd
54Summary(ja): gpsd 用クライアント
55Group: Applications/System
56
57%description clients
58xgps is a simple test client for gpsd with an X interface. It displays
59current GPS position/time/velocity information and (for GPSes that
60support the feature) the locations of accessible satellites.
61
62xgpsspeed is a speedometer that uses position information from the GPS.
63It accepts an -h option and optional argument as for gps, or a -v option
64to dump the package version and exit. Additionally, it accepts -rv
65(reverse video) and -nc (needle color) options.
66
67cgps resembles xgps, but without the pictorial satellite display.  It
68can run on a serial terminal or terminal emulator.
69
70
71%prep
72%setup -q
73
74
75%build
76scons %{_smp_mflags}                    \
77        prefix=%{_prefix}                       \
78        bindir=%{_bindir}                       \
79        includedir=%{_includedir}       \
80        libdir=%{_libdir}                       \
81        sbindir=%{_sbindir}                     \
82        mandir=%{_mandir}                       \
83        docdir=%{_docdir}                       \
84        pkgconfigdir=%{_libdir}/pkgconfig
85
86scons build
87
88%install
89rm -rf $RPM_BUILD_ROOT
90export DESTDIR=$RPM_BUILD_ROOT
91scons install
92
93# init scripts
94%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
95%{__install} -p -m 0755 %{SOURCE10} \
96        %{buildroot}%{_sysconfdir}/init.d/gpsd
97
98%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
99%{__install} -p -m 0644 %{SOURCE11} \
100        %{buildroot}%{_sysconfdir}/sysconfig/gpsd
101
102# udev rules
103%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/udev/rules.d
104%{__install} -p -m 0644 gpsd.rules \
105        %{buildroot}%{_sysconfdir}/udev/rules.d/99-gpsd.rules
106
107# hotplug script
108%{__install} -d -m 0755 %{buildroot}/lib/udev
109%{__install} -p -m 0755 gpsd.hotplug %{buildroot}/lib/udev
110
111# remove .la files
112find %{buildroot} -name '*.la' -exec rm -f {} ';'
113
114# fix non-executable python script
115%{__chmod} +x %{buildroot}%{python_sitearch}/gps/gps.py
116
117# Install the .desktop files
118desktop-file-install \
119        --dir %{buildroot}%{_datadir}/applications \
120        packaging/X11/xgps.desktop
121desktop-file-install \
122        --dir %{buildroot}%{_datadir}/applications \
123        packaging/X11/xgpsspeed.desktop
124
125# Install logo icon for .desktop files
126%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
127%{__install} -p -m 0644 packaging/X11/gpsd-logo.png %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
128
129
130%clean
131rm -rf %{buildroot}
132
133%post
134/sbin/ldconfig
135/sbin/chkconfig --add %{name}
136
137%preun
138if [ $1 = 0 ]; then
139        /sbin/service %{name} stop > /dev/null 2>&1 || true
140        /sbin/chkconfig --del %{name}
141fi
142
143%postun -p /sbin/ldconfig
144
145
146%files
147%defattr(-,root,root,-)
148%doc README INSTALL COPYING
149%config(noreplace) %{_sysconfdir}/init.d/%{name}
150%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
151%config(noreplace) %{_sysconfdir}/udev/rules.d/*
152%{_sbindir}/gpsd
153%{_sbindir}/gpsdctl
154%{_bindir}/gegps
155%{_bindir}/gpsprof
156%{_bindir}/gpsmon
157%{_bindir}/gpsctl
158%{_libdir}/libgps*.so.*
159/lib/udev/gpsd*
160%{python_sitearch}/gps*
161%exclude %{python_sitearch}/gps/fake*
162%{_mandir}/man8/gpsd.8*
163%{_mandir}/man8/gpsdctl.8*
164%{_mandir}/man8/gpsinit.8*
165%{_mandir}/man1/gegps.1*
166%{_mandir}/man1/gpsprof.1*
167%{_mandir}/man1/gpsmon.1*
168%{_mandir}/man1/gpsctl.1*
169
170%files devel
171%defattr(-,root,root,-)
172%doc TODO
173%{_bindir}/gpsfake
174%{_libdir}/libgps*.so
175%{_libdir}/pkgconfig/*.pc
176%{python_sitearch}/gps/fake*
177%{_includedir}/gps.h
178%{_includedir}/libgpsmm.h
179%{_mandir}/man1/gpsfake.1*
180%{_mandir}/man3/libQgpsmm.3*
181%{_mandir}/man3/libgps.3*
182%{_mandir}/man3/libgpsmm.3*
183%{_mandir}/man3/libgpsd.3*
184%{_mandir}/man5/gpsd_json.5*
185%{_mandir}/man5/srec.5*
186
187%files clients
188%defattr(-,root,root,-)
189%{_bindir}/cgps
190%{_bindir}/gpscat
191%{_bindir}/gpsdecode
192%{_bindir}/gpspipe
193%{_bindir}/gpxlogger
194%{_bindir}/lcdgps
195%{_bindir}/xgps
196%{_bindir}/xgpsspeed
197%{_mandir}/man1/gps.1*
198%{_mandir}/man1/gpsdecode.1*
199%{_mandir}/man1/gpspipe.1*
200%{_mandir}/man1/lcdgps.1*
201%{_mandir}/man1/xgps.1*
202%{_mandir}/man1/xgpsspeed.1*
203%{_mandir}/man1/cgps.1*
204%{_mandir}/man1/gpscat.1*
205%{_datadir}/applications/*.desktop
206%dir %{_datadir}/gpsd
207%{_datadir}/gpsd/gpsd-logo.png
208
209
210%changelog
211* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
212- new upstream release
213
214* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.7-1
215- update to 3.7
216- remove old patches
217- add BuildRequires: scons, chrpath
218
219* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-3
220- rebuild with python-2.7.2
221
222* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.95-2
223- rebuilt with rpm-4.8.1 for pkg-config
224
225* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
226- new upstream release
227- merge spec, patch, source from fedora
228
229* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
230- add BuildRequires: libXp-devel
231
232* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
233- rebuilt with python-2.6.4
234
235* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
236- initial build for Vine Linux
237
238* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
239- Rebuild for Python 2.6
240
241* Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
242- moving gpspacket.so python lib to main package
243- adding zero.patch to make ZEROIZE error go away on fedora 7
244
245* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
246- update to 2.37
247- removed install-gpsd_config.h.patch
248- installed pkgconfig files in devel package
249- added patch to install python modules in sitearch
250- removing rpath from inclucded libtool
251- moving X11 app-defaults to datadir
252- using macros for commands in install; using install instead of cp and mkdir
253- cleaning up spaces/tabs for rpmlint
254
255* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
256- Autorebuild for GCC 4.3
257
258* Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
259- Patch Makefile to also install gpsd_config.h as needed by
260  libgpsmm.h.  Redhat BZ 253433.
261
262* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
263- Make sure the logo is actually included (via the spec file).
264  I need to wake up before I try even trivial updates. 
265
266* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
267- Learn how to use search and replace (aka fix all instances of
268  gpsd-logo.png spelled incorrectly as gspd-logo.png).
269
270* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
271- Fix desktop file and logo file name.
272
273* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
274- Include icon for .desktop files per BZ 241428
275
276* Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
277- Bump release for FE5 -> Fedora 7 upgrade path.
278
279* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
280- BR python-devel instead of python to make it build. 
281
282* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
283- Upgrade to 2.34.
284- Get rid of %%makeinstall (which was never needed).
285- Possibly fix hotplug issuses (BZ 219750).
286- Use %%python_sitelib for python site-files stuff.
287
288* Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
289- Rebuild to pull in new version of python.
290
291* Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
292- Remove openmotif requirment, and switch to lesstif.
293
294* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
295- Bump release for rebuild in prep. for FC6.
296
297* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
298- Actually, was a missing BR glib-dbus-devel. Ooops.
299
300* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
301- Missing BR glib-devel
302
303* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
304- Update to version 2.33
305
306* Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
307- Don't --enable-tnt in build as it causes some gpses to not work
308  properly with sattelite view mode.  See bugzilla bug 189220.
309
310* Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
311- Add dbus-glib to BuildRequires as needed for build.
312
313* Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
314- Include xmlto and python in buildrequires so things build right.
315- Don't package static library file. 
316
317* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
318- Use ye olde %%{?dist} tag.
319
320* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
321- Initial Fedora Extras specfile
Note: See TracBrowser for help on using the repository browser.