source: projects/specs/trunk/g/gpsd/gpsd-vl.spec @ 10570

Revision 10570, 10.1 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3
4Summary: Service daemon for mediating access to a GPS
5Summary(ja): GPS にアクセスするためのサービスデーモン
6
7Name: gpsd
8Version: 3.15
9Release: 2%{?_dist_release}
10
11Group: System Environment/Daemons
12License: BSD
13URL: http://www.catb.org/gpsd/
14Source0: http://download-mirror.savannah.gnu.org/releases/gpsd/%{name}-%{version}.tar.gz
15Source10: gpsd.init
16Source11: gpsd.sysconfig
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19BuildRequires: scons
20BuildRequires: chrpath
21BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
22BuildRequires: libusb1-devel desktop-file-utils
23BuildRequires: eudev-libudev-devel
24
25Requires: udev
26Requires(post): /sbin/ldconfig
27Requires(post): /sbin/chkconfig
28Requires(preun): initscripts
29Requires(preun): /sbin/chkconfig
30Requires(postun): /sbin/ldconfig
31
32%description
33gpsd is a service daemon that mediates access to a GPS sensor
34connected to the host computer by serial or USB interface, making its
35data on the location/course/velocity of the sensor available to be
36queried on TCP port 2947 of the host computer.  With gpsd, multiple
37GPS client applications (such as navigational and wardriving software)
38can share access to a GPS without contention or loss of data.  Also,
39gpsd responds to queries with a format that is substantially easier to
40parse than NMEA 0183. 
41
42%package devel
43Summary: Client libraries in C and Python for talking to a running gpsd or GPS
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: pkgconfig
47
48%description devel
49This package provides C header files and python modules for the gpsd shared
50libraries that manage access to a GPS for applications
51
52%package clients
53Summary: Clients for gpsd
54Summary(ja): gpsd 用クライアント
55Group: Applications/System
56
57%description clients
58xgps is a simple test client for gpsd with an X interface. It displays
59current GPS position/time/velocity information and (for GPSes that
60support the feature) the locations of accessible satellites.
61
62xgpsspeed is a speedometer that uses position information from the GPS.
63It accepts an -h option and optional argument as for gps, or a -v option
64to dump the package version and exit. Additionally, it accepts -rv
65(reverse video) and -nc (needle color) options.
66
67cgps resembles xgps, but without the pictorial satellite display.  It
68can run on a serial terminal or terminal emulator.
69
70
71%prep
72%setup -q
73
74
75%build
76scons %{_smp_mflags}                    \
77        prefix=%{_prefix}                       \
78        bindir=%{_bindir}                       \
79        includedir=%{_includedir}       \
80        libdir=%{_libdir}                       \
81        sbindir=%{_sbindir}                     \
82        mandir=%{_mandir}                       \
83        docdir=%{_docdir}                       \
84        pkgconfigdir=%{_libdir}/pkgconfig
85
86scons build
87
88%install
89rm -rf $RPM_BUILD_ROOT
90export DESTDIR=$RPM_BUILD_ROOT
91scons install
92
93# init scripts
94%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
95%{__install} -p -m 0755 %{SOURCE10} \
96        %{buildroot}%{_sysconfdir}/init.d/gpsd
97
98%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
99%{__install} -p -m 0644 %{SOURCE11} \
100        %{buildroot}%{_sysconfdir}/sysconfig/gpsd
101
102# udev rules
103%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/udev/rules.d
104%{__install} -p -m 0644 gpsd.rules \
105        %{buildroot}%{_sysconfdir}/udev/rules.d/99-gpsd.rules
106
107# hotplug script
108%{__install} -d -m 0755 %{buildroot}/lib/udev
109%{__install} -p -m 0755 gpsd.hotplug %{buildroot}/lib/udev
110
111# remove .la files
112find %{buildroot} -name '*.la' -exec rm -f {} ';'
113
114# fix non-executable python script
115%{__chmod} +x %{buildroot}%{python_sitearch}/gps/gps.py
116
117# Install the .desktop files
118desktop-file-install \
119        --dir %{buildroot}%{_datadir}/applications \
120        packaging/X11/xgps.desktop
121desktop-file-install \
122        --dir %{buildroot}%{_datadir}/applications \
123        packaging/X11/xgpsspeed.desktop
124
125# Install logo icon for .desktop files
126%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
127%{__install} -p -m 0644 packaging/X11/gpsd-logo.png %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
128
129
130%clean
131rm -rf %{buildroot}
132
133%post
134/sbin/ldconfig
135/sbin/chkconfig --add %{name}
136
137%preun
138if [ $1 = 0 ]; then
139        /sbin/service %{name} stop > /dev/null 2>&1 || true
140        /sbin/chkconfig --del %{name}
141fi
142
143%postun -p /sbin/ldconfig
144
145
146%files
147%defattr(-,root,root,-)
148%doc README INSTALL COPYING
149%config(noreplace) %{_sysconfdir}/init.d/%{name}
150%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
151%config(noreplace) %{_sysconfdir}/udev/rules.d/*
152%{_sbindir}/gpsd
153%{_sbindir}/gpsdctl
154%{_bindir}/gegps
155%{_bindir}/gpsprof
156%{_bindir}/gpsmon
157%{_bindir}/gpsctl
158%{_bindir}/ntpshmmon
159%{_libdir}/libgps*.so.*
160/lib/udev/gpsd*
161%{python_sitearch}/gps*
162%exclude %{python_sitearch}/gps/fake*
163%{_mandir}/man8/gpsd.8*
164%{_mandir}/man8/gpsdctl.8*
165%{_mandir}/man8/gpsinit.8*
166%{_mandir}/man1/gegps.1*
167%{_mandir}/man1/gpsprof.1*
168%{_mandir}/man1/gpsmon.1*
169%{_mandir}/man1/gpsctl.1*
170%{_mandir}/man1/ntpshmmon.1*
171
172%files devel
173%defattr(-,root,root,-)
174%doc TODO
175%{_bindir}/gpsfake
176%{_libdir}/libgps*.so
177%{_libdir}/pkgconfig/*.pc
178%{python_sitearch}/gps/fake*
179%{_includedir}/gps.h
180%{_includedir}/libgpsmm.h
181%{_mandir}/man1/gpsfake.1*
182%{_mandir}/man3/libQgpsmm.3*
183%{_mandir}/man3/libgps.3*
184%{_mandir}/man3/libgpsmm.3*
185%{_mandir}/man5/gpsd_json.5*
186%{_mandir}/man5/srec.5*
187
188%files clients
189%defattr(-,root,root,-)
190%{_bindir}/cgps
191%{_bindir}/gps2udp
192%{_bindir}/gpscat
193%{_bindir}/gpsdecode
194%{_bindir}/gpspipe
195%{_bindir}/gpxlogger
196%{_bindir}/lcdgps
197%{_bindir}/xgps
198%{_bindir}/xgpsspeed
199%{_mandir}/man1/gps.1*
200%{_mandir}/man1/gps2udp.1*
201%{_mandir}/man1/gpsdecode.1*
202%{_mandir}/man1/gpspipe.1*
203%{_mandir}/man1/lcdgps.1*
204%{_mandir}/man1/xgps.1*
205%{_mandir}/man1/xgpsspeed.1*
206%{_mandir}/man1/cgps.1*
207%{_mandir}/man1/gpscat.1*
208%{_datadir}/applications/*.desktop
209%dir %{_datadir}/gpsd
210%{_datadir}/gpsd/gpsd-logo.png
211
212
213%changelog
214* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.15-2
215- rebuild with gcc-5.4.0
216
217* Sat Aug 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.15-1
218- new upstream release
219
220* Sat Dec 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.11-1
221- new upstream release
222- change BuildRequires: eudev-libudev-devel instead of libudev-devel
223
224* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
225- new upstream release
226
227* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.7-1
228- update to 3.7
229- remove old patches
230- add BuildRequires: scons, chrpath
231
232* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-3
233- rebuild with python-2.7.2
234
235* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.95-2
236- rebuilt with rpm-4.8.1 for pkg-config
237
238* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
239- new upstream release
240- merge spec, patch, source from fedora
241
242* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
243- add BuildRequires: libXp-devel
244
245* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
246- rebuilt with python-2.6.4
247
248* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
249- initial build for Vine Linux
250
251* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
252- Rebuild for Python 2.6
253
254* Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
255- moving gpspacket.so python lib to main package
256- adding zero.patch to make ZEROIZE error go away on fedora 7
257
258* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
259- update to 2.37
260- removed install-gpsd_config.h.patch
261- installed pkgconfig files in devel package
262- added patch to install python modules in sitearch
263- removing rpath from inclucded libtool
264- moving X11 app-defaults to datadir
265- using macros for commands in install; using install instead of cp and mkdir
266- cleaning up spaces/tabs for rpmlint
267
268* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
269- Autorebuild for GCC 4.3
270
271* Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
272- Patch Makefile to also install gpsd_config.h as needed by
273  libgpsmm.h.  Redhat BZ 253433.
274
275* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
276- Make sure the logo is actually included (via the spec file).
277  I need to wake up before I try even trivial updates. 
278
279* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
280- Learn how to use search and replace (aka fix all instances of
281  gpsd-logo.png spelled incorrectly as gspd-logo.png).
282
283* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
284- Fix desktop file and logo file name.
285
286* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
287- Include icon for .desktop files per BZ 241428
288
289* Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
290- Bump release for FE5 -> Fedora 7 upgrade path.
291
292* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
293- BR python-devel instead of python to make it build. 
294
295* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
296- Upgrade to 2.34.
297- Get rid of %%makeinstall (which was never needed).
298- Possibly fix hotplug issuses (BZ 219750).
299- Use %%python_sitelib for python site-files stuff.
300
301* Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
302- Rebuild to pull in new version of python.
303
304* Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
305- Remove openmotif requirment, and switch to lesstif.
306
307* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
308- Bump release for rebuild in prep. for FC6.
309
310* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
311- Actually, was a missing BR glib-dbus-devel. Ooops.
312
313* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
314- Missing BR glib-devel
315
316* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
317- Update to version 2.33
318
319* Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
320- Don't --enable-tnt in build as it causes some gpses to not work
321  properly with sattelite view mode.  See bugzilla bug 189220.
322
323* Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
324- Add dbus-glib to BuildRequires as needed for build.
325
326* Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
327- Include xmlto and python in buildrequires so things build right.
328- Don't package static library file. 
329
330* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
331- Use ye olde %%{?dist} tag.
332
333* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
334- Initial Fedora Extras specfile
Note: See TracBrowser for help on using the repository browser.