source: projects/specs/trunk/g/gpsd/gpsd-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: Service daemon for mediating access to a GPS
4Summary(ja): GPS にアクセスするためのサービスデーモン
5
6Name: gpsd
7Version: 2.37
8Release: 3%{?_dist_release}
9
10Group: System Environment/Daemons
11License: BSD
12URL: http://developer.berlios.de/projects/gpsd/
13Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
14Source1: xgps.desktop
15Source2: xgpsspeed.desktop
16Source3: gpsd-logo.png
17Patch0: python-pyexecdir-install-gpsd-2.37.patch
18Patch1: zero.patch
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
22BuildRequires: openMotif-devel libXaw-devel desktop-file-utils
23BuildRequires: python
24BuildRequires: libXp-devel
25
26Requires(post): /sbin/ldconfig
27Requires(postun): /sbin/ldconfig
28
29%description
30gpsd is a service daemon that mediates access to a GPS sensor
31connected to the host computer by serial or USB interface, making its
32data on the location/course/velocity of the sensor available to be
33queried on TCP port 2947 of the host computer.  With gpsd, multiple
34GPS client applications (such as navigational and wardriving software)
35can share access to a GPS without contention or loss of data.  Also,
36gpsd responds to queries with a format that is substantially easier to
37parse than NMEA 0183. 
38
39%package devel
40Summary: Client libraries in C and Python for talking to a running gpsd or GPS
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: pkgconfig
44
45%description devel
46This package provides C header files and python modules for the gpsd shared
47libraries that manage access to a GPS for applications
48
49%package clients
50Summary: Clients for gpsd
51Summary(ja): gpsd 用クライアント
52Group: Applications/System
53
54%description clients
55xgps is a simple test client for gpsd with an X interface. It displays
56current GPS position/time/velocity information and (for GPSes that
57support the feature) the locations of accessible satellites.
58
59xgpsspeed is a speedometer that uses position information from the GPS.
60It accepts an -h option and optional argument as for gps, or a -v option
61to dump the package version and exit. Additionally, it accepts -rv
62(reverse video) and -nc (needle color) options.
63
64cgps resembles xgps, but without the pictorial satellite display.  It
65can run on a serial terminal or terminal emulator.
66
67
68%prep
69%setup -q
70%patch0 -p1
71%patch1 -p0
72
73
74%build
75%configure --enable-dbus --disable-static
76sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
77sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
78make %{?_smp_mflags}
79
80
81%install
82rm -rf %{buildroot}
83make DESTDIR=%{buildroot} install
84
85# X11 defaults
86%{__install} -d -m 0755 %{buildroot}%{_datadir}/X11/app-defaults/
87%{__install} -p -m 0644 xgps.ad %{buildroot}%{_datadir}/X11/app-defaults/xgps
88%{__install} -p -m 0644 xgpsspeed.ad \
89        %{buildroot}%{_datadir}/X11/app-defaults/xgpsspeed
90
91# hotplug script
92%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/hotplug.d/usb
93%{__install} -p -m 0644 gpsd.hotplug gpsd.usermap \
94        %{buildroot}%{_sysconfdir}/hotplug.d/usb/
95
96# remove .la files
97rm -f %{buildroot}%{_libdir}/libgps.la
98
99# fix non-executable libraries
100%{__chmod} +x %{buildroot}%{_libdir}/libgps.so.17.0.0
101%{__chmod} +x %{buildroot}%{python_sitearch}/gpspacket.so
102
103# fix non-executable python script
104%{__chmod} +x %{buildroot}%{python_sitearch}/gps.py
105
106# Install the .desktop files
107desktop-file-install --vendor fedora \
108        --dir %{buildroot}%{_datadir}/applications \
109        --add-category X-Fedora \
110        %{SOURCE1}
111desktop-file-install --vendor fedora \
112        --dir %{buildroot}%{_datadir}/applications \
113        --add-category X-Fedora \
114        %{SOURCE2}
115
116# Install logo icon for .desktop files
117%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
118%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
119
120
121%clean
122rm -rf %{buildroot}
123
124
125%post -p /sbin/ldconfig
126
127%postun -p /sbin/ldconfig
128
129
130%files
131%defattr(-,root,root,-)
132%doc README INSTALL COPYING
133%{_sbindir}/gpsd
134%{_bindir}/gpsprof
135%{_bindir}/sirfmon
136%{_bindir}/gpsctl
137%{_libdir}/libgps.so.*
138%{python_sitearch}/gps.py*
139%{python_sitearch}/gpspacket.so
140%{_mandir}/man8/gpsd.8*
141%{_mandir}/man1/gpsprof.1*
142%{_mandir}/man1/sirfmon.1*
143%{_mandir}/man1/gpsctl.1*
144%{_sysconfdir}/hotplug.d/usb/gpsd.hotplug
145%{_sysconfdir}/hotplug.d/usb/gpsd.usermap
146
147%files devel
148%defattr(-,root,root,-)
149%doc TODO
150%{_bindir}/gpsfake
151%{_bindir}/rtcmdecode
152%{_bindir}/gpsflash
153%{_libdir}/libgps.so
154%{_libdir}/pkgconfig/*.pc
155%{python_sitearch}/gpsfake*
156%{_includedir}/gps.h
157%{_includedir}/libgpsmm.h
158%{_includedir}/gpsd.h
159%{_mandir}/man1/gpsfake.1*
160%{_mandir}/man1/rtcmdecode.1*
161%{_mandir}/man1/gpsflash.1*
162%{_mandir}/man3/libgps.3*
163%{_mandir}/man3/libgpsmm.3*
164%{_mandir}/man3/libgpsd.3*
165%{_mandir}/man5/rtcm-104.5*
166%{_mandir}/man5/srec.5*
167
168%files clients
169%defattr(-,root,root,-)
170%{_bindir}/xgps
171%{_bindir}/xgpsspeed
172%{_bindir}/cgps
173%{_bindir}/gpspipe
174%{_bindir}/gpxlogger
175%{_bindir}/cgpxlogger
176%{_bindir}/gpscat
177%{_mandir}/man1/gps.1*
178%{_mandir}/man1/gpspipe.1*
179%{_mandir}/man1/xgps.1*
180%{_mandir}/man1/xgpsspeed.1*
181%{_mandir}/man1/cgps.1*
182%{_mandir}/man1/gpscat.1*
183%{_mandir}/man1/cgpxlogger.1*
184%{_datadir}/X11/app-defaults/xgps
185%{_datadir}/X11/app-defaults/xgpsspeed
186%{_datadir}/applications/*.desktop
187%dir %{_datadir}/gpsd
188%{_datadir}/gpsd/gpsd-logo.png
189
190
191%changelog
192* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
193- add BuildRequires: libXp-devel
194
195* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
196- rebuilt with python-2.6.4
197
198* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
199- initial build for Vine Linux
200
201* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
202- Rebuild for Python 2.6
203
204* Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
205- moving gpspacket.so python lib to main package
206- adding zero.patch to make ZEROIZE error go away on fedora 7
207
208* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
209- update to 2.37
210- removed install-gpsd_config.h.patch
211- installed pkgconfig files in devel package
212- added patch to install python modules in sitearch
213- removing rpath from inclucded libtool
214- moving X11 app-defaults to datadir
215- using macros for commands in install; using install instead of cp and mkdir
216- cleaning up spaces/tabs for rpmlint
217
218* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
219- Autorebuild for GCC 4.3
220
221* Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
222- Patch Makefile to also install gpsd_config.h as needed by
223  libgpsmm.h.  Redhat BZ 253433.
224
225* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
226- Make sure the logo is actually included (via the spec file).
227  I need to wake up before I try even trivial updates. 
228
229* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
230- Learn how to use search and replace (aka fix all instances of
231  gpsd-logo.png spelled incorrectly as gspd-logo.png).
232
233* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
234- Fix desktop file and logo file name.
235
236* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
237- Include icon for .desktop files per BZ 241428
238
239* Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
240- Bump release for FE5 -> Fedora 7 upgrade path.
241
242* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
243- BR python-devel instead of python to make it build. 
244
245* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
246- Upgrade to 2.34.
247- Get rid of %%makeinstall (which was never needed).
248- Possibly fix hotplug issuses (BZ 219750).
249- Use %%python_sitelib for python site-files stuff.
250
251* Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
252- Rebuild to pull in new version of python.
253
254* Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
255- Remove openmotif requirment, and switch to lesstif.
256
257* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
258- Bump release for rebuild in prep. for FC6.
259
260* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
261- Actually, was a missing BR glib-dbus-devel. Ooops.
262
263* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
264- Missing BR glib-devel
265
266* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
267- Update to version 2.33
268
269* Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
270- Don't --enable-tnt in build as it causes some gpses to not work
271  properly with sattelite view mode.  See bugzilla bug 189220.
272
273* Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
274- Add dbus-glib to BuildRequires as needed for build.
275
276* Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
277- Include xmlto and python in buildrequires so things build right.
278- Don't package static library file. 
279
280* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
281- Use ye olde %%{?dist} tag.
282
283* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
284- Initial Fedora Extras specfile
Note: See TracBrowser for help on using the repository browser.