source: projects/specs/trunk/g/gpgme/gpgme-vl.spec @ 1594

Revision 1594, 5.3 KB checked in by inagaki, 14 years ago (diff)

update: akonadi, gpgme, polkit-qt, shared-desktop-ontologies, soprano
NEW: cagibi, dbusmenu-qt, qjson

Line 
1%define _gnupg_ver              1.3.0
2%define _libgpg_error_ver       1.4
3
4Name:           gpgme
5Summary:        GPGME - GnuPG Made Easy
6Summary(ja):    GPGME - GnuPG Made Easy
7Version:        1.1.8
8Release:        1%{?_dist_release}
9
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://www.gnupg.org/related_software/gpgme/
13
14Source:         ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  gnupg >= %{_gnupg_ver}
18BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
19Requires:       gnupg >= %{_gnupg_ver}
20Requires:       libgpg-error >= %{_libgpg_error_ver}
21
22Obsoletes:      gpgme10
23Provides:       gpgme10
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27
28%description
29GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
30for applications. It provides a High-Level Crypto API for encryption,
31decryption, signing, signature verification and key management. Currently it
32uses GnuPG as it's backend but the API isn't restricted to this engine; in
33fact it is planned to add other backends to it.
34
35%description -l ja
36GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
37るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
38ための高レベルの暗号 API を提供します。
39現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
40定されません。実際、他のバックエンドを追加することが計画されています。
41
42%package devel
43Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
44Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
45Group:          Development/Libraries
46Requires:       %{name} = %{version}
47Requires:       libgpg-error-devel >= 0.5
48Requires(post): install-info
49Requires(preun): install-info
50Obsoletes:      %{name} < 0.3.16-0vl2
51Obsoletes:      gpgme10-devel
52Provides:       gpgme10-devel
53
54%description devel
55GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
56for applications.
57
58Install this package if you want to develop applications that will use the
59gpgme library.
60
61%description -l ja devel
62GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
63るように設計されたライブラリです。
64
65GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
66ジをインストールしてください。
67
68%prep
69%setup -q
70
71%build
72%configure --without-gpgsm
73%__make
74
75%install
76%__rm -rf %{buildroot}
77%{makeinstall}
78
79# remove unneeded files
80%__rm -rf %{buildroot}%{_datadir}/common-lisp
81%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
82%__rm -f $RPM_BUILD_ROOT%{_infodir}/dir
83
84%clean
85%__rm -rf %{buildroot}
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%triggerun -- %{name} < 0.3.16-0vl2
92/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
93
94%post devel
95/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
96
97%preun devel
98if [ "$1" = 0 ] ; then
99        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
100fi
101
102%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
103/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
104
105%files
106%defattr(-,root,root)
107%doc AUTHORS COPYING* ChangeLog INSTALL NEWS README THANKS TODO
108%{_libdir}/libgpgme*.so.*
109
110%files devel
111%defattr(-,root,root)
112%{_bindir}/gpgme-config
113%{_libdir}/libgpgme*.so
114%{_datadir}/aclocal/gpgme.m4
115%{_includedir}/*
116%{_infodir}/*
117
118%changelog
119* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
120- new upstream release
121
122* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
123- removed *.la
124- spec in utf-8
125
126* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
127- applied new versioning policy
128
129* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
130- upstream release
131- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
132- update %%_gnupg_ver to 1.3.0
133- update %%_libgpg_error_ver to 1.4
134
135* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
136- upstream release
137
138* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
139- add Obsoletes/Provides: gpgme10{,-devel}
140
141* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
142- fix spec file's encoding from iso-2022-jp to euc-jp
143- add PreReq: ldconfig
144- add PreReq: install-info (devel)
145- change group to System Environment/Libraries (main)
146- add poor Japanese description
147
148* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
149- upstream release
150- change license from GPL to LGPL
151- update {Build,}Requires for GnuPG (>= 1.2.2)
152- add (Build)Requires: libgpg-error(-devel) >= 0.5
153- add docs
154- run ldconfig at post/postun
155- separate devel package
156  - Requires: libgpg-error-devel
157  - Obsoletes: gpgme <= 0.3.16
158
159* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
160- update to 0.3.16
161- s/Copyright/License/
162- update URL
163
164* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
165- update to 0.3.15
166- update {Build,}Requires for GnuPG
167
168* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
169- update to 0.3.11
170- added {Build,}Requires: gnupg = 1.0.7
171- added info files
172- added %%post and %%preun section for info files
173- fixed %%install section (executing rm command)
174
175* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
176- initial release
177
Note: See TracBrowser for help on using the repository browser.