source: projects/specs/trunk/g/gpgme/gpgme-vl.spec @ 3317

Revision 3317, 5.5 KB checked in by iwaim, 13 years ago (diff)

gpgme-1.3.0-1

Line 
1%define _gnupg_ver              1.4.0
2%define _libgpg_error_ver       1.4
3
4Name:           gpgme
5Summary:        GPGME - GnuPG Made Easy
6Summary(ja):    GPGME - GnuPG Made Easy
7Version:        1.3.0
8Release:        1%{?_dist_release}
9
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://www.gnupg.org/related_software/gpgme/
13
14Source:         ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  gnupg >= %{_gnupg_ver}
18BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
19BuildRequires:  libassuan-devel >= 2
20Requires:       gnupg >= %{_gnupg_ver}
21Requires:       libgpg-error >= %{_libgpg_error_ver}
22
23Obsoletes:      gpgme10
24Provides:       gpgme10
25
26Vendor:         Project Vine
27Distribution:   Vine Linux
28
29%description
30GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
31for applications. It provides a High-Level Crypto API for encryption,
32decryption, signing, signature verification and key management. Currently it
33uses GnuPG as it's backend but the API isn't restricted to this engine; in
34fact it is planned to add other backends to it.
35
36%description -l ja
37GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
38るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
39ための高レベルの暗号 API を提供します。
40現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
41定されません。実際、他のバックエンドを追加することが計画されています。
42
43%package devel
44Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
45Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
46Group:          Development/Libraries
47Requires:       %{name} = %{version}
48Requires:       libgpg-error-devel >= 0.5
49Requires:       libassuan-devel >= 2
50Requires(post): install-info
51Requires(preun): install-info
52Obsoletes:      %{name} < 0.3.16-0vl2
53Obsoletes:      gpgme10-devel
54Provides:       gpgme10-devel
55
56%description devel
57GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
58for applications.
59
60Install this package if you want to develop applications that will use the
61gpgme library.
62
63%description -l ja devel
64GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
65るように設計されたライブラリです。
66
67GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
68ジをインストールしてください。
69
70%prep
71%setup -q
72
73%build
74%configure --without-gpgsm
75%__make
76
77%install
78%__rm -rf %{buildroot}
79%{makeinstall}
80
81# remove unneeded files
82%__rm -rf %{buildroot}%{_datadir}/common-lisp
83%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84%__rm -f $RPM_BUILD_ROOT%{_infodir}/dir
85
86%clean
87%__rm -rf %{buildroot}
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%triggerun -- %{name} < 0.3.16-0vl2
94/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
95
96%post devel
97/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
98
99%preun devel
100if [ "$1" = 0 ] ; then
101        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
102fi
103
104%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
105/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
106
107%files
108%defattr(-,root,root)
109%doc AUTHORS COPYING* ChangeLog INSTALL NEWS README THANKS TODO
110%{_libdir}/libgpgme*.so.*
111
112%files devel
113%defattr(-,root,root)
114%{_bindir}/gpgme-config
115%{_libdir}/libgpgme*.so
116%{_datadir}/aclocal/gpgme.m4
117%{_includedir}/*
118%{_infodir}/*
119
120%changelog
121* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
122- new upstream release
123- add BuildRequires: libassuan-devel >= 2
124- add Requires: libassuan-devel >= 2 for devel subpackage
125- update GnuPG min version
126
127* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
128- new upstream release
129
130* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
131- removed *.la
132- spec in utf-8
133
134* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
135- applied new versioning policy
136
137* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
138- upstream release
139- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
140- update %%_gnupg_ver to 1.3.0
141- update %%_libgpg_error_ver to 1.4
142
143* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
144- upstream release
145
146* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
147- add Obsoletes/Provides: gpgme10{,-devel}
148
149* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
150- fix spec file's encoding from iso-2022-jp to euc-jp
151- add PreReq: ldconfig
152- add PreReq: install-info (devel)
153- change group to System Environment/Libraries (main)
154- add poor Japanese description
155
156* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
157- upstream release
158- change license from GPL to LGPL
159- update {Build,}Requires for GnuPG (>= 1.2.2)
160- add (Build)Requires: libgpg-error(-devel) >= 0.5
161- add docs
162- run ldconfig at post/postun
163- separate devel package
164  - Requires: libgpg-error-devel
165  - Obsoletes: gpgme <= 0.3.16
166
167* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
168- update to 0.3.16
169- s/Copyright/License/
170- update URL
171
172* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
173- update to 0.3.15
174- update {Build,}Requires for GnuPG
175
176* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
177- update to 0.3.11
178- added {Build,}Requires: gnupg = 1.0.7
179- added info files
180- added %%post and %%preun section for info files
181- fixed %%install section (executing rm command)
182
183* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
184- initial release
185
Note: See TracBrowser for help on using the repository browser.