source: projects/specs/trunk/g/gpgme/gpgme-vl.spec @ 11956

Revision 11956, 7.1 KB checked in by tomop, 5 years ago (diff)

gpgme-1.12.0-2

Line 
1%define _gnupg_ver              1.4.0
2%define _libgpg_error_ver       1.4
3
4%define _unpackaged_files_terminate_build 1
5
6Name:           gpgme
7Summary:        GPGME - GnuPG Made Easy
8Summary(ja):    GPGME - GnuPG Made Easy
9Version:        1.12.0
10Release:        2%{?_dist_release}
11
12License:        LGPL
13Group:          System Environment/Libraries
14URL:            http://www.gnupg.org/related_software/gpgme/
15
16Source:         ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  gnupg >= %{_gnupg_ver}
20BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
21BuildRequires:  libassuan-devel >= 2.0.2
22BuildRequires:  chrpath
23BuildRequires:  swig
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26BuildRequires:  python-rpm-macros
27BuildRequires:  python3-devel
28BuildRequires:  python3-setuptools
29BuildRequires:  python3-rpm-macros
30
31Requires:       gnupg >= %{_gnupg_ver}
32Requires:       libgpg-error >= %{_libgpg_error_ver}
33
34Obsoletes:      gpgme10
35Provides:       gpgme10
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39
40%description
41GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
42for applications. It provides a High-Level Crypto API for encryption,
43decryption, signing, signature verification and key management. Currently it
44uses GnuPG as it's backend but the API isn't restricted to this engine; in
45fact it is planned to add other backends to it.
46
47%description -l ja
48GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
49るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
50ための高レベルの暗号 API を提供します。
51現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
52定されません。実際、他のバックエンドを追加することが計画されています。
53
54%package devel
55Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
56Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
57Group:          Development/Libraries
58Requires:       %{name} = %{version}
59Requires:       libgpg-error-devel >= 0.5
60Requires:       libassuan-devel >= 2.0.2
61Requires(post): install-info
62Requires(preun): install-info
63Obsoletes:      %{name} < 0.3.16-0vl2
64Obsoletes:      gpgme10-devel
65Provides:       gpgme10-devel
66
67%description devel
68GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
69for applications.
70
71Install this package if you want to develop applications that will use the
72gpgme library.
73
74%description -l ja devel
75GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
76るように設計されたライブラリです。
77
78GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
79ジをインストールしてください。
80
81%package -n python-gpg
82Summary:        %{name} bindings for Python 2
83%{?python_provide:%python_provide python2-gpg}
84Requires:       %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
85
86%description -n python-gpg
87%{summary}.
88
89%package -n python3-gpg
90Summary:        %{name} bindings for Python 3
91%{?python_provide:%python_provide python3-gpg}
92Requires:       %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
93
94%description -n python3-gpg
95%{summary}.
96
97
98%prep
99%setup -q
100
101%build
102%configure --disable-gpgsm-test
103%__make
104
105%install
106%__rm -rf %{buildroot}
107%{makeinstall}
108
109# remove unneeded files
110%__rm -rf %{buildroot}%{_datadir}/common-lisp
111%__rm -f %{buildroot}%{_libdir}/*.la
112%__rm -f %{buildroot}%{_infodir}/dir
113
114chrpath -d %{buildroot}%{_bindir}/%{name}-tool
115chrpath -d %{buildroot}%{_libdir}/lib%{name}*.so*
116
117# autofoo installs useless stuff for uninstall
118rm -vf %{buildroot}%{python2_sitelib}/gpg/install_files.txt
119rm -vf %{buildroot}%{python3_sitelib}/gpg/install_files.txt
120
121%clean
122%__rm -rf %{buildroot}
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%triggerun -- %{name} < 0.3.16-0vl2
129/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
130
131%post devel
132/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
133
134%preun devel
135if [ "$1" = 0 ] ; then
136        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
137fi
138
139%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
140/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
141
142%files
143%defattr(-,root,root)
144%license COPYING*
145%doc AUTHORS ChangeLog NEWS README* THANKS TODO VERSION
146%{_bindir}/gpgme-json
147%{_libdir}/libgpgme*.so.*
148
149%files devel
150%defattr(-,root,root)
151%{_bindir}/gpgme-config
152%{_bindir}/gpgme-tool
153%{_libdir}/libgpgme*.so
154%{_libdir}/cmake/*
155%{_datadir}/aclocal/gpgme.m4
156%{_includedir}/*
157%{_infodir}/*
158
159%files -n python-gpg
160%doc lang/python/README
161%{python_sitearch}/gpg-*.egg-info
162%{python_sitearch}/gpg/
163
164%files -n python3-gpg
165%doc lang/python/README
166%{python3_sitearch}/gpg-*.egg-info
167%{python3_sitearch}/gpg/
168
169%changelog
170* Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
171- enabled python{2,3} bindings.
172
173* Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
174- new upstream release.
175
176* Fri Jul 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
177- new upstream release.
178
179* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
180- new upstream release
181- add BuildRequires: libassuan-devel >= 2
182- add Requires: libassuan-devel >= 2 for devel subpackage
183- update GnuPG min version
184
185* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
186- new upstream release
187
188* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
189- removed *.la
190- spec in utf-8
191
192* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
193- applied new versioning policy
194
195* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
196- upstream release
197- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
198- update %%_gnupg_ver to 1.3.0
199- update %%_libgpg_error_ver to 1.4
200
201* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
202- upstream release
203
204* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
205- add Obsoletes/Provides: gpgme10{,-devel}
206
207* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
208- fix spec file's encoding from iso-2022-jp to euc-jp
209- add PreReq: ldconfig
210- add PreReq: install-info (devel)
211- change group to System Environment/Libraries (main)
212- add poor Japanese description
213
214* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
215- upstream release
216- change license from GPL to LGPL
217- update {Build,}Requires for GnuPG (>= 1.2.2)
218- add (Build)Requires: libgpg-error(-devel) >= 0.5
219- add docs
220- run ldconfig at post/postun
221- separate devel package
222  - Requires: libgpg-error-devel
223  - Obsoletes: gpgme <= 0.3.16
224
225* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
226- update to 0.3.16
227- s/Copyright/License/
228- update URL
229
230* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
231- update to 0.3.15
232- update {Build,}Requires for GnuPG
233
234* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
235- update to 0.3.11
236- added {Build,}Requires: gnupg = 1.0.7
237- added info files
238- added %%post and %%preun section for info files
239- fixed %%install section (executing rm command)
240
241* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
242- initial release
243
Note: See TracBrowser for help on using the repository browser.