source: projects/specs/trunk/g/gpgme/gpgme-vl.spec @ 11868

Revision 11868, 5.9 KB checked in by tomop, 5 years ago (diff)

gpgme-1.12.0-1

Line 
1%define _gnupg_ver              1.4.0
2%define _libgpg_error_ver       1.4
3
4%define _unpackaged_files_terminate_build 1
5
6Name:           gpgme
7Summary:        GPGME - GnuPG Made Easy
8Summary(ja):    GPGME - GnuPG Made Easy
9Version:        1.12.0
10Release:        1%{?_dist_release}
11
12License:        LGPL
13Group:          System Environment/Libraries
14URL:            http://www.gnupg.org/related_software/gpgme/
15
16Source:         ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  gnupg >= %{_gnupg_ver}
20BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
21BuildRequires:  libassuan-devel >= 2.0.2
22Requires:       gnupg >= %{_gnupg_ver}
23Requires:       libgpg-error >= %{_libgpg_error_ver}
24
25Obsoletes:      gpgme10
26Provides:       gpgme10
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31%description
32GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
33for applications. It provides a High-Level Crypto API for encryption,
34decryption, signing, signature verification and key management. Currently it
35uses GnuPG as it's backend but the API isn't restricted to this engine; in
36fact it is planned to add other backends to it.
37
38%description -l ja
39GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
40るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
41ための高レベルの暗号 API を提供します。
42現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
43定されません。実際、他のバックエンドを追加することが計画されています。
44
45%package devel
46Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
47Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
48Group:          Development/Libraries
49Requires:       %{name} = %{version}
50Requires:       libgpg-error-devel >= 0.5
51Requires:       libassuan-devel >= 2.0.2
52Requires(post): install-info
53Requires(preun): install-info
54Obsoletes:      %{name} < 0.3.16-0vl2
55Obsoletes:      gpgme10-devel
56Provides:       gpgme10-devel
57
58%description devel
59GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
60for applications.
61
62Install this package if you want to develop applications that will use the
63gpgme library.
64
65%description -l ja devel
66GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
67るように設計されたライブラリです。
68
69GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
70ジをインストールしてください。
71
72%prep
73%setup -q
74
75%build
76%configure --disable-gpgsm-test
77%__make
78
79%install
80%__rm -rf %{buildroot}
81%{makeinstall}
82
83# remove unneeded files
84%__rm -rf %{buildroot}%{_datadir}/common-lisp
85%__rm -f %{buildroot}%{_libdir}/*.la
86%__rm -f %{buildroot}%{_infodir}/dir
87%__rm -rf %{buildroot}%{_libdir}/python*
88
89%clean
90%__rm -rf %{buildroot}
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%triggerun -- %{name} < 0.3.16-0vl2
97/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
98
99%post devel
100/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
101
102%preun devel
103if [ "$1" = 0 ] ; then
104        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
105fi
106
107%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
108/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
109
110%files
111%defattr(-,root,root)
112%doc AUTHORS COPYING* ChangeLog INSTALL NEWS README THANKS TODO
113%{_libdir}/libgpgme*.so.*
114
115%files devel
116%defattr(-,root,root)
117%{_bindir}/gpgme-config
118%{_bindir}/gpgme-json
119%{_bindir}/gpgme-tool
120%{_libdir}/libgpgme*.so
121%{_libdir}/cmake/*
122%{_datadir}/aclocal/gpgme.m4
123%{_includedir}/*
124%{_infodir}/*
125
126%changelog
127* Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
128- new upstream release.
129
130* Fri Jul 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
131- new upstream release.
132
133* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
134- new upstream release
135- add BuildRequires: libassuan-devel >= 2
136- add Requires: libassuan-devel >= 2 for devel subpackage
137- update GnuPG min version
138
139* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
140- new upstream release
141
142* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
143- removed *.la
144- spec in utf-8
145
146* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
147- applied new versioning policy
148
149* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
150- upstream release
151- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
152- update %%_gnupg_ver to 1.3.0
153- update %%_libgpg_error_ver to 1.4
154
155* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
156- upstream release
157
158* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
159- add Obsoletes/Provides: gpgme10{,-devel}
160
161* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
162- fix spec file's encoding from iso-2022-jp to euc-jp
163- add PreReq: ldconfig
164- add PreReq: install-info (devel)
165- change group to System Environment/Libraries (main)
166- add poor Japanese description
167
168* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
169- upstream release
170- change license from GPL to LGPL
171- update {Build,}Requires for GnuPG (>= 1.2.2)
172- add (Build)Requires: libgpg-error(-devel) >= 0.5
173- add docs
174- run ldconfig at post/postun
175- separate devel package
176  - Requires: libgpg-error-devel
177  - Obsoletes: gpgme <= 0.3.16
178
179* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
180- update to 0.3.16
181- s/Copyright/License/
182- update URL
183
184* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
185- update to 0.3.15
186- update {Build,}Requires for GnuPG
187
188* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
189- update to 0.3.11
190- added {Build,}Requires: gnupg = 1.0.7
191- added info files
192- added %%post and %%preun section for info files
193- fixed %%install section (executing rm command)
194
195* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
196- initial release
197
Note: See TracBrowser for help on using the repository browser.