source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 10555

Revision 10555, 16.5 KB checked in by tomop, 8 years ago (diff)

gnutls-3.4.14-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.4.14
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20# Nothing...
21
22# Security fixes
23# Nothing...
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  libtasn1-devel >= 4.3
27BuildRequires:  datefudge
28BuildRequires:  gmp-devel
29BuildRequires:  gettext readline-devel libtool
30BuildRequires:  guile-devel >= 1.8.6
31BuildRequires:  p11-kit-devel >= 0.21.3
32BuildRequires:  nettle-devel >= 3.1.1
33BuildRequires:  texinfo, autogen
34BuildRequires:  zlib-devel
35Requires:      zlib
36
37Requires(post):   ldconfig
38Requires(postun): ldconfig
39
40Vendor:         Project Vine
41Distribution:   Vine Linux
42
43%description
44GnuTLS is a project that aims to develop a library which provides a secure
45layer, over a reliable transport layer. Currently the GnuTLS library implements
46the proposed standards by the IETF's TLS working group.
47#'
48
49%package devel
50Summary:        Development files for the GnuTLS package.
51Summary(ja):    GnuTLS の開発用ファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       libgcrypt-devel, zlib-devel, pkgconfig
55Requires:       libtasn1-devel, nettle-devel
56Requires(post,preun): /sbin/install-info
57
58%description devel
59GnuTLS is a project that aims to develop a library which provides a secure
60layer, over a reliable transport layer. Currently the GnuTLS library implements
61the proposed standards by the IETF's TLS working group.
62
63This package contains files needed for developing applications with the GnuTLS
64library.
65#'
66
67%package utils
68Summary:        Command line tools for TLS protocol.
69Summary(ja):    GnuTLS のコマンドラインツール
70Group:          Applications/System
71Requires:       %{name} = %{version}-%{release}
72
73%description utils
74GnuTLS is a project that aims to develop a library which provides a secure
75layer, over a reliable transport layer. Currently the GnuTLS library implements
76the proposed standards by the IETF's TLS working group.
77
78This package contains command line TLS client and server and certificate
79manipulation tools.
80#'
81
82%package guile
83Summary: Guile bindings for the GNUTLS library
84Group: Development/Libraries
85Requires: %{name} = %{version}-%{release}
86Requires: guile
87
88%description guile
89GnuTLS is a project that aims to develop a library which provides a secure
90layer, over a reliable transport layer. Currently the GnuTLS library implements
91the proposed standards by the IETF's TLS working group.
92This package contains Guile bindings for the library.
93#'
94
95%package c++
96Summary: The C++ interface to GnuTLS
97Group: System Environment/Libraries
98Requires: %{name} = %{version}-%{release}
99
100%description c++
101GnuTLS is a project that aims to develop a library which provides a secure
102layer, over a reliable transport layer. Currently the GnuTLS library implements
103the proposed standards by the IETF's TLS working group.
104This package contains the C++ interface for the GnuTLS library.
105#'
106
107%package -n compat32-%{name}
108Summary:        GNU TLS Library
109Summary(ja):    GNU TLS ライブラリ
110Group:          System Environment/Libraries
111Requires:       %{name} = %{version}-%{release}
112
113%description -n compat32-%{name}
114GnuTLS is a project that aims to develop a library which provides a secure
115layer, over a reliable transport layer. Currently the GnuTLS library implements
116the proposed standards by the IETF's TLS working group.
117#'
118
119%package -n compat32-%{name}-devel
120Summary:        Development files for the GnuTLS package.
121Summary(ja):    GnuTLS の開発用ファイル
122Group:          Development/Libraries
123Requires:       compat32-%{name} = %{version}-%{release}
124Requires:       %{name}-devel = %{version}-%{release}
125Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
126Requires(post,preun): /sbin/install-info
127
128%description -n compat32-%{name}-devel
129GnuTLS is a project that aims to develop a library which provides a secure
130layer, over a reliable transport layer. Currently the GnuTLS library implements
131the proposed standards by the IETF's TLS working group.
132
133This package contains files needed for developing applications with the GnuTLS
134library.
135#'
136
137%package -n compat32-%{name}-guile
138Summary: Guile bindings for the GNUTLS library
139Group: Development/Libraries
140Requires: compat32-%{name} = %{version}-%{release}
141Requires: %{name}-guile = %{version}-%{release}
142
143%description -n compat32-%{name}-guile
144GnuTLS is a project that aims to develop a library which provides a secure
145layer, over a reliable transport layer. Currently the GnuTLS library implements
146the proposed standards by the IETF's TLS working group.
147This package contains Guile bindings for the library.
148#'
149
150%prep
151%setup -q
152
153%patch1 -p1 -b .rpath
154%patch3 -p1 -b .nosrp
155
156%build
157export LDFLAGS="-Wl,--no-add-needed"
158# autoreconf -fi
159%configure \
160        --disable-openssl-compatibility \
161        --disable-srp-authentication \
162        --disable-static \
163        --disable-srp-authentication \
164        --disable-non-suiteb-curves \
165        --disable-rpath \
166        --enable-guile
167#       --with-libgcrypt
168#       --with-lzo \
169#       --with-included-libcfg \
170#       --with-libtasn1-prefix=%{_prefix} \
171#       --with-included-libtasn1 \
172#       --with-included-opencdk \
173#       --with-included-lzo \
174make %{?_smp_mflags}
175# cp lib/COPYING COPYING.LIB
176
177%install
178%__rm -rf %{buildroot}
179# makeinstall macro causes build error, why?
180make install DESTDIR=%{buildroot}
181
182rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
183rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
184rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
185# replace libgnutls*-config
186%__install -d %{buildroot}%{_bindir}
187%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
188# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
189
190rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
191rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
192rm -f $RPM_BUILD_ROOT%{_infodir}/dir
193rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
194rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
195rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
196
197# remove unneeded files
198%__rm -f %{buildroot}%{_libdir}/*.la
199%__rm -f %{buildroot}%{_libdir}/guile/2.0/*.la
200
201%find_lang gnutls
202
203%check
204make check
205
206%clean
207rm -rf %{buildroot}
208
209%post -p /sbin/ldconfig
210
211%postun -p /sbin/ldconfig
212
213%post devel
214if [ -f %{_infodir}/gnutls.info.gz ]; then
215    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
216fi
217
218%preun devel
219if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
220   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
221fi
222
223%post guile -p /sbin/ldconfig
224
225%postun guile -p /sbin/ldconfig
226
227%post -n compat32-%{name} -p /sbin/ldconfig
228
229%postun -n compat32-%{name} -p /sbin/ldconfig
230
231%post -n compat32-%{name}-guile -p /sbin/ldconfig
232
233%postun -n compat32-%{name}-guile -p /sbin/ldconfig
234
235%files -f gnutls.lang
236%defattr(-,root,root,-)
237%{_libdir}/libgnutls.so.30*
238# %{_libdir}/libgnutls-xssl.so.0*
239%doc README AUTHORS NEWS THANKS
240
241%files devel
242%defattr(-,root,root,-)
243%{_bindir}/libgnutls*-config
244%{_includedir}/*
245%{_libdir}/libgnutls*.so
246%{_libdir}/pkgconfig/*.pc
247%{_mandir}/man3/*
248%{_infodir}/gnutls*
249%{_infodir}/pkcs11-vision.png.gz
250
251%files utils
252%defattr(-,root,root,-)
253%{_bindir}/certtool
254%{_bindir}/psktool
255%{_bindir}/p11tool
256%{_bindir}/ocsptool
257%{_bindir}/gnutls*
258%{_mandir}/man1/*
259%doc doc/certtool.cfg
260
261%files guile
262%defattr(-,root,root,-)
263%{_libdir}/guile/2.0/guile*.so*
264%{_datadir}/guile/site/gnutls
265%{_datadir}/guile/site/gnutls.scm
266
267%files c++
268%{_libdir}/libgnutlsxx.so.*
269
270%if %{build_compat32}
271%files -n compat32-%{name}
272%defattr(-,root,root,-)
273%{_libdir}/libgnutls.so.30*
274# %{_libdir}/libgnutls-xssl.so.0*
275
276%files -n compat32-%{name}-devel
277%defattr(-,root,root,-)
278#%{_libdir}/libgnutls*.a
279%{_libdir}/libgnutls*.so
280%{_libdir}/pkgconfig/*.pc
281
282%files -n compat32-%{name}-guile
283%defattr(-,root,root,-)
284%{_libdir}/guile/2.0/guile*.so*
285%endif
286
287%changelog
288* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.14-1
289- new upstream release 3.4.14.
290- dropped Patch100.
291- added BR: datefudge.
292
293* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.13-1
294- new upstream release 3.4.13.
295- added Patch100: workaround of failing cert-test (The certificate was expired).
296
297* Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
298- new upstream release 3.4.9
299
300* Fri Jan  1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
301- rebuilt to marge changelog
302
303* Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
304- new upstream release 3.4.7
305
306* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
307- rebuild with nettls-3.1.1
308
309* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
310- BR: libtasn1-devel >= 3.9
311
312* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
313- built for release
314
315* Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
316- rm libgnutls-xssl.so.0* in files list
317
318* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
319- for test
320
321* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
322- add patch1000 for fix SA-2015-3
323
324* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
325- rebuilt with guile 2.0.11
326
327* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
328- new upstream release with security fix   
329
330* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
331- new upstream release with security fix 
332
333* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
334- new upstream release with security fix
335
336* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
337- new upstream release with security fix
338
339* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
340- fix R: in compat32
341
342* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
343- fix BR:, R: (drop unneeded dependency)
344
345* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
346- new upstream release 3.2.10
347- update patches / drop old patches
348- add BR: nettle
349
350* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
351- added Patch100 from upstream to fix CVE-2013-2116
352
353* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
354- new upstream release
355- fixed a day of the week in %%changelog
356
357* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
358- new upstream release
359
360* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
361- new upstream release
362
363* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
364- new upstream release
365
366* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
367- new upstream release
368
369* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
370- new upstream release
371- changed BuildRequires: p11-kit-devel >= 0.11
372
373* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
374- new upstream release
375
376* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
377- new upstream release
378
379* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
380- added BuildRequires: p11-kit-devel
381
382* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
383- deleted BuildRequires: nettle-devel
384  - mistake.. fixed.
385
386* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
387- new upstream release
388- synced Fedora development package
389- add new sub-package: c++
390
391* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
392- add Requires: libtasn1-devel for devel subpackage
393
394* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
395- new upstream release
396
397* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
398- new upstream release
399
400* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
401- new upstream release
402- dropt patch1
403
404* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
405- new upstream release
406- added patch1,2,3,4 from Fedora development
407- added BuildRequires: gettext readline-devel libtool
408- added configure option
409  --disable-static,--disable-srp-authentication
410  - dropt *.a files from -devel package again
411
412* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
413- build with rpm-4.8.1-1 for pkg-config file
414
415* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
416- new upstream release
417- applied new naming policy to spec
418
419* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
420- new upstream release
421
422* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
423- new upstream release
424
425* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
426- new upstream release
427
428* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
429- new upstream release with security fix (handling X.509 CN or SAN fields)
430
431* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
432- added compat32 package for x86_64 arch support
433
434* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
435- new upstream release
436- added autoreconf
437- deleted libguile*.a
438- dropt Patch3
439- added %post guile, %postun guile
440
441* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
442- drop *.a files from -devel package
443- build with system lzo
444
445* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
446- new upstream release with security fixes (CVE-2009-1415,1416,1417)
447
448* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
449- update to 2.6.5
450
451* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
452- spec in UTF-8
453
454* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
455- update to 2.6.4
456- modifeid Source0
457
458* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
459- add BuildRequires: guile-devel >= 1.8.6
460
461* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
462- update to 2.6.3
463- import from fedora developing's 2.6.3
464  - License tag fixed
465- dropped patch0, patch1, patch2
466- added patch3
467- added BuildRequires: gmp-devel
468- add new sub-package: guile
469  - added %package guile, %description guile, %files guile
470
471* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
472- used %%{?_dist_release} macro
473
474* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
475- update to 1.6.3 (use no-SRP source)
476- import from fedora core's 1.6.3-2
477  - nosrc.tar.bz2 (source0)
478  - license tag fix
479- build with system libtasn1
480
481* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
482- update to 1.4.5 (use no-SRP source)
483- import from fedora core's 1.4.5-1
484  - nosrc.tar.bz2 (source0)
485- drop obsolete cve-2006-4790.patch (patch3)
486
487* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
488- [SECURITY] update to 1.4.1 (use no-SRP source)
489- import from fedora core's 1.4.1-2
490  - nosrp.tar.bz2 (source0)
491  - libgnutls-config (source1)
492  - nosrc.patch (patch0)
493  - enable-psk.patch (patch1)
494  - cve-2006-4790.patch (patch3)
495- update required version of libgcrypt (>= 1.2.2)
496- add Requires: pkgconfig to -devel package
497- add %%check section
498- update %%files
499- add new sub-package: utils
500
501* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
502- [SECURITY FIX] upstream release
503  - record packet parsing denial of service (CAN-2005-1431)
504
505* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
506- initial build for Vine Linux
507- upstream release
508
509* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
510- gcc4 rebuild
511
512* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
513- add gnutls Requires zlib-devel (#144069)
514
515* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
516- Make gnutls-devel Require libgcrypt-devel
517
518* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
519- rebuild with release++, otherwise unchanged.
520
521* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
522- patent tainted SRP code removed.
523
524* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
525- update to 1.0.20.
526- add --with-included-opencdk --with-included-libtasn1
527- add --with-included-libcfg --with-included-lzo
528- add --disable-srp-authentication.
529- do "make check" after build.
530
531* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
532- upgrade to 0.9.2
533
534* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
535- update to 0.4.4.
536
537* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
538- automated rebuild
539
540* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
541- update to 0.4.3.
542
543* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
544- update to 0.4.2.
545- change license to LGPL.
546- include splint annotations patch.
547
548* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
549- update to 0.4.0
550
551* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
552- update to 0.3.2
553
554* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
555- add a URL
556
557* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
558- initial package
Note: See TracBrowser for help on using the repository browser.