source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 10869

Revision 10869, 16.8 KB checked in by iwaim, 7 years ago (diff)

gnutls 3.4.14-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.4.14
7Release:        2%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20# Nothing...
21
22# Security fixes
23# CVE-2016-7444/GNUTLS-SA-2016-3
24Patch2001: https://gitlab.com/gnutls/gnutls/commit/964632f37dfdfb914ebc5e49db4fa29af35b1de9.patch
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  libtasn1-devel >= 4.3
28BuildRequires:  datefudge
29BuildRequires:  gmp-devel
30BuildRequires:  gettext readline-devel libtool
31BuildRequires:  guile-devel >= 1.8.6
32BuildRequires:  p11-kit-devel >= 0.21.3
33BuildRequires:  nettle-devel >= 3.1.1
34BuildRequires:  texinfo, autogen
35BuildRequires:  zlib-devel
36Requires:      zlib
37# for tests
38BuildRequires:  net-tools
39
40Requires(post):   ldconfig
41Requires(postun): ldconfig
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45
46%description
47GnuTLS is a project that aims to develop a library which provides a secure
48layer, over a reliable transport layer. Currently the GnuTLS library implements
49the proposed standards by the IETF's TLS working group.
50#'
51
52%package devel
53Summary:        Development files for the GnuTLS package.
54Summary(ja):    GnuTLS の開発用ファイル
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57Requires:       libgcrypt-devel, zlib-devel, pkgconfig
58Requires:       libtasn1-devel, nettle-devel
59Requires(post,preun): /sbin/install-info
60
61%description devel
62GnuTLS is a project that aims to develop a library which provides a secure
63layer, over a reliable transport layer. Currently the GnuTLS library implements
64the proposed standards by the IETF's TLS working group.
65
66This package contains files needed for developing applications with the GnuTLS
67library.
68#'
69
70%package utils
71Summary:        Command line tools for TLS protocol.
72Summary(ja):    GnuTLS のコマンドラインツール
73Group:          Applications/System
74Requires:       %{name} = %{version}-%{release}
75
76%description utils
77GnuTLS is a project that aims to develop a library which provides a secure
78layer, over a reliable transport layer. Currently the GnuTLS library implements
79the proposed standards by the IETF's TLS working group.
80
81This package contains command line TLS client and server and certificate
82manipulation tools.
83#'
84
85%package guile
86Summary: Guile bindings for the GNUTLS library
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
89Requires: guile
90
91%description guile
92GnuTLS is a project that aims to develop a library which provides a secure
93layer, over a reliable transport layer. Currently the GnuTLS library implements
94the proposed standards by the IETF's TLS working group.
95This package contains Guile bindings for the library.
96#'
97
98%package c++
99Summary: The C++ interface to GnuTLS
100Group: System Environment/Libraries
101Requires: %{name} = %{version}-%{release}
102
103%description c++
104GnuTLS is a project that aims to develop a library which provides a secure
105layer, over a reliable transport layer. Currently the GnuTLS library implements
106the proposed standards by the IETF's TLS working group.
107This package contains the C++ interface for the GnuTLS library.
108#'
109
110%package -n compat32-%{name}
111Summary:        GNU TLS Library
112Summary(ja):    GNU TLS ライブラリ
113Group:          System Environment/Libraries
114Requires:       %{name} = %{version}-%{release}
115
116%description -n compat32-%{name}
117GnuTLS is a project that aims to develop a library which provides a secure
118layer, over a reliable transport layer. Currently the GnuTLS library implements
119the proposed standards by the IETF's TLS working group.
120#'
121
122%package -n compat32-%{name}-devel
123Summary:        Development files for the GnuTLS package.
124Summary(ja):    GnuTLS の開発用ファイル
125Group:          Development/Libraries
126Requires:       compat32-%{name} = %{version}-%{release}
127Requires:       %{name}-devel = %{version}-%{release}
128Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
129Requires(post,preun): /sbin/install-info
130
131%description -n compat32-%{name}-devel
132GnuTLS is a project that aims to develop a library which provides a secure
133layer, over a reliable transport layer. Currently the GnuTLS library implements
134the proposed standards by the IETF's TLS working group.
135
136This package contains files needed for developing applications with the GnuTLS
137library.
138#'
139
140%package -n compat32-%{name}-guile
141Summary: Guile bindings for the GNUTLS library
142Group: Development/Libraries
143Requires: compat32-%{name} = %{version}-%{release}
144Requires: %{name}-guile = %{version}-%{release}
145
146%description -n compat32-%{name}-guile
147GnuTLS is a project that aims to develop a library which provides a secure
148layer, over a reliable transport layer. Currently the GnuTLS library implements
149the proposed standards by the IETF's TLS working group.
150This package contains Guile bindings for the library.
151#'
152
153%prep
154%setup -q
155
156%patch1 -p1 -b .rpath
157%patch3 -p1 -b .nosrp
158%patch2001 -p1
159
160%build
161export LDFLAGS="-Wl,--no-add-needed"
162# autoreconf -fi
163%configure \
164        --disable-openssl-compatibility \
165        --disable-srp-authentication \
166        --disable-static \
167        --disable-srp-authentication \
168        --disable-non-suiteb-curves \
169        --disable-rpath \
170        --enable-guile
171#       --with-libgcrypt
172#       --with-lzo \
173#       --with-included-libcfg \
174#       --with-libtasn1-prefix=%{_prefix} \
175#       --with-included-libtasn1 \
176#       --with-included-opencdk \
177#       --with-included-lzo \
178make %{?_smp_mflags}
179# cp lib/COPYING COPYING.LIB
180
181%install
182%__rm -rf %{buildroot}
183# makeinstall macro causes build error, why?
184make install DESTDIR=%{buildroot}
185
186rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
187rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
188rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
189# replace libgnutls*-config
190%__install -d %{buildroot}%{_bindir}
191%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
192# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
193
194rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
195rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
196rm -f $RPM_BUILD_ROOT%{_infodir}/dir
197rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
198rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
199rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
200
201# remove unneeded files
202%__rm -f %{buildroot}%{_libdir}/*.la
203%__rm -f %{buildroot}%{_libdir}/guile/2.0/*.la
204
205%find_lang gnutls
206
207%check
208make check
209
210%clean
211rm -rf %{buildroot}
212
213%post -p /sbin/ldconfig
214
215%postun -p /sbin/ldconfig
216
217%post devel
218if [ -f %{_infodir}/gnutls.info.gz ]; then
219    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
220fi
221
222%preun devel
223if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
224   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
225fi
226
227%post guile -p /sbin/ldconfig
228
229%postun guile -p /sbin/ldconfig
230
231%post -n compat32-%{name} -p /sbin/ldconfig
232
233%postun -n compat32-%{name} -p /sbin/ldconfig
234
235%post -n compat32-%{name}-guile -p /sbin/ldconfig
236
237%postun -n compat32-%{name}-guile -p /sbin/ldconfig
238
239%files -f gnutls.lang
240%defattr(-,root,root,-)
241%{_libdir}/libgnutls.so.30*
242# %{_libdir}/libgnutls-xssl.so.0*
243%doc README AUTHORS NEWS THANKS
244
245%files devel
246%defattr(-,root,root,-)
247%{_bindir}/libgnutls*-config
248%{_includedir}/*
249%{_libdir}/libgnutls*.so
250%{_libdir}/pkgconfig/*.pc
251%{_mandir}/man3/*
252%{_infodir}/gnutls*
253%{_infodir}/pkcs11-vision.png.gz
254
255%files utils
256%defattr(-,root,root,-)
257%{_bindir}/certtool
258%{_bindir}/psktool
259%{_bindir}/p11tool
260%{_bindir}/ocsptool
261%{_bindir}/gnutls*
262%{_mandir}/man1/*
263%doc doc/certtool.cfg
264
265%files guile
266%defattr(-,root,root,-)
267%{_libdir}/guile/2.0/guile*.so*
268%{_datadir}/guile/site/gnutls
269%{_datadir}/guile/site/gnutls.scm
270
271%files c++
272%{_libdir}/libgnutlsxx.so.*
273
274%if %{build_compat32}
275%files -n compat32-%{name}
276%defattr(-,root,root,-)
277%{_libdir}/libgnutls.so.30*
278# %{_libdir}/libgnutls-xssl.so.0*
279
280%files -n compat32-%{name}-devel
281%defattr(-,root,root,-)
282#%{_libdir}/libgnutls*.a
283%{_libdir}/libgnutls*.so
284%{_libdir}/pkgconfig/*.pc
285
286%files -n compat32-%{name}-guile
287%defattr(-,root,root,-)
288%{_libdir}/guile/2.0/guile*.so*
289%endif
290
291%changelog
292* Thu Jan 12 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-2
293- fix CVE-2016-7444; OCSP validation issue
294 - add Patch2001
295- add BR: net-tools; for test
296
297* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.14-1
298- new upstream release 3.4.14.
299- dropped Patch100.
300- added BR: datefudge.
301
302* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.13-1
303- new upstream release 3.4.13.
304- added Patch100: workaround of failing cert-test (The certificate was expired).
305
306* Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
307- new upstream release 3.4.9
308
309* Fri Jan  1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
310- rebuilt to marge changelog
311
312* Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
313- new upstream release 3.4.7
314
315* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
316- rebuild with nettls-3.1.1
317
318* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
319- BR: libtasn1-devel >= 3.9
320
321* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
322- built for release
323
324* Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
325- rm libgnutls-xssl.so.0* in files list
326
327* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
328- for test
329
330* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
331- add patch1000 for fix SA-2015-3
332
333* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
334- rebuilt with guile 2.0.11
335
336* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
337- new upstream release with security fix   
338
339* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
340- new upstream release with security fix 
341
342* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
343- new upstream release with security fix
344
345* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
346- new upstream release with security fix
347
348* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
349- fix R: in compat32
350
351* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
352- fix BR:, R: (drop unneeded dependency)
353
354* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
355- new upstream release 3.2.10
356- update patches / drop old patches
357- add BR: nettle
358
359* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
360- added Patch100 from upstream to fix CVE-2013-2116
361
362* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
363- new upstream release
364- fixed a day of the week in %%changelog
365
366* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
367- new upstream release
368
369* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
370- new upstream release
371
372* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
373- new upstream release
374
375* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
376- new upstream release
377
378* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
379- new upstream release
380- changed BuildRequires: p11-kit-devel >= 0.11
381
382* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
383- new upstream release
384
385* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
386- new upstream release
387
388* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
389- added BuildRequires: p11-kit-devel
390
391* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
392- deleted BuildRequires: nettle-devel
393  - mistake.. fixed.
394
395* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
396- new upstream release
397- synced Fedora development package
398- add new sub-package: c++
399
400* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
401- add Requires: libtasn1-devel for devel subpackage
402
403* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
404- new upstream release
405
406* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
407- new upstream release
408
409* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
410- new upstream release
411- dropt patch1
412
413* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
414- new upstream release
415- added patch1,2,3,4 from Fedora development
416- added BuildRequires: gettext readline-devel libtool
417- added configure option
418  --disable-static,--disable-srp-authentication
419  - dropt *.a files from -devel package again
420
421* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
422- build with rpm-4.8.1-1 for pkg-config file
423
424* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
425- new upstream release
426- applied new naming policy to spec
427
428* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
429- new upstream release
430
431* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
432- new upstream release
433
434* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
435- new upstream release
436
437* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
438- new upstream release with security fix (handling X.509 CN or SAN fields)
439
440* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
441- added compat32 package for x86_64 arch support
442
443* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
444- new upstream release
445- added autoreconf
446- deleted libguile*.a
447- dropt Patch3
448- added %post guile, %postun guile
449
450* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
451- drop *.a files from -devel package
452- build with system lzo
453
454* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
455- new upstream release with security fixes (CVE-2009-1415,1416,1417)
456
457* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
458- update to 2.6.5
459
460* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
461- spec in UTF-8
462
463* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
464- update to 2.6.4
465- modifeid Source0
466
467* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
468- add BuildRequires: guile-devel >= 1.8.6
469
470* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
471- update to 2.6.3
472- import from fedora developing's 2.6.3
473  - License tag fixed
474- dropped patch0, patch1, patch2
475- added patch3
476- added BuildRequires: gmp-devel
477- add new sub-package: guile
478  - added %package guile, %description guile, %files guile
479
480* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
481- used %%{?_dist_release} macro
482
483* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
484- update to 1.6.3 (use no-SRP source)
485- import from fedora core's 1.6.3-2
486  - nosrc.tar.bz2 (source0)
487  - license tag fix
488- build with system libtasn1
489
490* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
491- update to 1.4.5 (use no-SRP source)
492- import from fedora core's 1.4.5-1
493  - nosrc.tar.bz2 (source0)
494- drop obsolete cve-2006-4790.patch (patch3)
495
496* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
497- [SECURITY] update to 1.4.1 (use no-SRP source)
498- import from fedora core's 1.4.1-2
499  - nosrp.tar.bz2 (source0)
500  - libgnutls-config (source1)
501  - nosrc.patch (patch0)
502  - enable-psk.patch (patch1)
503  - cve-2006-4790.patch (patch3)
504- update required version of libgcrypt (>= 1.2.2)
505- add Requires: pkgconfig to -devel package
506- add %%check section
507- update %%files
508- add new sub-package: utils
509
510* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
511- [SECURITY FIX] upstream release
512  - record packet parsing denial of service (CAN-2005-1431)
513
514* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
515- initial build for Vine Linux
516- upstream release
517
518* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
519- gcc4 rebuild
520
521* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
522- add gnutls Requires zlib-devel (#144069)
523
524* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
525- Make gnutls-devel Require libgcrypt-devel
526
527* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
528- rebuild with release++, otherwise unchanged.
529
530* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
531- patent tainted SRP code removed.
532
533* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
534- update to 1.0.20.
535- add --with-included-opencdk --with-included-libtasn1
536- add --with-included-libcfg --with-included-lzo
537- add --disable-srp-authentication.
538- do "make check" after build.
539
540* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
541- upgrade to 0.9.2
542
543* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
544- update to 0.4.4.
545
546* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
547- automated rebuild
548
549* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
550- update to 0.4.3.
551
552* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
553- update to 0.4.2.
554- change license to LGPL.
555- include splint annotations patch.
556
557* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
558- update to 0.4.0
559
560* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
561- update to 0.3.2
562
563* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
564- add a URL
565
566* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
567- initial package
Note: See TracBrowser for help on using the repository browser.