source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 8447

Revision 8447, 14.1 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.2

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.10.15
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.12.15
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
78desktop-file-install --vendor gnome --delete-original                   \
79  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
80  --add-category Office                                                 \
81  --add-category Application                                            \
82  --add-category Spreadsheet                                            \
83  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
84  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
85
86%find_lang %{name}-%{version}
87%find_lang %{name}-%{version}-functions
88cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
89
90find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
91
92rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
93rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
94rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99%post
100/sbin/ldconfig
101scrollkeeper-update > /dev/null 2>&1 || :
102touch --no-create %{_datadir}/icons/hicolor || :
103if [ -x %{_bindir}/gtk-update-icon-cache ]; then
104   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
105fi
106update-desktop-database -q &> /dev/null || :
107
108%postun
109/sbin/ldconfig
110scrollkeeper-update > /dev/null 2>&1 || :
111touch --no-create %{_datadir}/icons/hicolor || :
112if [ -x %{_bindir}/gtk-update-icon-cache ]; then
113   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
114fi
115update-desktop-database -q &> /dev/null || :
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121
122%files -f %{name}-%{version}.lang
123%defattr (-, root, root)
124%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
125%{_bindir}/*
126%{_libdir}/libspreadsheet*.so
127%{_libdir}/%{name}
128%{_libdir}/goffice/0.10/plugins/%{name}
129%{_datadir}/appdata/gnumeric.appdata.xml
130%{_datadir}/applications/*.desktop
131%{_datadir}/glib-2.0/schemas/*.xml
132%{_datadir}/gnome/help/%{name}
133%{_datadir}/%{name}
134%{_datadir}/pixmaps/*
135%{_datadir}/omf/*
136%{_datadir}/icons/hicolor/*
137%{_mandir}/man*/*
138%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
139
140
141%changelog
142* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.15-1
143- new upstream release
144
145* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
146- new upstream release
147
148* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
149- new upstream release
150
151* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
152- new upstream release
153
154* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
155- new upstream release
156
157* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
158- new upstream release
159
160* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
161- new upstream release
162
163* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
164- new upstream release
165
166* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
167- new upstream release
168
169* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
170- new upstream release
171
172* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
173- new upstream release
174
175* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
176- new upstream release
177- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
178- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
179
180* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
181- rebuild with libgsf-1.14.22
182- add Patch1 (gnumeric-1.10.17-libgsf.patch)
183
184* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
185- new upstream release
186- update Patch0
187
188* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
189- new upstream release
190
191* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
192- new upstream release
193- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
194
195* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
196- new upstream release
197
198* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
199- new upstream release
200
201* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
202- new upstream release
203
204* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
205- new upstream release
206- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
207   (fix error of MIME type)
208
209* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
210- new upstream release
211
212* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
213- new upstream release
214
215* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
216- new upstream release
217- fix %post and %postun
218
219* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
220- new upstream release
221
222* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
223- new upstream release
224- add BuildRequires: libSM-devel
225- fix BuildRequires: goffice-devel >= 0.8.1
226
227* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
228- spec in UTF-8 (fixed)
229
230* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
231- spec in UTF-8
232- added BuildRequires: libffi-devel
233- added %%pre, %%preun section
234
235* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
236- new upstream release
237- built with libgda-3.1.4, libgnomedb-3.1.2
238- applied new versioning policy
239
240* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
241- new upstream release
242
243* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
244- rebuild
245
246* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
247- new upstream release
248
249* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
250- new upstream release
251- updated build dependancies
252- rebuilt with libgsf-1.14.0
253- built with libgda and libgnomedb again
254
255* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
256- new upstream release
257- updated build dependancies
258- not compile with libgda and libgnomedb in this version
259
260* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
261- new upstream release
262
263* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
264- rebuild with libgda 1.2.0 and libgnome 1.2.0
265
266* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
267- new upstream release
268
269* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
270- new upstream release
271
272* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
273- new upstream release
274
275* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
276- rebuild with gnome-2.8 environment and libgsf-1.10.1
277
278* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
279- new upstream release
280- added BuildRequires: desktop-file-utils
281
282* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
283- new upstream release
284- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
285
286* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
287- new upstream release
288
289* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
290- new upstream release
291
292* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
293- new upstream release
294
295* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
296- new upstream release
297
298* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
299- new upstream release
300- clean up spec file (a little bit!)
301
302* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
303- new upstream release
304
305* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
306- new upstream release
307- to use intltool-0.28
308
309* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
310- new upstream release
311- rebuild with new toolchains
312
313* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
314- new upstream release
315- build with new libgnomeprint, libgnomeprintui
316
317* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
318- new upstream release
319
320* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
321- rebuild with newer libgda, libgnomedb
322
323* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
324- updated to 1.2.0 (stable release)
325- guile support is temporarily off this version.
326
327* Tue Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
328- update to 1.1.20 (gtk+-2 port)
329- based on Redhat Rawhide 1.1.20-1
330
331* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
332- update to 1.0.13
333- rebuild with gal 0.24
334
335* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
336- guile support on
337- rebuild with new gal, bonobo, libgda
338
339* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
340- New upstream release, remove xmliobackward.patch
341
342* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
343- xml-io back to 1.0.10 because japanese corrups with new xml_parser
344
345* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
346- New upstream release, fix for xml importing files with non ASCII characters.
347- Without guile, changelog.archive, requires, build scripts, description
348
349* Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
350- files: add gnumericConf.sh, which was missing
351
352* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
353- New upstream release.
354- BuildPrereq oaf-devel
355
356* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
357- New upstream release.
358
359* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
360- New upstream release.
361- Default font and Japanese fonts in excel
362- requires
363
364* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
365- New upstream release.
366- fixed plugins, apply patch2, remove patch3
367- files - no longer devel package
368- function-reference.html in help file
369
370* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
371- New upstream release.
372
373* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
374- New upstream release.
375- Fixed several owner dir.
376
377* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
378- Build against with new gal
379
380* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
381- New upstream release.
382
383* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
384- New upstream release.
385
386* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
387- New upstream release.
388- Applied XIM over-the-spot patch.
389- Fixed directories owner.
390
391* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
392- New upstream release.
393- Enable Bonobo.
394- Merged several RH patches.
395- Added BuildPreReq tags.
396
397* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
398- Fixed packaging mistake.
399
400* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
401- Rebuild for GAL 0.7
402
403* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
404- New upstream release.
405- Use rpmmacros.
406
407* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
408- 0.56-0vl2
409- update ja.po
410- avoid core dump when inserting a row
411
412* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
413- updated to 0.56
414- remake spec with the orginal gnumeric spec file.
415- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
416
417* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
418- updated to 0.53
419- remake SPEC based on gnumeric original.
420- added libxml183 patch for libxml 1.8.3
421
422* Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
423- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
424- Added --without-bonobo and --without-gb.
425- Added %define for sysconfdir
426
427* Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
428- Updated version requirements for gnome-print, and gnome-libs.
429
430* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
431- Added in some auto-detect the language files logic (rpm 3.0.xx only)
432
433* Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
434- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
435
436* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
437- Updated to 0.47
438
439* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
440- Updated the libglade dependancy.
441- Remove req for guile.  We can build without it.
442
443* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
444- Added small fix so glade generated dialogs appear.
445
446* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
447- Added the gnome-print requirement.
448- Updated the file list to try and quiet down the updating.
449- added the sysconfdir
450
451* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
452- Updated the spec file.
453
454* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
455- Version 0.2
456
Note: See TracBrowser for help on using the repository browser.