source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 8369

Revision 8369, 14.1 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.10.14
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.12.14
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
78desktop-file-install --vendor gnome --delete-original                   \
79  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
80  --add-category Office                                                 \
81  --add-category Application                                            \
82  --add-category Spreadsheet                                            \
83  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
84  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
85
86%find_lang %{name}-%{version}
87%find_lang %{name}-%{version}-functions
88cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
89
90find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
91
92rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
93rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
94rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99%post
100/sbin/ldconfig
101scrollkeeper-update > /dev/null 2>&1 || :
102touch --no-create %{_datadir}/icons/hicolor || :
103if [ -x %{_bindir}/gtk-update-icon-cache ]; then
104   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
105fi
106update-desktop-database -q &> /dev/null || :
107
108%postun
109/sbin/ldconfig
110scrollkeeper-update > /dev/null 2>&1 || :
111touch --no-create %{_datadir}/icons/hicolor || :
112if [ -x %{_bindir}/gtk-update-icon-cache ]; then
113   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
114fi
115update-desktop-database -q &> /dev/null || :
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121
122%files -f %{name}-%{version}.lang
123%defattr (-, root, root)
124%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
125%{_bindir}/*
126%{_libdir}/libspreadsheet*.so
127%{_libdir}/%{name}
128%{_libdir}/goffice/0.10/plugins/%{name}
129%{_datadir}/appdata/gnumeric.appdata.xml
130%{_datadir}/applications/*.desktop
131%{_datadir}/glib-2.0/schemas/*.xml
132%{_datadir}/gnome/help/%{name}
133%{_datadir}/%{name}
134%{_datadir}/pixmaps/*
135%{_datadir}/omf/*
136%{_datadir}/icons/hicolor/*
137%{_mandir}/man*/*
138%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
139
140
141%changelog
142* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
143- new upstream release
144
145* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
146- new upstream release
147
148* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
149- new upstream release
150
151* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
152- new upstream release
153
154* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
155- new upstream release
156
157* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
158- new upstream release
159
160* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
161- new upstream release
162
163* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
164- new upstream release
165
166* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
167- new upstream release
168
169* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
170- new upstream release
171
172* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
173- new upstream release
174- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
175- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
176
177* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
178- rebuild with libgsf-1.14.22
179- add Patch1 (gnumeric-1.10.17-libgsf.patch)
180
181* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
182- new upstream release
183- update Patch0
184
185* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
186- new upstream release
187
188* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
189- new upstream release
190- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
191
192* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
193- new upstream release
194
195* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
196- new upstream release
197
198* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
199- new upstream release
200
201* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
202- new upstream release
203- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
204   (fix error of MIME type)
205
206* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
207- new upstream release
208
209* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
210- new upstream release
211
212* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
213- new upstream release
214- fix %post and %postun
215
216* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
217- new upstream release
218
219* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
220- new upstream release
221- add BuildRequires: libSM-devel
222- fix BuildRequires: goffice-devel >= 0.8.1
223
224* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
225- spec in UTF-8 (fixed)
226
227* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
228- spec in UTF-8
229- added BuildRequires: libffi-devel
230- added %%pre, %%preun section
231
232* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
233- new upstream release
234- built with libgda-3.1.4, libgnomedb-3.1.2
235- applied new versioning policy
236
237* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
238- new upstream release
239
240* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
241- rebuild
242
243* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
244- new upstream release
245
246* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
247- new upstream release
248- updated build dependancies
249- rebuilt with libgsf-1.14.0
250- built with libgda and libgnomedb again
251
252* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
253- new upstream release
254- updated build dependancies
255- not compile with libgda and libgnomedb in this version
256
257* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
258- new upstream release
259
260* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
261- rebuild with libgda 1.2.0 and libgnome 1.2.0
262
263* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
264- new upstream release
265
266* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
267- new upstream release
268
269* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
270- new upstream release
271
272* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
273- rebuild with gnome-2.8 environment and libgsf-1.10.1
274
275* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
276- new upstream release
277- added BuildRequires: desktop-file-utils
278
279* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
280- new upstream release
281- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
282
283* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
284- new upstream release
285
286* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
287- new upstream release
288
289* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
290- new upstream release
291
292* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
293- new upstream release
294
295* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
296- new upstream release
297- clean up spec file (a little bit!)
298
299* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
300- new upstream release
301
302* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
303- new upstream release
304- to use intltool-0.28
305
306* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
307- new upstream release
308- rebuild with new toolchains
309
310* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
311- new upstream release
312- build with new libgnomeprint, libgnomeprintui
313
314* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
315- new upstream release
316
317* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
318- rebuild with newer libgda, libgnomedb
319
320* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
321- updated to 1.2.0 (stable release)
322- guile support is temporarily off this version.
323
324* Tue Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
325- update to 1.1.20 (gtk+-2 port)
326- based on Redhat Rawhide 1.1.20-1
327
328* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
329- update to 1.0.13
330- rebuild with gal 0.24
331
332* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
333- guile support on
334- rebuild with new gal, bonobo, libgda
335
336* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
337- New upstream release, remove xmliobackward.patch
338
339* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
340- xml-io back to 1.0.10 because japanese corrups with new xml_parser
341
342* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
343- New upstream release, fix for xml importing files with non ASCII characters.
344- Without guile, changelog.archive, requires, build scripts, description
345
346* Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
347- files: add gnumericConf.sh, which was missing
348
349* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
350- New upstream release.
351- BuildPrereq oaf-devel
352
353* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
354- New upstream release.
355
356* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
357- New upstream release.
358- Default font and Japanese fonts in excel
359- requires
360
361* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
362- New upstream release.
363- fixed plugins, apply patch2, remove patch3
364- files - no longer devel package
365- function-reference.html in help file
366
367* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
368- New upstream release.
369
370* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
371- New upstream release.
372- Fixed several owner dir.
373
374* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
375- Build against with new gal
376
377* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
378- New upstream release.
379
380* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
381- New upstream release.
382
383* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
384- New upstream release.
385- Applied XIM over-the-spot patch.
386- Fixed directories owner.
387
388* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
389- New upstream release.
390- Enable Bonobo.
391- Merged several RH patches.
392- Added BuildPreReq tags.
393
394* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
395- Fixed packaging mistake.
396
397* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
398- Rebuild for GAL 0.7
399
400* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
401- New upstream release.
402- Use rpmmacros.
403
404* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
405- 0.56-0vl2
406- update ja.po
407- avoid core dump when inserting a row
408
409* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
410- updated to 0.56
411- remake spec with the orginal gnumeric spec file.
412- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
413
414* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
415- updated to 0.53
416- remake SPEC based on gnumeric original.
417- added libxml183 patch for libxml 1.8.3
418
419* Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
420- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
421- Added --without-bonobo and --without-gb.
422- Added %define for sysconfdir
423
424* Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
425- Updated version requirements for gnome-print, and gnome-libs.
426
427* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
428- Added in some auto-detect the language files logic (rpm 3.0.xx only)
429
430* Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
431- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
432
433* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
434- Updated to 0.47
435
436* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
437- Updated the libglade dependancy.
438- Remove req for guile.  We can build without it.
439
440* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
441- Added small fix so glade generated dialogs appear.
442
443* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
444- Added the gnome-print requirement.
445- Updated the file list to try and quiet down the updating.
446- added the sysconfdir
447
448* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
449- Updated the spec file.
450
451* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
452- Version 0.2
453
Note: See TracBrowser for help on using the repository browser.