source: projects/specs/trunk/g/gnucash/gnucash-vl.spec @ 9426

Revision 9426, 8.2 KB checked in by inagaki, 9 years ago (diff)

2015-03-09 Ryoichi INAGAKI <ryo1@…>

  • gnucash, kmymoney, skrooge: rebuilt
  • libofx: updated


Line 
1%define ver 2.6.5
2%define rel 2%{?_dist_release}
3%define __libtoolize /bin/true
4
5Name:           gnucash
6Summary:        GnuCash is an application to keep track of your finances.
7Summary(ja):    個人用財務管理アプリケーション
8Version:        %{ver}
9Release:        %{rel}
10
11License:        GPL/LGPL/GFDL
12Group:          Applications/Productivity
13URL:            http://www.gnucash.org/
14
15Source:         %{name}-%{version}.tar.bz2
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires: aqbanking-devel >= 3.7.2
19BuildRequires: bzip2-devel
20BuildRequires: expat-devel
21BuildRequires: gettext
22BuildRequires: goffice08-devel >= 0.8
23BuildRequires: gtk2-devel
24BuildRequires: WebKit-gtk-devel
25BuildRequires: guile-devel
26BuildRequires: libofx-devel
27BuildRequires: libgnomeui-devel
28BuildRequires: libdbi-devel
29BuildRequires: libjpeg-devel
30BuildRequires: pcre-devel
31BuildRequires: popt-devel
32BuildRequires: swig
33#BuildRequires: slib
34BuildRequires: gwenhywfar-devel
35BuildRequires: desktop-file-utils
36
37BuildRequires: libdbi-dbd-pgsql
38BuildRequires: libdbi-dbd-mysql
39BuildRequires: libdbi-dbd-sqlite
40
41Requires:      aqbanking
42Requires:      perl-DateManip
43Requires:      yelp
44Requires(post,postun): gtk2
45Requires(postun,posttrans): glib2
46Obsoletes:     gnucash-backend-postgres
47
48Vendor:        Project Vine
49Distribution:  Vine Linux
50Packager:      kenta, inagaki
51
52
53%description
54GnuCash is a personal finance manager. A check-book like
55register GUI allows you to enter and track bank accounts,
56stocks, income and even currency trades. The interface is
57designed to be simple and easy to use, but is backed with
58double-entry accounting principles to ensure balanced books.
59
60%description -l ja
61GnuCashは 個人用財務管理をするアプリケーションです.
62預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
63グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
64使用できるようにデザインされています.
65
66%prep
67%setup -q
68
69%build
70%configure \
71                --enable-error-on-warning=no \
72                --disable-sql \
73                --enable-ofx  \
74                --enable-aqbanking \
75                --disable-static \
76                --enable-dbi \
77                --with-html-engine=webkit \
78                --docdir=%{_datadir}/doc/gnucash-%{version}
79
80make LIBTOOL=%{_bindir}/libtool
81
82%configure
83make
84
85
86%install
87[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
88
89make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
90
91%find_lang %name
92
93# vfolder desktop file install stuff
94mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
95desktop-file-install --vendor gnome --delete-original \
96  --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
97  --add-category X-Red-Hat-Extra                      \
98  --add-category Application                          \
99  --add-category Office                               \
100  $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
101echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
102
103rm -rf $RPM_BUILD_ROOT/%{_infodir} \
104       $RPM_BUILD_ROOT/%{_includedir} \
105       $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
106       $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
107
108%clean
109[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
110
111
112%post
113/sbin/ldconfig
114touch --no-create %{_datadir}/icons/hicolor || :
115gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
116
117%postun
118if [ $1 -eq 0 ] ; then
119        /sbin/ldconfig
120        touch --no-create %{_datadir}/icons/hicolor || :
121        gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
122        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
123fi
124
125%posttrans
126glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
127
128%files -f %{name}.lang
129%defattr(-,root,root,755)
130%config %{_sysconfdir}/%{name}
131%{_bindir}/*
132%{_libexecdir}/%{name}
133%{_libdir}/*
134%{_datadir}/appdata/%{name}.appdata.xml
135%{_datadir}/applications/*
136%{_datadir}/glib-2.0/schemas/*.xml
137%{_datadir}/%{name}
138%{_datadir}/icons/hicolor/*/apps/*
139%{_docdir}/%{name}
140%{_mandir}/man*/*
141%doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
142%doc doc/README.german doc/README.francais doc/guile-hackers.txt
143%doc doc/README.OFX
144
145%changelog
146* Mon Mar  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
147- rebuilt with libofx 0.9.10
148- added Vendor and Distribution tag
149
150* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
151- update to 2.6.5
152- remove old patches
153- add BuildRequires: libdbi-devel
154- change BuildRequires: goffice08-devel instead of goffice-devel
155
156* Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
157- rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
158- added Patch1 for building with aqbanking-4.2.4
159- added Patch2 for building with goffice-0.8.10
160
161* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
162- added slib to BuildRequires: and Requires:
163
164* Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
165- new upstream release
166
167* Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
168- new upstream release
169
170* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
171- rebuild with guile-1.8.6
172- add BuildRequires: gwenhywfar-devel
173
174* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
175- new upstream release
176- applied new versioning policy
177- built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
178
179* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
180- new upstream release
181- rebuilt with goffice-0.6.0
182
183* Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
184- new upstream release
185
186* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
187- new upstream release
188- enable HBCI (Home Banking Computer Interface)
189
190* Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
191- rebuild with libofx-0.8.3 (libofx.so.3)
192
193* Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
194- new upstream release
195- disable postgresql backend, as it is unmaintained upstream
196- added Patch0: gnucash-2.2.0-quiet.patch
197
198* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
199- new upstream release
200- remove BuildRequiers: autoconf213
201- update ja.po
202
203* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
204- new upstream release
205- added BuildPrereq: libtool-ltdl-devel
206
207* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
208- rebuild with new toolchains
209- update ja.po
210
211* Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
212- new upstream release
213
214* Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
215- merged gnucash-docs-1.8.3
216- added patch from Redhat Rawhide 1.8.7-1
217- changed Group, License
218
219* Mon Oct  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
220- updated to 1.8.7
221- updated print.patch
222- overwrite prefs.scm
223- s/Copyright/License/
224
225* Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
226- updated to 1.8.3
227- added datelength.patch
228- separated devel packages
229  (and ofx, hbci, backend-postgres. But default is off)
230
231* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
232- Build against with new gal.
233
234* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
235- Fixed printing issue.
236
237* Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
238- New upstream release.
239
240* Thu Jul 26 2001 <sagami@vinelinux.org>
241- 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
242
243* Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
244- %%make line is now commented out (bash2 complains it)
245  (BTW, what the hell is the macro %%make anyway? I don't even know...)
246
247* Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
248- update to 1.6.0 (stable release version)
249
250* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
251- update to 1.5.96 ( pre beta for 1.6.0 )
252
253* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
254- added japanese patch for reporting and printing (thanx tagoh-san)
255
256* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
257- updated to 1.5.6
258
259* Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
260- added translation messages to ja.po
261- enable guppi
262
263* Mon Apr  2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
264- upstream update
265- fixed broken ja.po
266
267* Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
268- fixed registor window cursor position problem(gnucash-cursor_pos.patch)
269
270* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
271- initial relese package
Note: See TracBrowser for help on using the repository browser.