source: projects/specs/trunk/g/gnucash/gnucash-vl.spec @ 9291

Revision 9291, 8.0 KB checked in by Takemikaduchi, 9 years ago (diff)

libdbi-drivers,goffice08,guile18: NEW package
geda-gaf,missile,rrdtool,trackballs,trackballs-music,ulogd,xkeycaps,xorg-x11-jpfonts: rebuild
others: new upstream release

Line 
1%define ver 2.6.5
2%define rel 1%{?_dist_release}
3%define __libtoolize /bin/true
4
5Name:           gnucash
6Summary:        GnuCash is an application to keep track of your finances.
7Summary(ja):    個人用財務管理アプリケーション
8Version:        %{ver}
9Release:        %{rel}
10
11License:        GPL/LGPL/GFDL
12Group:          Applications/Productivity
13URL:            http://www.gnucash.org/
14
15Source:         %{name}-%{version}.tar.bz2
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires: aqbanking-devel >= 3.7.2
19BuildRequires: bzip2-devel
20BuildRequires: expat-devel
21BuildRequires: gettext
22BuildRequires: goffice08-devel >= 0.8
23BuildRequires: gtk2-devel
24BuildRequires: WebKit-gtk-devel
25BuildRequires: guile-devel
26BuildRequires: libofx-devel
27BuildRequires: libgnomeui-devel
28BuildRequires: libdbi-devel
29BuildRequires: libjpeg-devel
30BuildRequires: pcre-devel
31BuildRequires: popt-devel
32BuildRequires: swig
33#BuildRequires: slib
34BuildRequires: gwenhywfar-devel
35BuildRequires: desktop-file-utils
36
37BuildRequires: libdbi-dbd-pgsql
38BuildRequires: libdbi-dbd-mysql
39BuildRequires: libdbi-dbd-sqlite
40
41Requires:      aqbanking
42Requires:      perl-DateManip
43Requires:      yelp
44Requires(post,postun): gtk2
45Requires(postun,posttrans): glib2
46Obsoletes:     gnucash-backend-postgres
47
48Packager:      kenta, inagaki
49
50
51%description
52GnuCash is a personal finance manager. A check-book like
53register GUI allows you to enter and track bank accounts,
54stocks, income and even currency trades. The interface is
55designed to be simple and easy to use, but is backed with
56double-entry accounting principles to ensure balanced books.
57
58%description -l ja
59GnuCashは 個人用財務管理をするアプリケーションです.
60預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
61グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
62使用できるようにデザインされています.
63
64%prep
65%setup -q
66
67%build
68%configure \
69                --enable-error-on-warning=no \
70                --disable-sql \
71                --enable-ofx  \
72                --enable-aqbanking \
73                --disable-static \
74                --enable-dbi \
75                --with-html-engine=webkit \
76                --docdir=%{_datadir}/doc/gnucash-%{version}
77
78make LIBTOOL=%{_bindir}/libtool
79
80%configure
81make
82
83
84%install
85[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
86
87make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
88
89%find_lang %name
90
91# vfolder desktop file install stuff
92mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
93desktop-file-install --vendor gnome --delete-original \
94  --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
95  --add-category X-Red-Hat-Extra                      \
96  --add-category Application                          \
97  --add-category Office                               \
98  $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
99echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
100
101rm -rf $RPM_BUILD_ROOT/%{_infodir} \
102       $RPM_BUILD_ROOT/%{_includedir} \
103       $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
104       $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
105
106%clean
107[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
108
109
110%post
111/sbin/ldconfig
112touch --no-create %{_datadir}/icons/hicolor || :
113gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
114
115%postun
116if [ $1 -eq 0 ] ; then
117        /sbin/ldconfig
118        touch --no-create %{_datadir}/icons/hicolor || :
119        gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
120        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
121fi
122
123%posttrans
124glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
125
126%files -f %{name}.lang
127%defattr(-,root,root,755)
128%config %{_sysconfdir}/%{name}
129%{_bindir}/*
130%{_libexecdir}/%{name}
131%{_libdir}/*
132%{_datadir}/appdata/%{name}.appdata.xml
133%{_datadir}/applications/*
134%{_datadir}/glib-2.0/schemas/*.xml
135%{_datadir}/%{name}
136%{_datadir}/icons/hicolor/*/apps/*
137%{_docdir}/%{name}
138%{_mandir}/man*/*
139%doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
140%doc doc/README.german doc/README.francais doc/guile-hackers.txt
141%doc doc/README.OFX
142
143%changelog
144* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
145- update to 2.6.5
146- remove old patches
147- add BuildRequires: libdbi-devel
148- change BuildRequires: goffice08-devel instead of goffice-devel
149
150* Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
151- rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
152- added Patch1 for building with aqbanking-4.2.4
153- added Patch2 for building with goffice-0.8.10
154
155* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
156- added slib to BuildRequires: and Requires:
157
158* Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
159- new upstream release
160
161* Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
162- new upstream release
163
164* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
165- rebuild with guile-1.8.6
166- add BuildRequires: gwenhywfar-devel
167
168* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
169- new upstream release
170- applied new versioning policy
171- built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
172
173* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
174- new upstream release
175- rebuilt with goffice-0.6.0
176
177* Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
178- new upstream release
179
180* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
181- new upstream release
182- enable HBCI (Home Banking Computer Interface)
183
184* Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
185- rebuild with libofx-0.8.3 (libofx.so.3)
186
187* Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
188- new upstream release
189- disable postgresql backend, as it is unmaintained upstream
190- added Patch0: gnucash-2.2.0-quiet.patch
191
192* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
193- new upstream release
194- remove BuildRequiers: autoconf213
195- update ja.po
196
197* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
198- new upstream release
199- added BuildPrereq: libtool-ltdl-devel
200
201* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
202- rebuild with new toolchains
203- update ja.po
204
205* Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
206- new upstream release
207
208* Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
209- merged gnucash-docs-1.8.3
210- added patch from Redhat Rawhide 1.8.7-1
211- changed Group, License
212
213* Mon Oct  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
214- updated to 1.8.7
215- updated print.patch
216- overwrite prefs.scm
217- s/Copyright/License/
218
219* Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
220- updated to 1.8.3
221- added datelength.patch
222- separated devel packages
223  (and ofx, hbci, backend-postgres. But default is off)
224
225* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
226- Build against with new gal.
227
228* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
229- Fixed printing issue.
230
231* Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
232- New upstream release.
233
234* Thu Jul 26 2001 <sagami@vinelinux.org>
235- 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
236
237* Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
238- %%make line is now commented out (bash2 complains it)
239  (BTW, what the hell is the macro %%make anyway? I don't even know...)
240
241* Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
242- update to 1.6.0 (stable release version)
243
244* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
245- update to 1.5.96 ( pre beta for 1.6.0 )
246
247* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
248- added japanese patch for reporting and printing (thanx tagoh-san)
249
250* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
251- updated to 1.5.6
252
253* Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
254- added translation messages to ja.po
255- enable guppi
256
257* Mon Apr  2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
258- upstream update
259- fixed broken ja.po
260
261* Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
262- fixed registor window cursor position problem(gnucash-cursor_pos.patch)
263
264* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
265- initial relese package
Note: See TracBrowser for help on using the repository browser.