source: projects/specs/trunk/g/gnome-web-photo/gnome-web-photo-vl.spec @ 8152

Revision 8152, 6.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_vine7 0
2
3%if "%{?_dist_release}" == "vl7"
4%define build_vine7 1
5%endif
6
7Summary:        HTML pages thumbnailer
8Summary(ja):    HTML ページのサムネール作成ツール
9Name:           gnome-web-photo
10Version:        0.10.6
11Release:        2%{?_dist_release}
12License:        LGPLv2+
13Group:          Applications/Internet
14URL:            http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/
15Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/%{name}-%{version}.tar.xz
16
17BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
18%if %{build_vine7}
19BuildRequires:  gtk3-devel >= 2.14.0
20BuildRequires:  WebKit3-gtk-devel >= 1.1.23
21%else
22Requires(post): GConf2
23Requires(preun):GConf2
24BuildRequires:  gtk2-devel >= 2.14.0
25BuildRequires:  GConf2-devel
26BuildRequires:  WebKit-gtk-devel >= 1.1.23
27%endif
28BuildRequires:  gettext intltool
29
30Vendor:         Project Vine
31Distribution:   Vine Linux
32Packager:       kazutaka
33
34%description
35gnome-web-photo contains a thumbnailer that will be used by
36GNOME applications, including the file manager, to generate
37screenshots of web pages.
38
39%prep
40%setup -q
41
42%build
43%if %{build_vine7}
44%configure --with-gtk=3.0
45%else
46%configure --with-gtk=2.0
47%endif
48%{__make} %{?_smp_mflags}
49
50%install
51%{__rm} -rf $RPM_BUILD_ROOT
52
53%if %{build_vine7}
54%{__make} DESTDIR=$RPM_BUILD_ROOT install
55%else
56export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
57%{__make} DESTDIR=$RPM_BUILD_ROOT install
58unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
59
60%{__mv} $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/thumbnailer.schemas \
61        $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
62%endif
63
64%find_lang %{name}
65
66
67%if %{build_vine7}
68
69%post -p /sbin/ldconfig
70%postun -p /sbin/ldconfig
71
72%else
73
74%post
75/sbin/ldconfig
76export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
77gconftool-2 --makefile-install-rule \
78        %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
79
80%pre
81if [ "$1" -gt 1 ]; then
82    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
83    gconftool-2 --makefile-uninstall-rule                               \
84        %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas            \
85        >& /dev/null || :
86fi
87
88%preun
89if [ "$1" -eq 0 ]; then
90    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91    gconftool-2 --makefile-uninstall-rule \
92      %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
93fi
94
95%postun -p /sbin/ldconfig
96
97%endif
98
99
100%clean
101%{__rm} -rf $RPM_BUILD_ROOT
102
103%files -f %{name}.lang
104%defattr(-,root,root,-)
105%doc ChangeLog AUTHORS README TODO COPYING.README
106%if !%{build_vine7}
107%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
108%endif
109%{_bindir}/gnome-web-photo
110%{_bindir}/gnome-web-print
111%{_bindir}/gnome-web-thumbnail
112%{_datadir}/gnome-web-photo
113%if %{build_vine7}
114%{_datadir}/thumbnailers/gnome-web-photo.thumbnailer
115%endif
116
117%changelog
118* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.6-2
119- rebuild with VineSeed environment
120
121* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.6-1
122- new upstream release
123
124* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-1
125- new upstream release
126
127* Sat Apr 17 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-4
128- remove %%{gecko_version} macro and specify explicit minimum version
129
130* Sat Mar 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-3
131- rebuild with xulrunner-%{gecko_version}
132
133* Wed Jan 27 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-2
134- rebuild with xulrunner-%{gecko_version}
135- add Patch0 to fix xulrunner-1.9.2 build
136
137* Fri Jan 15 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-1
138- new upstream release
139- build with xulrunner-1.9.1.7 (gecko-libs)
140
141* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8-1
142- initial build for Vine Linux based on fedora development
143
144* Fri Sep 11 2009 Jan Horak <jhorak@redhat.com> - 0.8-6
145- Rebuild against newer gecko
146
147* Thu Aug 06 2009 Jan Horak <jhorak@redhat.com> - 0.8-5
148- Rebuild against newer gecko
149
150* Tue Aug 04 2009 Jan Horak <jhorak@redhat.com> - 0.8-4
151- Rebuild against newer gecko
152
153* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8-3
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
155
156* Mon Jul 20 2009 Jan Horak <jhorak@redhat.com> - 0.8-2
157- Rebuild against newer gecko
158
159* Tue Jun 30 2009 Matthias Clasen <mclasen@redhat.com> - 0.8-1
160- Update to 0.8
161
162* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.7-2
163- Rebuild against newer gecko
164
165* Mon Apr 13 2009 Matthias Clasen <mclasen@redhat.com> - 0.7-1
166- Update to 0.7
167
168* Tue Mar 24 2009 Jan Horak <jhorak@redhat.com> - 0.6-2
169- Fix for rebuild against newer gecko
170
171* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.6-1
172- Update to 0.6
173
174* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-14
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
176
177* Tue Jan 06 2009 Christopher Aillon <caillon@redhat.com> - 0.3-13
178- Rebuild against newer gecko
179
180* Wed Nov 12 2008 Christopher Aillon <caillon@redhat.com> - 0.3-12
181- Rebuild against newer gecko
182
183* Wed Mar 12 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-11
184- Better xulrunner-1.9 patch which also works with very long pages
185
186* Fri Mar  7 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-10
187- Add patch to make it work with xulrunner 1.9
188
189* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.3-9
190- Autorebuild for GCC 4.3
191
192* Tue Nov 27 2007 Christopher Aillon <caillon@redhat.com> - 0.3-8
193- Rebuild against newer gecko
194
195* Fri Nov 23 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-7
196- Rebuilding against xulrunner will require a lot of porting,
197  disable for now
198
199* Fri Nov 16 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-6
200- Try to rebuild with xulrunner
201
202* Thu Oct 25 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-5
203- Rebuild for new Gecko, tighten dependencies
204
205* Mon Sep 10 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-4
206- Fix license, as mentioned by Kevin Fenzi
207
208* Thu Sep 06 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-3
209- Update following Matthias Clasen's comments
210
211* Wed Sep 05 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-2
212- Update following Peter Gordon's comments
213
214* Tue Mar 20 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-1
215- First post!
216
Note: See TracBrowser for help on using the repository browser.