source: projects/specs/trunk/g/gnome-user-share/gnome-user-share-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Gnome user file sharing
2Summary(ja): Gnome ユーザファイル共有
3Name: gnome-user-share
4Version: 2.28.2
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Libraries
8URL: http://www.gnome.org
9Source0: %{name}-%{version}.tar.bz2
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12Requires: httpd >= 2.2.0
13Requires: gnome-bluetooth-libs >= 2.28.0
14BuildRequires: GConf2-devel avahi-glib-devel >= 0.6 pkgconfig
15BuildRequires: gtk2-devel >= 2.4.0
16BuildRequires: httpd >= 2.2.0
17BuildRequires: libglade2-devel >= 2.0.0
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: perl(XML::Parser)
21BuildRequires: libnotify-devel
22BuildRequires: libcanberra-devel
23BuildRequires: gnome-bluetooth-devel >= 2.28.0
24BuildRequires: unique-devel
25BuildRequires: gnome-doc-utils
26Requires(post,pre,preun): GConf2
27
28%description
29gnome-user-share is a small package that binds together various free
30software projects to bring easy to use user-level file sharing to the
31masses.
32
33%prep
34%setup -q
35
36%build
37%configure
38%__make %{?_smp_mflags}
39
40%install
41rm -rf $RPM_BUILD_ROOT
42
43export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
44%__make install DESTDIR=$RPM_BUILD_ROOT
45unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
46
47desktop-file-install --vendor gnome --delete-original                   \
48  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
49  --add-only-show-in GNOME                                              \
50  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
51
52%find_lang %{name}
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
59gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
60
61%pre
62if [ "$1" -gt 1 ]; then
63  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
64  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
65fi
66
67%preun
68if [ "$1" -eq 0 ]; then
69  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
70  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
71fi
72
73%files -f %{name}.lang
74%defattr(-,root,root,-)
75%doc README ChangeLog
76%{_bindir}/*
77%{_libexecdir}/*
78%{_datadir}/gnome-user-share
79%{_datadir}/applications/*
80%{_datadir}/gnome/*
81%{_datadir}/icons/hicolor/*/apps/*
82%{_datadir}/omf/*
83%{_sysconfdir}/gconf/schemas/*
84%{_sysconfdir}/xdg/autostart/gnome-user-share.desktop
85
86%changelog
87* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
88- initial build for Vine Linux
89- add BuildRequires: libnotify-devel, libcanberra-devel, gnome-bluetooth-devel, unique-devel, gnome-doc-utils
90- add Requires: gnome-bluetooth-libs
91
92* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11-0vl1
93- initial build for Vine Linux
94
95* Fri Mar 23 2007 Matthias Clasen  <mclasen@redhat.com> - 0.11-2
96- Don't hardwire invisible char (#233676)
97
98* Tue Mar  6 2007 Alexander Larsson <alexl@redhat.com> - 0.11-1
99- Update to 0.11 with xdg-user-dirs support
100
101* Wed Jan 24 2007 Matthias Clasen <mclasen@redhat.com> 0.10-6
102- Add better categories to the desktop file
103
104* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 0.10-5
105- rebuilt for unwind info generation, broken in gcc-4.1.1-21
106
107* Thu Sep 21 2006 Nalin Dahyabhai <nalin@redhat.com> - 0.10-4
108- add missing BuildRequires: on httpd, so that the configure script can find
109  the binary
110
111* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.10-3.1
112- rebuild
113
114* Mon May 29 2006 Alexander Larsson <alexl@redhat.com> - 0.10-3
115- buildrequire gettext and perl-XML-Parser (#193391)
116
117* Thu Apr 20 2006 Matthias Clasen <mclasen@redhat.com> 0.10-2
118- Update to 0.10
119
120* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 0.9-3
121- BuildRequires: gtk2-devel, libglade2-devel, libselinux-devel
122
123* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9-2.2
124- bump again for double-long bug on ppc(64)
125
126* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9-2.1
127- rebuilt for new gcc4.1 snapshot and glibc changes
128
129* Fri Feb  3 2006 Alexander Larsson <alexl@redhat.com> 0.9-2
130- Patch config for apache 2.2
131
132* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
133- rebuilt
134
135* Tue Nov 22 2005 Alexander Larsson <alexl@redhat.com> - 0.9-1
136- New release with avahi 0.6 support
137
138* Mon Nov 14 2005 Alexander Larsson <alexl@redhat.com> - 0.8-1
139- update to 0.8
140
141* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.7-1
142- New version, with desktop file
143
144* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.6-1
145- New version, switch to avahi
146- Handle translations
147
148* Fri Dec  3 2004 Alexander Larsson <alexl@redhat.com> - 0.4-1
149- New version
150
151* Fri Nov 26 2004 Alexander Larsson <alexl@redhat.com> - 0.3-1
152- New version
153
154* Thu Sep  9 2004 Alexander Larsson <alexl@redhat.com> - 0.2-1
155- New version
156
157* Wed Sep  8 2004 Alexander Larsson <alexl@redhat.com> - 0.1-1
158- Initial Build
159
Note: See TracBrowser for help on using the repository browser.