source: projects/specs/trunk/g/gnome-user-share/gnome-user-share-vl.spec @ 912

Revision 912, 5.1 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file

Line 
1Summary: Gnome user file sharing
2Summary(ja): Gnome ユーザファイル共有
3Name: gnome-user-share
4Version: 2.30.0
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Libraries
8URL: http://www.gnome.org
9Source0: %{name}-%{version}.tar.bz2
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12Requires: httpd >= 2.2.0
13Requires: gnome-bluetooth-libs >= 2.28.0
14BuildRequires: GConf2-devel avahi-glib-devel >= 0.6 pkgconfig
15BuildRequires: gtk2-devel >= 2.4.0
16BuildRequires: httpd >= 2.2.0
17BuildRequires: libglade2-devel >= 2.0.0
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: perl(XML::Parser)
21BuildRequires: libnotify-devel
22BuildRequires: libcanberra-devel
23BuildRequires: gnome-bluetooth-devel >= 2.30.0
24BuildRequires: unique-devel
25BuildRequires: nautilus-devel
26BuildRequires: gnome-doc-utils
27Requires(post,pre,preun): GConf2
28
29%description
30gnome-user-share is a small package that binds together various free
31software projects to bring easy to use user-level file sharing to the
32masses.
33
34%prep
35%setup -q
36
37%build
38%configure
39%__make %{?_smp_mflags}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43
44export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
45%__make install DESTDIR=$RPM_BUILD_ROOT
46unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
47
48rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/*.la
49
50desktop-file-install --vendor gnome --delete-original                   \
51  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
52  --add-only-show-in GNOME                                              \
53  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
54
55%find_lang %{name}
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%post
61export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
62gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
63
64%pre
65if [ "$1" -gt 1 ]; then
66  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
67  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
68fi
69
70%preun
71if [ "$1" -eq 0 ]; then
72  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
73  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
74fi
75
76%files -f %{name}.lang
77%defattr(-,root,root,-)
78%doc README ChangeLog
79%{_bindir}/*
80%{_libexecdir}/*
81%{_libdir}/nautilus/extensions-2.0/*.so
82%{_datadir}/gnome-user-share
83%{_datadir}/applications/*
84%{_datadir}/gnome/*
85%{_datadir}/icons/hicolor/*/apps/*
86%{_datadir}/omf/*
87%{_sysconfdir}/gconf/schemas/*
88%{_sysconfdir}/xdg/autostart/gnome-user-share.desktop
89
90%changelog
91* Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
92- new upstream release
93- add BuildRequires: nautilus-devel
94
95* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
96- new upstream release
97- add BuildRequires: libnotify-devel, libcanberra-devel, gnome-bluetooth-devel, unique-devel, gnome-doc-utils
98- add Requires: gnome-bluetooth-libs
99
100* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11-0vl1
101- initial build for Vine Linux
102
103* Fri Mar 23 2007 Matthias Clasen  <mclasen@redhat.com> - 0.11-2
104- Don't hardwire invisible char (#233676)
105
106* Tue Mar  6 2007 Alexander Larsson <alexl@redhat.com> - 0.11-1
107- Update to 0.11 with xdg-user-dirs support
108
109* Wed Jan 24 2007 Matthias Clasen <mclasen@redhat.com> 0.10-6
110- Add better categories to the desktop file
111
112* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 0.10-5
113- rebuilt for unwind info generation, broken in gcc-4.1.1-21
114
115* Thu Sep 21 2006 Nalin Dahyabhai <nalin@redhat.com> - 0.10-4
116- add missing BuildRequires: on httpd, so that the configure script can find
117  the binary
118
119* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.10-3.1
120- rebuild
121
122* Mon May 29 2006 Alexander Larsson <alexl@redhat.com> - 0.10-3
123- buildrequire gettext and perl-XML-Parser (#193391)
124
125* Thu Apr 20 2006 Matthias Clasen <mclasen@redhat.com> 0.10-2
126- Update to 0.10
127
128* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 0.9-3
129- BuildRequires: gtk2-devel, libglade2-devel, libselinux-devel
130
131* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9-2.2
132- bump again for double-long bug on ppc(64)
133
134* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9-2.1
135- rebuilt for new gcc4.1 snapshot and glibc changes
136
137* Fri Feb  3 2006 Alexander Larsson <alexl@redhat.com> 0.9-2
138- Patch config for apache 2.2
139
140* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
141- rebuilt
142
143* Tue Nov 22 2005 Alexander Larsson <alexl@redhat.com> - 0.9-1
144- New release with avahi 0.6 support
145
146* Mon Nov 14 2005 Alexander Larsson <alexl@redhat.com> - 0.8-1
147- update to 0.8
148
149* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.7-1
150- New version, with desktop file
151
152* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.6-1
153- New version, switch to avahi
154- Handle translations
155
156* Fri Dec  3 2004 Alexander Larsson <alexl@redhat.com> - 0.4-1
157- New version
158
159* Fri Nov 26 2004 Alexander Larsson <alexl@redhat.com> - 0.3-1
160- New version
161
162* Thu Sep  9 2004 Alexander Larsson <alexl@redhat.com> - 0.2-1
163- New version
164
165* Wed Sep  8 2004 Alexander Larsson <alexl@redhat.com> - 0.1-1
166- Initial Build
167
Note: See TracBrowser for help on using the repository browser.