source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9484

Revision 9484, 9.8 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define pkg_version 3.16.0
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
14
15License:        GPLv2+
16Group:          User Interface/Desktops
17URL:            http://live.gnome.org/GnomeShell
18
19Requires: mutter
20Requires: caribou
21Requires: ca-certificates
22Requires: at-spi2-atk
23Requires: telepathy-logger
24Requires: network-manager-applet
25Requires: gnome-tweak-tool
26
27BuildRequires: gnome-common
28BuildRequires: libtool
29BuildRequires: automake
30BuildRequires: autoconf
31
32BuildRequires: pkgconfig
33BuildRequires: gtk2-devel
34BuildRequires: clutter-devel
35BuildRequires: mutter-devel
36BuildRequires: gjs-devel
37BuildRequires: gnome-desktop3-devel
38BuildRequires: gnome-menus-devel
39BuildRequires: libSM-devel
40BuildRequires: libffi-devel
41BuildRequires: startup-notification-devel
42BuildRequires: gnome-doc-utils
43BuildRequires: desktop-file-utils
44BuildRequires: libcroco-devel
45BuildRequires: librsvg2-devel
46BuildRequires: gobject-introspection-devel
47BuildRequires: control-center-devel
48BuildRequires: gcr-devel
49BuildRequires: gstreamer-devel
50BuildRequires: dbus-glib-devel
51BuildRequires: telepathy-logger-devel
52BuildRequires: polkit-devel
53BuildRequires: pulseaudio-libs-devel
54BuildRequires: evolution-data-server-devel
55BuildRequires: folks-devel
56BuildRequires: NetworkManager-glib-devel
57BuildRequires: libnm-gtk-devel
58BuildRequires: libgudev1-devel
59BuildRequires: libcanberra-gtk3-devel
60BuildRequires: caribou-devel
61BuildRequires: ca-certificates
62BuildRequires: python3-devel
63BuildRequires: intltool
64
65BuildRoot: %{_tmppath}/%{name}-%{version}-root
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: Takemikaduchi
70
71
72%description
73GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
74It provides core interface functions like switching to windows and launching
75applications. GNOME Shell takes advantage of the capabilities of modern graphics
76hardware and introduces innovative user interface concepts to provide a delightful
77and easy to use experience.
78
79
80%package        docs
81Summary:        Documentation for %{name}
82Summary(ja):    %{name} 用のドキュメント
83Group:          Documentation
84Requires:       %{name} = %{version}-%{release}
85BuildArch:              noarch
86
87%description    docs
88This package contains documentation for %{name}.
89
90
91
92%prep
93%setup -q
94%patch101 -p1 -b .vine
95%patch102 -p1 -b .vine
96
97%build
98%configure \
99        --disable-static \
100        --disable-systemd
101
102%{__make} %{?_smp_mflags} V=1
103
104
105%install
106%{__rm} -rf ${RPM_BUILD_ROOT}
107%{__make} install DESTDIR=${RPM_BUILD_ROOT}
108
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
110
111rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
112%find_lang %{name}
113
114
115
116%clean
117%{__rm} -rf ${RPM_BUILD_ROOT}
118
119
120%post
121/sbin/ldconfig
122touch --no-create %{_datadir}/icons/hicolor
123if [ -x /usr/bin/gtk-update-icon-cache ]; then
124  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
125fi
126
127%postun
128/sbin/ldconfig
129touch --no-create %{_datadir}/icons/hicolor
130if [ -x /usr/bin/gtk-update-icon-cache ]; then
131  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
132fi
133glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134
135%posttrans
136glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
137
138
139%files -f %{name}.lang
140%defattr(-,root,root,-)
141%doc COPYING NEWS README
142%{_bindir}/gnome-shell
143%{_bindir}/gnome-shell-extension-tool
144%{_bindir}/gnome-shell-extension-prefs
145%{_bindir}/gnome-shell-perf-tool
146%{_libdir}/%{name}/*
147%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
148%{_libexecdir}/gnome-shell-calendar-server
149%{_libexecdir}/gnome-shell-hotplug-sniffer
150%{_libexecdir}/gnome-shell-perf-helper
151%{_libexecdir}/gnome-shell-portal-helper
152%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
153%{_datadir}/applications/gnome-shell.desktop
154%{_datadir}/applications/gnome-shell-extension-prefs.desktop
155%{_datadir}/applications/evolution-calendar.desktop
156%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
157%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
159%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
160%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
161%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
162%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
163%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
164%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
165%{_datadir}/%{name}/*
166%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
167%{_mandir}/man1/%{name}.1.gz
168
169%files docs
170%defattr(-,root,root,-)
171%{_datadir}/gtk-doc/html/shell
172%{_datadir}/gtk-doc/html/st
173
174
175%changelog
176* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
177- new upstream release
178- add BuildRequires: python3-devel
179- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
180
181* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
182- rebuilt with libical 1.0.1
183
184* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
185- new upstream release
186
187* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
188- new upstream release
189
190* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
191- new upstream release
192- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
193- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
194
195* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
196- new upstream release
197
198* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
199- new upstream release
200
201* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
202- new upstream release
203
204* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
205- new upstream release
206
207* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
208- new upstream release
209
210* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
211- new upstream release
212
213* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
214- new upstream release
215
216* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
217- new upstream release
218
219* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
220- new upstream release
221
222* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
223- new upstream release
224- update Patch101 (gnome-shell-vine-settings.patch)
225- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
226- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
227- create %%{name}-docs subpackage
228
229* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
230- new upstream release
231- remove Source102 (gnome-shell.gnome-3-6.ja.po)
232
233* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
234- new upstream release
235- add Source102 (gnome-shell.gnome-3-6.ja.po)
236
237* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
238- new upstream release
239- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
240
241* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
242- rebuild with telepathy-logger-0.6.0
243- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
244
245* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
246- new upstream release
247
248* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
249- new upstream release
250- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
251- update Patch101 (gnome-shell-vine-settings.patch)
252- change BuildRequires: ca-certificates instead of openssl
253- add BuildRequires: libcanberra-gtl3-devel
254
255* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
256- new upstream release
257- remove Patch103 (gnome-shell-ja.po-date.patch)
258
259* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
260- new upstream release
261- update Patch101,103
262- remove Patch0,102
263- add BuildRequires: gcr-devel
264- remove BuildRequires: GConf2-devel
265- add Requires: at-spi2-atk
266
267* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
268- new upstream release
269- remove Patch1
270
271* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
272- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
273- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
274- rename Patch103 (gnome-shell-ja.po-date.patch)
275- drop Patch102
276
277* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
278- new upstream release
279
280* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
281- new upstream release
282
283* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
284- new upstream release
285- update Patch101
286- update Patch102
287- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
288- add BuildRequires: libgudev1-devel, openssl
289
290* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
291- new upstream release
292- add BuildRequires: folks-devel, NetworkManager-glib-devel
293- add Requires: caribou
294- remove Patch0
295- update Patch101
296- update Patch102
297- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
298
299* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
300- rebuild with gnome-menus-3.1.5
301- add Patch0 (gnome-shell-git20110821.patch)
302
303* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
304- new upstream release
305- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
306- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
307- remove BuildRequires: xulrunner-devel
308- add Patch101 (gnome-shell-vine-settings.patch)
309- add Patch102 (gnome-shell-vine-customize.patch)
310- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
311
312* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
313- add Requires: mutter
314
315* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
316- new upstream release
317
318* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
319- initial build for Vine Linux
320
Note: See TracBrowser for help on using the repository browser.