source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9475

Revision 9475, 9.8 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define pkg_version 3.16.0
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.14.1.5-revert-loginManager.patch
14
15License:        GPLv2+
16Group:          User Interface/Desktops
17URL:            http://live.gnome.org/GnomeShell
18
19Requires: mutter
20Requires: caribou
21Requires: ca-certificates
22Requires: at-spi2-atk
23Requires: telepathy-logger
24Requires: network-manager-applet
25Requires: gnome-tweak-tool
26
27BuildRequires: gnome-common
28BuildRequires: libtool
29BuildRequires: automake
30BuildRequires: autoconf
31
32BuildRequires: pkgconfig
33BuildRequires: gtk2-devel
34BuildRequires: clutter-devel
35BuildRequires: mutter-devel
36BuildRequires: gjs-devel
37BuildRequires: gnome-desktop3-devel
38BuildRequires: gnome-menus-devel
39BuildRequires: libSM-devel
40BuildRequires: libffi-devel
41BuildRequires: startup-notification-devel
42BuildRequires: gnome-doc-utils
43BuildRequires: desktop-file-utils
44BuildRequires: libcroco-devel
45BuildRequires: librsvg2-devel
46BuildRequires: gobject-introspection-devel
47BuildRequires: control-center-devel
48BuildRequires: gcr-devel
49BuildRequires: gstreamer-devel
50BuildRequires: dbus-glib-devel
51BuildRequires: telepathy-logger-devel
52BuildRequires: polkit-devel
53BuildRequires: pulseaudio-libs-devel
54BuildRequires: evolution-data-server-devel
55BuildRequires: folks-devel
56BuildRequires: NetworkManager-glib-devel
57BuildRequires: libnm-gtk-devel
58BuildRequires: libgudev1-devel
59BuildRequires: libcanberra-gtk3-devel
60BuildRequires: caribou-devel
61BuildRequires: ca-certificates
62BuildRequires: python3-devel
63BuildRequires: intltool
64
65BuildRoot: %{_tmppath}/%{name}-%{version}-root
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: Takemikaduchi
70
71
72%description
73GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
74It provides core interface functions like switching to windows and launching
75applications. GNOME Shell takes advantage of the capabilities of modern graphics
76hardware and introduces innovative user interface concepts to provide a delightful
77and easy to use experience.
78
79
80%package        docs
81Summary:        Documentation for %{name}
82Summary(ja):    %{name} 用のドキュメント
83Group:          Documentation
84Requires:       %{name} = %{version}-%{release}
85BuildArch:              noarch
86
87%description    docs
88This package contains documentation for %{name}.
89
90
91
92%prep
93%setup -q
94%patch101 -p1 -b .vine
95%patch102 -p1 -b .vine
96
97%build
98%configure \
99        --disable-static \
100        --disable-systemd
101
102%{__make} %{?_smp_mflags} V=1
103
104
105%install
106%{__rm} -rf ${RPM_BUILD_ROOT}
107%{__make} install DESTDIR=${RPM_BUILD_ROOT}
108
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
110
111rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
112%find_lang %{name}
113
114
115
116%clean
117%{__rm} -rf ${RPM_BUILD_ROOT}
118
119
120%post
121/sbin/ldconfig
122touch --no-create %{_datadir}/icons/hicolor
123if [ -x /usr/bin/gtk-update-icon-cache ]; then
124  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
125fi
126
127%postun
128/sbin/ldconfig
129touch --no-create %{_datadir}/icons/hicolor
130if [ -x /usr/bin/gtk-update-icon-cache ]; then
131  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
132fi
133glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134
135%posttrans
136glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
137
138
139%files -f %{name}.lang
140%defattr(-,root,root,-)
141%doc COPYING NEWS README
142%{_bindir}/gnome-shell
143%{_bindir}/gnome-shell-extension-tool
144%{_bindir}/gnome-shell-extension-prefs
145%{_bindir}/gnome-shell-perf-tool
146%{_libdir}/%{name}/*
147%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
148%{_libexecdir}/gnome-shell-calendar-server
149%{_libexecdir}/gnome-shell-hotplug-sniffer
150%{_libexecdir}/gnome-shell-perf-helper
151%{_libexecdir}/gnome-shell-portal-helper
152%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
153%{_datadir}/applications/gnome-shell.desktop
154%{_datadir}/applications/gnome-shell-extension-prefs.desktop
155%{_datadir}/applications/evolution-calendar.desktop
156%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
157%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
159%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
160%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
161%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
162%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
163%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
164%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
165%{_datadir}/%{name}/*
166%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
167%{_mandir}/man1/%{name}.1.gz
168
169%files docs
170%defattr(-,root,root,-)
171%{_datadir}/gtk-doc/html/shell
172%{_datadir}/gtk-doc/html/st
173
174
175%changelog
176* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
177- new upstream release
178- add BuildRequires: python3-devel
179
180* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
181- rebuilt with libical 1.0.1
182
183* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
184- new upstream release
185
186* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
187- new upstream release
188
189* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
190- new upstream release
191- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
192- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
193
194* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
195- new upstream release
196
197* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
198- new upstream release
199
200* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
201- new upstream release
202
203* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
204- new upstream release
205
206* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
207- new upstream release
208
209* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
210- new upstream release
211
212* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
213- new upstream release
214
215* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
216- new upstream release
217
218* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
219- new upstream release
220
221* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
222- new upstream release
223- update Patch101 (gnome-shell-vine-settings.patch)
224- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
225- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
226- create %%{name}-docs subpackage
227
228* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
229- new upstream release
230- remove Source102 (gnome-shell.gnome-3-6.ja.po)
231
232* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
233- new upstream release
234- add Source102 (gnome-shell.gnome-3-6.ja.po)
235
236* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
237- new upstream release
238- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
239
240* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
241- rebuild with telepathy-logger-0.6.0
242- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
243
244* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
245- new upstream release
246
247* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
248- new upstream release
249- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
250- update Patch101 (gnome-shell-vine-settings.patch)
251- change BuildRequires: ca-certificates instead of openssl
252- add BuildRequires: libcanberra-gtl3-devel
253
254* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
255- new upstream release
256- remove Patch103 (gnome-shell-ja.po-date.patch)
257
258* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
259- new upstream release
260- update Patch101,103
261- remove Patch0,102
262- add BuildRequires: gcr-devel
263- remove BuildRequires: GConf2-devel
264- add Requires: at-spi2-atk
265
266* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
267- new upstream release
268- remove Patch1
269
270* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
271- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
272- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
273- rename Patch103 (gnome-shell-ja.po-date.patch)
274- drop Patch102
275
276* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
277- new upstream release
278
279* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
280- new upstream release
281
282* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
283- new upstream release
284- update Patch101
285- update Patch102
286- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
287- add BuildRequires: libgudev1-devel, openssl
288
289* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
290- new upstream release
291- add BuildRequires: folks-devel, NetworkManager-glib-devel
292- add Requires: caribou
293- remove Patch0
294- update Patch101
295- update Patch102
296- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
297
298* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
299- rebuild with gnome-menus-3.1.5
300- add Patch0 (gnome-shell-git20110821.patch)
301
302* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
303- new upstream release
304- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
305- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
306- remove BuildRequires: xulrunner-devel
307- add Patch101 (gnome-shell-vine-settings.patch)
308- add Patch102 (gnome-shell-vine-customize.patch)
309- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
310
311* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
312- add Requires: mutter
313
314* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
315- new upstream release
316
317* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
318- initial build for Vine Linux
319
Note: See TracBrowser for help on using the repository browser.