source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9376

Revision 9376, 9.6 KB checked in by inagaki, 9 years ago (diff)

2015-02-24 Ryoichi INAGAKI <ryo1@…>

  • evolution, evolution-data-server, gnokii, gnome-shell, kdepimlibs, kmymoney: rebuilt with libical
  • libical: updated


Line 
1%define pkg_version 3.14.3
2%define pkg_release 2%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.14.1.5-revert-loginManager.patch
14
15License:        GPLv2+
16Group:          User Interface/Desktops
17URL:            http://live.gnome.org/GnomeShell
18
19Requires: mutter
20Requires: caribou
21Requires: ca-certificates
22Requires: at-spi2-atk
23Requires: telepathy-logger
24Requires: network-manager-applet
25Requires: gnome-tweak-tool
26
27BuildRequires: gnome-common
28BuildRequires: libtool
29BuildRequires: automake
30BuildRequires: autoconf
31
32BuildRequires: pkgconfig
33BuildRequires: gtk2-devel
34BuildRequires: clutter-devel
35BuildRequires: mutter-devel
36BuildRequires: gjs-devel
37BuildRequires: gnome-desktop3-devel
38BuildRequires: gnome-menus-devel
39BuildRequires: libSM-devel
40BuildRequires: libffi-devel
41BuildRequires: startup-notification-devel
42BuildRequires: gnome-doc-utils
43BuildRequires: desktop-file-utils
44BuildRequires: libcroco-devel
45BuildRequires: librsvg2-devel
46BuildRequires: gobject-introspection-devel
47BuildRequires: control-center-devel
48BuildRequires: gcr-devel
49BuildRequires: gstreamer-devel
50BuildRequires: dbus-glib-devel
51BuildRequires: telepathy-logger-devel
52BuildRequires: polkit-devel
53BuildRequires: pulseaudio-libs-devel
54BuildRequires: evolution-data-server-devel
55BuildRequires: folks-devel
56BuildRequires: NetworkManager-glib-devel
57BuildRequires: libnm-gtk-devel
58BuildRequires: libgudev1-devel
59BuildRequires: libcanberra-gtk3-devel
60BuildRequires: caribou-devel
61BuildRequires: ca-certificates
62BuildRequires: intltool
63
64BuildRoot: %{_tmppath}/%{name}-%{version}-root
65
66Vendor: Project Vine
67Distribution: Vine Linux
68Packager: Takemikaduchi
69
70
71%description
72GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
73It provides core interface functions like switching to windows and launching
74applications. GNOME Shell takes advantage of the capabilities of modern graphics
75hardware and introduces innovative user interface concepts to provide a delightful
76and easy to use experience.
77
78
79%package        docs
80Summary:        Documentation for %{name}
81Summary(ja):    %{name} 用のドキュメント
82Group:          Documentation
83Requires:       %{name} = %{version}-%{release}
84BuildArch:              noarch
85
86%description    docs
87This package contains documentation for %{name}.
88
89
90
91%prep
92%setup -q
93%patch101 -p1 -b .vine
94%patch102 -p1 -b .vine
95
96%build
97%configure \
98        --disable-static \
99        --disable-systemd
100
101%{__make} %{?_smp_mflags} V=1
102
103
104%install
105%{__rm} -rf ${RPM_BUILD_ROOT}
106%{__make} install DESTDIR=${RPM_BUILD_ROOT}
107
108find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
109
110rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
111%find_lang %{name}
112
113
114
115%clean
116%{__rm} -rf ${RPM_BUILD_ROOT}
117
118
119%post
120/sbin/ldconfig
121touch --no-create %{_datadir}/icons/hicolor
122if [ -x /usr/bin/gtk-update-icon-cache ]; then
123  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
124fi
125
126%postun
127/sbin/ldconfig
128touch --no-create %{_datadir}/icons/hicolor
129if [ -x /usr/bin/gtk-update-icon-cache ]; then
130  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
131fi
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
133
134%posttrans
135glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
136
137
138%files -f %{name}.lang
139%defattr(-,root,root,-)
140%doc COPYING NEWS README
141%{_bindir}/gnome-shell
142%{_bindir}/gnome-shell-extension-tool
143%{_bindir}/gnome-shell-extension-prefs
144%{_bindir}/gnome-shell-perf-tool
145%{_libdir}/%{name}/*
146%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
147%{_libexecdir}/gnome-shell-calendar-server
148%{_libexecdir}/gnome-shell-hotplug-sniffer
149%{_libexecdir}/gnome-shell-perf-helper
150%{_libexecdir}/gnome-shell-portal-helper
151%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
152%{_datadir}/applications/gnome-shell.desktop
153%{_datadir}/applications/gnome-shell-extension-prefs.desktop
154%{_datadir}/applications/evolution-calendar.desktop
155%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
156%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
157%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
159%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
160%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
161%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
162%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
163%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
164%{_datadir}/%{name}/*
165%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
166%{_mandir}/man1/%{name}.1.gz
167
168%files docs
169%defattr(-,root,root,-)
170%{_datadir}/gtk-doc/html/shell
171%{_datadir}/gtk-doc/html/st
172
173
174%changelog
175* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
176- rebuilt with libical 1.0.1
177
178* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
179- new upstream release
180
181* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
182- new upstream release
183
184* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
185- new upstream release
186- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
187- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
188
189* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
190- new upstream release
191
192* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
193- new upstream release
194
195* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
196- new upstream release
197
198* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
199- new upstream release
200
201* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
202- new upstream release
203
204* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
205- new upstream release
206
207* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
208- new upstream release
209
210* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
211- new upstream release
212
213* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
214- new upstream release
215
216* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
217- new upstream release
218- update Patch101 (gnome-shell-vine-settings.patch)
219- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
220- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
221- create %%{name}-docs subpackage
222
223* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
224- new upstream release
225- remove Source102 (gnome-shell.gnome-3-6.ja.po)
226
227* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
228- new upstream release
229- add Source102 (gnome-shell.gnome-3-6.ja.po)
230
231* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
232- new upstream release
233- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
234
235* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
236- rebuild with telepathy-logger-0.6.0
237- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
238
239* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
240- new upstream release
241
242* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
243- new upstream release
244- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
245- update Patch101 (gnome-shell-vine-settings.patch)
246- change BuildRequires: ca-certificates instead of openssl
247- add BuildRequires: libcanberra-gtl3-devel
248
249* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
250- new upstream release
251- remove Patch103 (gnome-shell-ja.po-date.patch)
252
253* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
254- new upstream release
255- update Patch101,103
256- remove Patch0,102
257- add BuildRequires: gcr-devel
258- remove BuildRequires: GConf2-devel
259- add Requires: at-spi2-atk
260
261* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
262- new upstream release
263- remove Patch1
264
265* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
266- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
267- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
268- rename Patch103 (gnome-shell-ja.po-date.patch)
269- drop Patch102
270
271* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
272- new upstream release
273
274* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
275- new upstream release
276
277* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
278- new upstream release
279- update Patch101
280- update Patch102
281- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
282- add BuildRequires: libgudev1-devel, openssl
283
284* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
285- new upstream release
286- add BuildRequires: folks-devel, NetworkManager-glib-devel
287- add Requires: caribou
288- remove Patch0
289- update Patch101
290- update Patch102
291- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
292
293* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
294- rebuild with gnome-menus-3.1.5
295- add Patch0 (gnome-shell-git20110821.patch)
296
297* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
298- new upstream release
299- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
300- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
301- remove BuildRequires: xulrunner-devel
302- add Patch101 (gnome-shell-vine-settings.patch)
303- add Patch102 (gnome-shell-vine-customize.patch)
304- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
305
306* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
307- add Requires: mutter
308
309* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
310- new upstream release
311
312* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
313- initial build for Vine Linux
314
Note: See TracBrowser for help on using the repository browser.