source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 8011

Revision 8011, 8.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define pkg_version 3.10.2.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-vine-settings.patch
12
13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
16
17Requires: mutter
18Requires: caribou
19Requires: ca-certificates
20Requires: at-spi2-atk
21Requires: telepathy-logger
22Requires: network-manager-applet
23Requires: gnome-tweak-tool
24
25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
35BuildRequires: gnome-desktop3-devel
36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
45BuildRequires: control-center-devel
46BuildRequires: gcr-devel
47BuildRequires: gstreamer-devel
48BuildRequires: dbus-glib-devel
49BuildRequires: telepathy-logger-devel
50BuildRequires: polkit-devel
51BuildRequires: pulseaudio-libs-devel
52BuildRequires: evolution-data-server-devel
53BuildRequires: folks-devel
54BuildRequires: NetworkManager-glib-devel
55BuildRequires: libnm-gtk-devel
56BuildRequires: libgudev1-devel
57BuildRequires: libcanberra-gtk3-devel
58BuildRequires: caribou-devel
59BuildRequires: ca-certificates
60BuildRequires: intltool
61
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: Takemikaduchi
67
68
69%description
70GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
71It provides core interface functions like switching to windows and launching
72applications. GNOME Shell takes advantage of the capabilities of modern graphics
73hardware and introduces innovative user interface concepts to provide a delightful
74and easy to use experience.
75
76
77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:              noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88
89%prep
90%setup -q
91%patch101 -p1 -b .vine
92
93%build
94autoreconf -if
95%configure \
96        --disable-static
97
98%{__make} %{?_smp_mflags}
99
100
101%install
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%{__make} install DESTDIR=${RPM_BUILD_ROOT}
104
105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
106
107%find_lang %{name}
108
109
110
111%clean
112%{__rm} -rf ${RPM_BUILD_ROOT}
113
114
115%post
116/sbin/ldconfig
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121
122%postun
123/sbin/ldconfig
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x /usr/bin/gtk-update-icon-cache ]; then
126  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
127fi
128glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
129
130%posttrans
131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
132
133
134%files -f %{name}.lang
135%defattr(-,root,root,-)
136%doc COPYING NEWS README
137%{_bindir}/gnome-shell
138%{_bindir}/gnome-shell-extension-tool
139%{_bindir}/gnome-shell-extension-prefs
140%{_bindir}/gnome-shell-perf-tool
141%{_libdir}/%{name}/*
142%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
143%{_libexecdir}/gnome-shell-calendar-server
144%{_libexecdir}/gnome-shell-hotplug-sniffer
145%{_libexecdir}/gnome-shell-perf-helper
146%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
147%{_datadir}/applications/gnome-shell.desktop
148%{_datadir}/applications/gnome-shell-extension-prefs.desktop
149%{_datadir}/applications/evolution-calendar.desktop
150%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
151%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
152%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
153%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
154%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
155%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
156%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
157%{_datadir}/%{name}/*
158%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
159%{_mandir}/man1/%{name}.1.gz
160
161%files docs
162%defattr(-,root,root,-)
163%{_datadir}/gtk-doc/html/shell
164%{_datadir}/gtk-doc/html/st
165
166
167%changelog
168* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
169- new upstream release
170
171* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
172- new upstream release
173
174* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
175- new upstream release
176
177* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
178- new upstream release
179
180* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
181- new upstream release
182
183* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
184- new upstream release
185- update Patch101 (gnome-shell-vine-settings.patch)
186- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
187- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
188- create %%{name}-docs subpackage
189
190* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
191- new upstream release
192- remove Source102 (gnome-shell.gnome-3-6.ja.po)
193
194* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
195- new upstream release
196- add Source102 (gnome-shell.gnome-3-6.ja.po)
197
198* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
199- new upstream release
200- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
201
202* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
203- rebuild with telepathy-logger-0.6.0
204- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
205
206* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
207- new upstream release
208
209* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
210- new upstream release
211- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
212- update Patch101 (gnome-shell-vine-settings.patch)
213- change BuildRequires: ca-certificates instead of openssl
214- add BuildRequires: libcanberra-gtl3-devel
215
216* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
217- new upstream release
218- remove Patch103 (gnome-shell-ja.po-date.patch)
219
220* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
221- new upstream release
222- update Patch101,103
223- remove Patch0,102
224- add BuildRequires: gcr-devel
225- remove BuildRequires: GConf2-devel
226- add Requires: at-spi2-atk
227
228* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
229- new upstream release
230- remove Patch1
231
232* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
233- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
234- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
235- rename Patch103 (gnome-shell-ja.po-date.patch)
236- drop Patch102
237
238* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
239- new upstream release
240
241* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
242- new upstream release
243
244* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
245- new upstream release
246- update Patch101
247- update Patch102
248- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
249- add BuildRequires: libgudev1-devel, openssl
250
251* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
252- new upstream release
253- add BuildRequires: folks-devel, NetworkManager-glib-devel
254- add Requires: caribou
255- remove Patch0
256- update Patch101
257- update Patch102
258- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
259
260* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
261- rebuild with gnome-menus-3.1.5
262- add Patch0 (gnome-shell-git20110821.patch)
263
264* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
265- new upstream release
266- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
267- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
268- remove BuildRequires: xulrunner-devel
269- add Patch101 (gnome-shell-vine-settings.patch)
270- add Patch102 (gnome-shell-vine-customize.patch)
271- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
272
273* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
274- add Requires: mutter
275
276* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
277- new upstream release
278
279* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
280- initial build for Vine Linux
281
Note: See TracBrowser for help on using the repository browser.