source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 7938

Revision 7938, 8.3 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define pkg_version 3.10.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-vine-settings.patch
12
13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
16
17Requires: mutter
18Requires: caribou
19Requires: ca-certificates
20Requires: at-spi2-atk
21Requires: telepathy-logger
22Requires: network-manager-applet
23Requires: gnome-tweak-tool
24
25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
35BuildRequires: gnome-desktop3-devel
36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
45BuildRequires: control-center-devel
46BuildRequires: gcr-devel
47BuildRequires: gstreamer-devel
48BuildRequires: dbus-glib-devel
49BuildRequires: telepathy-logger-devel
50BuildRequires: polkit-devel
51BuildRequires: pulseaudio-libs-devel
52BuildRequires: evolution-data-server-devel
53BuildRequires: folks-devel
54BuildRequires: NetworkManager-glib-devel
55BuildRequires: libnm-gtk-devel
56BuildRequires: libgudev1-devel
57BuildRequires: libcanberra-gtk3-devel
58BuildRequires: caribou-devel
59BuildRequires: ca-certificates
60BuildRequires: intltool
61
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: Takemikaduchi
67
68
69%description
70GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
71It provides core interface functions like switching to windows and launching
72applications. GNOME Shell takes advantage of the capabilities of modern graphics
73hardware and introduces innovative user interface concepts to provide a delightful
74and easy to use experience.
75
76
77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:              noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88
89%prep
90%setup -q
91%patch101 -p1 -b .vine
92
93%build
94autoreconf -if
95%configure \
96        --disable-static
97
98%{__make} %{?_smp_mflags}
99
100
101%install
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%{__make} install DESTDIR=${RPM_BUILD_ROOT}
104
105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
106
107%find_lang %{name}
108
109
110
111%clean
112%{__rm} -rf ${RPM_BUILD_ROOT}
113
114
115%post
116/sbin/ldconfig
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121
122%postun
123/sbin/ldconfig
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x /usr/bin/gtk-update-icon-cache ]; then
126  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
127fi
128glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
129
130%posttrans
131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
132
133
134%files -f %{name}.lang
135%defattr(-,root,root,-)
136%doc COPYING NEWS README
137%{_bindir}/gnome-shell
138%{_bindir}/gnome-shell-extension-tool
139%{_bindir}/gnome-shell-extension-prefs
140%{_bindir}/gnome-shell-perf-tool
141%{_libdir}/%{name}/*
142%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
143%{_libexecdir}/gnome-shell-calendar-server
144%{_libexecdir}/gnome-shell-hotplug-sniffer
145%{_libexecdir}/gnome-shell-perf-helper
146%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
147%{_datadir}/applications/gnome-shell.desktop
148%{_datadir}/applications/gnome-shell-extension-prefs.desktop
149%{_datadir}/applications/evolution-calendar.desktop
150%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
151%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
152%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
153%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
154%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
155%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
156%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
157%{_datadir}/%{name}/*
158%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
159%{_mandir}/man1/%{name}.1.gz
160
161%files docs
162%defattr(-,root,root,-)
163%{_datadir}/gtk-doc/html/shell
164%{_datadir}/gtk-doc/html/st
165
166
167%changelog
168* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
169- new upstream release
170
171* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
172- new upstream release
173
174* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
175- new upstream release
176
177* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
178- new upstream release
179
180* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
181- new upstream release
182- update Patch101 (gnome-shell-vine-settings.patch)
183- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
184- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
185- create %%{name}-docs subpackage
186
187* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
188- new upstream release
189- remove Source102 (gnome-shell.gnome-3-6.ja.po)
190
191* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
192- new upstream release
193- add Source102 (gnome-shell.gnome-3-6.ja.po)
194
195* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
196- new upstream release
197- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
198
199* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
200- rebuild with telepathy-logger-0.6.0
201- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
202
203* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
204- new upstream release
205
206* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
207- new upstream release
208- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
209- update Patch101 (gnome-shell-vine-settings.patch)
210- change BuildRequires: ca-certificates instead of openssl
211- add BuildRequires: libcanberra-gtl3-devel
212
213* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
214- new upstream release
215- remove Patch103 (gnome-shell-ja.po-date.patch)
216
217* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
218- new upstream release
219- update Patch101,103
220- remove Patch0,102
221- add BuildRequires: gcr-devel
222- remove BuildRequires: GConf2-devel
223- add Requires: at-spi2-atk
224
225* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
226- new upstream release
227- remove Patch1
228
229* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
230- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
231- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
232- rename Patch103 (gnome-shell-ja.po-date.patch)
233- drop Patch102
234
235* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
236- new upstream release
237
238* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
239- new upstream release
240
241* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
242- new upstream release
243- update Patch101
244- update Patch102
245- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
246- add BuildRequires: libgudev1-devel, openssl
247
248* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
249- new upstream release
250- add BuildRequires: folks-devel, NetworkManager-glib-devel
251- add Requires: caribou
252- remove Patch0
253- update Patch101
254- update Patch102
255- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
256
257* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
258- rebuild with gnome-menus-3.1.5
259- add Patch0 (gnome-shell-git20110821.patch)
260
261* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
262- new upstream release
263- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
264- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
265- remove BuildRequires: xulrunner-devel
266- add Patch101 (gnome-shell-vine-settings.patch)
267- add Patch102 (gnome-shell-vine-customize.patch)
268- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
269
270* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
271- add Requires: mutter
272
273* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
274- new upstream release
275
276* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
277- initial build for Vine Linux
278
Note: See TracBrowser for help on using the repository browser.