source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 7633

Revision 7633, 8.0 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define pkg_version 3.8.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-vine-settings.patch
12
13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
16
17Requires(post,postun): scrollkeeper >= 0.1.4
18Requires: mutter
19Requires: caribou
20Requires: ca-certificates
21Requires: at-spi2-atk
22Requires: telepathy-logger
23Requires: network-manager-applet
24Requires: gnome-tweak-tool
25
26BuildRequires: gnome-common
27BuildRequires: libtool
28BuildRequires: automake
29BuildRequires: autoconf
30
31BuildRequires: pkgconfig
32BuildRequires: gtk2-devel
33BuildRequires: clutter-devel
34BuildRequires: mutter-devel
35BuildRequires: gjs-devel
36BuildRequires: gnome-desktop3-devel
37BuildRequires: gnome-menus-devel
38BuildRequires: libSM-devel
39BuildRequires: libffi-devel
40BuildRequires: startup-notification-devel
41BuildRequires: gnome-doc-utils
42BuildRequires: desktop-file-utils
43BuildRequires: libcroco-devel
44BuildRequires: librsvg2-devel
45BuildRequires: gobject-introspection-devel
46BuildRequires: control-center-devel
47BuildRequires: gcr-devel
48BuildRequires: gstreamer-devel
49BuildRequires: dbus-glib-devel
50BuildRequires: telepathy-logger-devel
51BuildRequires: polkit-devel
52BuildRequires: pulseaudio-libs-devel
53BuildRequires: evolution-data-server-devel
54BuildRequires: folks-devel
55BuildRequires: NetworkManager-glib-devel
56BuildRequires: libnm-gtk-devel
57BuildRequires: libgudev1-devel
58BuildRequires: libcanberra-gtk3-devel
59BuildRequires: caribou-devel
60BuildRequires: ca-certificates
61BuildRequires: intltool
62
63BuildRoot: %{_tmppath}/%{name}-%{version}-root
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: Takemikaduchi
68
69
70%description
71GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
72It provides core interface functions like switching to windows and launching
73applications. GNOME Shell takes advantage of the capabilities of modern graphics
74hardware and introduces innovative user interface concepts to provide a delightful
75and easy to use experience.
76
77
78%package        docs
79Summary:        Documentation for %{name}
80Summary(ja):    %{name} 用のドキュメント
81Group:          Documentation
82Requires:       %{name} = %{version}-%{release}
83BuildArch:              noarch
84
85%description    docs
86This package contains documentation for %{name}.
87
88
89
90%prep
91%setup -q
92%patch101 -p1 -b .vine
93
94%build
95libtoolize --copy --force
96autoreconf
97%configure \
98        --disable-static
99
100%{__make} %{?_smp_mflags}
101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105%{__make} install DESTDIR=${RPM_BUILD_ROOT}
106
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
108
109%find_lang %{name}
110
111
112
113%clean
114%{__rm} -rf ${RPM_BUILD_ROOT}
115
116
117%post
118/sbin/ldconfig
119touch --no-create %{_datadir}/icons/hicolor
120if [ -x /usr/bin/gtk-update-icon-cache ]; then
121  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
122fi
123
124%postun
125/sbin/ldconfig
126touch --no-create %{_datadir}/icons/hicolor
127if [ -x /usr/bin/gtk-update-icon-cache ]; then
128  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
129fi
130glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
131
132%posttrans
133glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134
135
136%files -f %{name}.lang
137%defattr(-,root,root,-)
138%doc COPYING NEWS README
139%{_bindir}/gnome-shell
140%{_bindir}/gnome-shell-extension-tool
141%{_bindir}/gnome-shell-extension-prefs
142%{_bindir}/gnome-shell-perf-tool
143%{_libdir}/%{name}/*
144%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
145%{_libexecdir}/gnome-shell-calendar-server
146%{_libexecdir}/gnome-shell-hotplug-sniffer
147%{_libexecdir}/gnome-shell-perf-helper
148%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
149%{_datadir}/applications/gnome-shell.desktop
150%{_datadir}/applications/gnome-shell-extension-prefs.desktop
151%{_datadir}/applications/evolution-calendar.desktop
152%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
153%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
154%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
155%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
156%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
157%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
158%{_datadir}/%{name}/*
159%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-screenshot.xml
160%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
161%{_mandir}/man1/%{name}.1.gz
162
163%files docs
164%defattr(-,root,root,-)
165%{_datadir}/gtk-doc/html/shell
166%{_datadir}/gtk-doc/html/st
167
168
169%changelog
170* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
171- new upstream release
172- update Patch101 (gnome-shell-vine-settings.patch)
173- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
174- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
175- create %%{name}-docs subpackage
176
177* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
178- new upstream release
179- remove Source102 (gnome-shell.gnome-3-6.ja.po)
180
181* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
182- new upstream release
183- add Source102 (gnome-shell.gnome-3-6.ja.po)
184
185* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
186- new upstream release
187- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
188
189* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
190- rebuild with telepathy-logger-0.6.0
191- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
192
193* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
194- new upstream release
195
196* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
197- new upstream release
198- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
199- update Patch101 (gnome-shell-vine-settings.patch)
200- change BuildRequires: ca-certificates instead of openssl
201- add BuildRequires: libcanberra-gtl3-devel
202
203* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
204- new upstream release
205- remove Patch103 (gnome-shell-ja.po-date.patch)
206
207* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
208- new upstream release
209- update Patch101,103
210- remove Patch0,102
211- add BuildRequires: gcr-devel
212- remove BuildRequires: GConf2-devel
213- add Requires: at-spi2-atk
214
215* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
216- new upstream release
217- remove Patch1
218
219* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
220- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
221- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
222- rename Patch103 (gnome-shell-ja.po-date.patch)
223- drop Patch102
224
225* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
226- new upstream release
227
228* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
229- new upstream release
230
231* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
232- new upstream release
233- update Patch101
234- update Patch102
235- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
236- add BuildRequires: libgudev1-devel, openssl
237
238* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
239- new upstream release
240- add BuildRequires: folks-devel, NetworkManager-glib-devel
241- add Requires: caribou
242- remove Patch0
243- update Patch101
244- update Patch102
245- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
246
247* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
248- rebuild with gnome-menus-3.1.5
249- add Patch0 (gnome-shell-git20110821.patch)
250
251* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
252- new upstream release
253- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
254- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
255- remove BuildRequires: xulrunner-devel
256- add Patch101 (gnome-shell-vine-settings.patch)
257- add Patch102 (gnome-shell-vine-customize.patch)
258- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
259
260* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
261- add Requires: mutter
262
263* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
264- new upstream release
265
266* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
267- initial build for Vine Linux
268
Note: See TracBrowser for help on using the repository browser.