source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 7516

Revision 7516, 6.9 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define pkg_version 3.6.3.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-vine-settings.patch
12
13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
16
17Requires(post,postun): scrollkeeper >= 0.1.4
18Requires: mutter
19Requires: caribou
20Requires: ca-certificates
21Requires: at-spi2-atk
22
23BuildRequires: gnome-common
24BuildRequires: libtool
25BuildRequires: automake
26BuildRequires: autoconf
27
28BuildRequires: pkgconfig
29BuildRequires: gtk2-devel
30BuildRequires: clutter-devel
31BuildRequires: mutter-devel
32BuildRequires: gjs-devel
33BuildRequires: gnome-desktop3-devel
34BuildRequires: gnome-menus-devel
35BuildRequires: libSM-devel
36BuildRequires: libffi-devel
37BuildRequires: startup-notification-devel
38BuildRequires: gnome-doc-utils
39BuildRequires: desktop-file-utils
40BuildRequires: libcroco-devel
41BuildRequires: librsvg2-devel
42BuildRequires: gobject-introspection-devel
43BuildRequires: gcr-devel
44BuildRequires: gstreamer-devel
45BuildRequires: dbus-glib-devel
46BuildRequires: telepathy-logger-devel
47BuildRequires: polkit-devel
48BuildRequires: pulseaudio-libs-devel
49BuildRequires: evolution-data-server-devel
50BuildRequires: folks-devel
51BuildRequires: NetworkManager-glib-devel
52BuildRequires: libgudev1-devel
53BuildRequires: libcanberra-gtk3-devel
54BuildRequires: ca-certificates
55BuildRequires: intltool
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: Takemikaduchi
62
63
64%description
65GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
66It provides core interface functions like switching to windows and launching
67applications. GNOME Shell takes advantage of the capabilities of modern graphics
68hardware and introduces innovative user interface concepts to provide a delightful
69and easy to use experience.
70
71
72%prep
73%setup -q
74%patch101 -p1 -b .vine
75
76%build
77libtoolize --copy --force
78autoreconf
79%configure \
80        --disable-static
81
82%{__make} %{?_smp_mflags}
83
84
85%install
86%{__rm} -rf ${RPM_BUILD_ROOT}
87%{__make} install DESTDIR=${RPM_BUILD_ROOT}
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
90
91%find_lang %{name}
92
93
94
95%clean
96%{__rm} -rf ${RPM_BUILD_ROOT}
97
98
99%post
100/sbin/ldconfig
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
104fi
105
106%postun
107/sbin/ldconfig
108touch --no-create %{_datadir}/icons/hicolor
109if [ -x /usr/bin/gtk-update-icon-cache ]; then
110  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
111fi
112glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
113
114%posttrans
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117
118%files -f %{name}.lang
119%defattr(-,root,root)
120%doc COPYING NEWS README
121%{_bindir}/gnome-shell
122%{_bindir}/gnome-shell-extension-tool
123%{_bindir}/gnome-shell-extension-prefs
124%{_bindir}/gnome-shell-perf-tool
125%{_libdir}/gnome-shell/*
126%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
127%{_libexecdir}/gnome-shell-calendar-server
128%{_libexecdir}/gnome-shell-hotplug-sniffer
129%{_libexecdir}/gnome-shell-perf-helper
130%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
131%{_datadir}/applications/gnome-shell.desktop
132%{_datadir}/applications/gnome-shell-extension-prefs.desktop
133%{_datadir}/applications/evolution-calendar.desktop
134%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
135%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
136%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
137%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
138%{_datadir}/gnome-shell/*
139%{_datadir}/gtk-doc/html/shell
140%{_datadir}/gtk-doc/html/st
141%{_datadir}/man/man1/*.1.gz
142
143
144%changelog
145* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
146- new upstream release
147- remove Source102 (gnome-shell.gnome-3-6.ja.po)
148
149* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
150- new upstream release
151- add Source102 (gnome-shell.gnome-3-6.ja.po)
152
153* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
154- new upstream release
155- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
156
157* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
158- rebuild with telepathy-logger-0.6.0
159- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
160
161* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
162- new upstream release
163
164* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
165- new upstream release
166- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
167- update Patch101 (gnome-shell-vine-settings.patch)
168- change BuildRequires: ca-certificates instead of openssl
169- add BuildRequires: libcanberra-gtl3-devel
170
171* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
172- new upstream release
173- remove Patch103 (gnome-shell-ja.po-date.patch)
174
175* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
176- new upstream release
177- update Patch101,103
178- remove Patch0,102
179- add BuildRequires: gcr-devel
180- remove BuildRequires: GConf2-devel
181- add Requires: at-spi2-atk
182
183* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
184- new upstream release
185- remove Patch1
186
187* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
188- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
189- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
190- rename Patch103 (gnome-shell-ja.po-date.patch)
191- drop Patch102
192
193* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
194- new upstream release
195
196* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
197- new upstream release
198
199* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
200- new upstream release
201- update Patch101
202- update Patch102
203- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
204- add BuildRequires: libgudev1-devel, openssl
205
206* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
207- new upstream release
208- add BuildRequires: folks-devel, NetworkManager-glib-devel
209- add Requires: caribou
210- remove Patch0
211- update Patch101
212- update Patch102
213- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
214
215* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
216- rebuild with gnome-menus-3.1.5
217- add Patch0 (gnome-shell-git20110821.patch)
218
219* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
220- new upstream release
221- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
222- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
223- remove BuildRequires: xulrunner-devel
224- add Patch101 (gnome-shell-vine-settings.patch)
225- add Patch102 (gnome-shell-vine-customize.patch)
226- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
227
228* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
229- add Requires: mutter
230
231* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
232- new upstream release
233
234* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
235- initial build for Vine Linux
236
Note: See TracBrowser for help on using the repository browser.