source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 5448

Revision 5448, 6.2 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkg_version 3.2.2.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.xz
9
10Patch0:      gnome-shell-3.2.1-shell_parse_argv.patch
11
12# settings for Vine
13Patch101:    gnome-shell-vine-settings.patch
14Patch102:    gnome-shell-vine-customize.patch
15Patch103:    gnome-shell-ja.po-date.patch
16
17License:     GPLv2+
18Group:       User Interface/Desktops
19URL:         http://live.gnome.org/GnomeShell
20
21Requires(post,postun): scrollkeeper >= 0.1.4
22Requires(post,pre,preun): GConf2 >= 2.14
23Requires: mutter
24Requires: caribou
25Requires: openssl
26
27BuildRequires: gnome-common
28BuildRequires: libtool
29BuildRequires: automake
30BuildRequires: autoconf
31
32BuildRequires: pkgconfig
33BuildRequires: gtk2-devel
34BuildRequires: clutter-devel
35BuildRequires: mutter-devel
36BuildRequires: gjs-devel
37BuildRequires: gnome-desktop3-devel
38BuildRequires: gnome-menus-devel
39BuildRequires: libSM-devel
40BuildRequires: libffi-devel
41BuildRequires: GConf2-devel
42BuildRequires: startup-notification-devel
43BuildRequires: gnome-doc-utils
44BuildRequires: desktop-file-utils
45BuildRequires: libcroco-devel
46BuildRequires: librsvg2-devel
47BuildRequires: gobject-introspection-devel
48BuildRequires: gstreamer-devel
49BuildRequires: dbus-glib-devel
50BuildRequires: telepathy-logger-devel
51BuildRequires: polkit-devel
52BuildRequires: pulseaudio-libs-devel
53BuildRequires: evolution-data-server-devel
54BuildRequires: folks-devel
55BuildRequires: NetworkManager-glib-devel
56BuildRequires: libgudev1-devel
57BuildRequires: openssl
58BuildRequires: intltool
59
60BuildRoot: %{_tmppath}/%{name}-%{version}-root
61
62Vendor: Project Vine
63Distribution: Vine Linux
64Packager: Takemikaduchi
65
66
67%description
68GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
69It provides core interface functions like switching to windows and launching
70applications. GNOME Shell takes advantage of the capabilities of modern graphics
71hardware and introduces innovative user interface concepts to provide a delightful
72and easy to use experience.
73
74
75%prep
76%setup -q
77%patch0 -p1 -b .spawn
78%patch101 -p1 -b .vine
79#%patch102 -p1 -b .vine
80%patch103 -p1 -b .old_po2
81
82%build
83libtoolize --copy --force
84autoreconf
85%configure \
86        --disable-static \
87        --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
88
89%{__make} %{?_smp_mflags}
90
91
92%install
93%{__rm} -rf ${RPM_BUILD_ROOT}
94%{__make} install DESTDIR=${RPM_BUILD_ROOT}
95
96find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
97
98%find_lang %{name}
99
100
101
102%clean
103%{__rm} -rf ${RPM_BUILD_ROOT}
104
105
106%post
107/sbin/ldconfig
108export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109gconftool-2 --makefile-install-rule \
110    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
111    > /dev/null || :
112touch --no-create %{_datadir}/icons/hicolor
113if [ -x /usr/bin/gtk-update-icon-cache ]; then
114  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
115fi
116
117%pre
118if [ "$1" -gt 1 ]; then
119  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
120  gconftool-2 --makefile-uninstall-rule \
121    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
122    > /dev/null || :
123fi
124
125%preun
126if [ "$1" -eq 0 ]; then
127  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
128  gconftool-2 --makefile-uninstall-rule \
129    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
130    > /dev/null || :
131fi
132
133%postun
134scrollkeeper-update -q || :
135/sbin/ldconfig
136touch --no-create %{_datadir}/icons/hicolor
137if [ -x /usr/bin/gtk-update-icon-cache ]; then
138  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
139fi
140glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
141
142%posttrans
143glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
144
145
146%files -f %{name}.lang
147%defattr(-,root,root)
148%doc COPYING NEWS README
149%{_sysconfdir}/gconf/schemas/gnome-shell.schemas
150%{_bindir}/gnome-shell
151%{_bindir}/gnome-shell-extension-tool
152%{_libdir}/gnome-shell/*
153%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
154%{_libexecdir}/gnome-shell-calendar-server
155%{_libexecdir}/gnome-shell-hotplug-sniffer
156%{_libexecdir}/gnome-shell-perf-helper
157%{_datadir}/applications/gnome-shell.desktop
158%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
159%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
160%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
161%{_datadir}/gnome-shell/*
162%{_datadir}/man/man1/*.1.gz
163
164
165%changelog
166* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
167- new upstream release
168- remove Patch1
169
170* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
171- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
172- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
173- rename Patch103 (gnome-shell-ja.po-date.patch)
174- drop Patch102
175
176* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
177- new upstream release
178
179* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
180- new upstream release
181
182* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
183- new upstream release
184- update Patch101
185- update Patch102
186- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
187- add BuildRequires: libgudev1-devel, openssl
188
189* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
190- new upstream release
191- add BuildRequires: folks-devel, NetworkManager-glib-devel
192- add Requires: caribou
193- remove Patch0
194- update Patch101
195- update Patch102
196- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
197
198* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
199- rebuild with gnome-menus-3.1.5
200- add Patch0 (gnome-shell-git20110821.patch)
201
202* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
203- new upstream release
204- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
205- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
206- remove BuildRequires: xulrunner-devel
207- add Patch101 (gnome-shell-vine-settings.patch)
208- add Patch102 (gnome-shell-vine-customize.patch)
209- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
210
211* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
212- add Requires: mutter
213
214* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
215- new upstream release
216
217* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
218- initial build for Vine Linux
219
Note: See TracBrowser for help on using the repository browser.