source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 5206

Revision 5206, 6.1 KB checked in by Takemikaduchi, 13 years ago (diff)

fix bug

Line 
1%define pkg_version 3.2.1
2%define pkg_release 2%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.xz
9
10Patch0:      gnome-shell-3.2.1-shell_parse_argv.patch
11Patch1:      gnome-shell-3.2.1-ja.po.patch
12
13# settings for Vine
14Patch101:    gnome-shell-vine-settings.patch
15Patch102:    gnome-shell-vine-customize.patch
16Patch103:    gnome-shell-ja.po-date.patch
17
18License:     GPLv2+
19Group:       User Interface/Desktops
20URL:         http://live.gnome.org/GnomeShell
21
22Requires(post,postun): scrollkeeper >= 0.1.4
23Requires(post,pre,preun): GConf2 >= 2.14
24Requires: mutter
25Requires: caribou
26Requires: openssl
27
28BuildRequires: gnome-common
29BuildRequires: libtool
30BuildRequires: automake
31BuildRequires: autoconf
32
33BuildRequires: pkgconfig
34BuildRequires: gtk2-devel
35BuildRequires: clutter-devel
36BuildRequires: mutter-devel
37BuildRequires: gjs-devel
38BuildRequires: gnome-desktop3-devel
39BuildRequires: gnome-menus-devel
40BuildRequires: libSM-devel
41BuildRequires: libffi-devel
42BuildRequires: GConf2-devel
43BuildRequires: startup-notification-devel
44BuildRequires: gnome-doc-utils
45BuildRequires: desktop-file-utils
46BuildRequires: libcroco-devel
47BuildRequires: librsvg2-devel
48BuildRequires: gobject-introspection-devel
49BuildRequires: gstreamer-devel
50BuildRequires: dbus-glib-devel
51BuildRequires: telepathy-logger-devel
52BuildRequires: polkit-devel
53BuildRequires: pulseaudio-libs-devel
54BuildRequires: evolution-data-server-devel
55BuildRequires: folks-devel
56BuildRequires: NetworkManager-glib-devel
57BuildRequires: libgudev1-devel
58BuildRequires: openssl
59BuildRequires: intltool
60
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: Takemikaduchi
66
67
68%description
69GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
70It provides core interface functions like switching to windows and launching
71applications. GNOME Shell takes advantage of the capabilities of modern graphics
72hardware and introduces innovative user interface concepts to provide a delightful
73and easy to use experience.
74
75
76%prep
77%setup -q
78%patch0 -p1 -b .spawn
79%patch1 -p1 -b .old_po1
80%patch101 -p1 -b .vine
81#%patch102 -p1 -b .vine
82%patch103 -p1 -b .old_po2
83
84%build
85libtoolize --copy --force
86autoreconf
87%configure \
88        --disable-static \
89        --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
90
91%{__make} %{?_smp_mflags}
92
93
94%install
95%{__rm} -rf ${RPM_BUILD_ROOT}
96%{__make} install DESTDIR=${RPM_BUILD_ROOT}
97
98find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
99
100%find_lang %{name}
101
102
103
104%clean
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107
108%post
109/sbin/ldconfig
110export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111gconftool-2 --makefile-install-rule \
112    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
113    > /dev/null || :
114touch --no-create %{_datadir}/icons/hicolor
115if [ -x /usr/bin/gtk-update-icon-cache ]; then
116  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
117fi
118
119%pre
120if [ "$1" -gt 1 ]; then
121  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
122  gconftool-2 --makefile-uninstall-rule \
123    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
124    > /dev/null || :
125fi
126
127%preun
128if [ "$1" -eq 0 ]; then
129  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
130  gconftool-2 --makefile-uninstall-rule \
131    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
132    > /dev/null || :
133fi
134
135%postun
136scrollkeeper-update -q || :
137/sbin/ldconfig
138touch --no-create %{_datadir}/icons/hicolor
139if [ -x /usr/bin/gtk-update-icon-cache ]; then
140  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
141fi
142glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
143
144%posttrans
145glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
146
147
148%files -f %{name}.lang
149%defattr(-,root,root)
150%doc COPYING NEWS README
151%{_sysconfdir}/gconf/schemas/gnome-shell.schemas
152%{_bindir}/gnome-shell
153%{_bindir}/gnome-shell-extension-tool
154%{_libdir}/gnome-shell/*
155%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
156%{_libexecdir}/gnome-shell-calendar-server
157%{_libexecdir}/gnome-shell-hotplug-sniffer
158%{_libexecdir}/gnome-shell-perf-helper
159%{_datadir}/applications/gnome-shell.desktop
160%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
161%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
162%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
163%{_datadir}/gnome-shell/*
164%{_datadir}/man/man1/*.1.gz
165
166
167%changelog
168* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
169- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
170- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
171- rename Patch103 (gnome-shell-ja.po-date.patch)
172- drop Patch102
173
174* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
175- new upstream release
176
177* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
178- new upstream release
179
180* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
181- new upstream release
182- update Patch101
183- update Patch102
184- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
185- add BuildRequires: libgudev1-devel, openssl
186
187* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
188- new upstream release
189- add BuildRequires: folks-devel, NetworkManager-glib-devel
190- add Requires: caribou
191- remove Patch0
192- update Patch101
193- update Patch102
194- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
195
196* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
197- rebuild with gnome-menus-3.1.5
198- add Patch0 (gnome-shell-git20110821.patch)
199
200* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
201- new upstream release
202- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
203- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
204- remove BuildRequires: xulrunner-devel
205- add Patch101 (gnome-shell-vine-settings.patch)
206- add Patch102 (gnome-shell-vine-customize.patch)
207- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
208
209* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
210- add Requires: mutter
211
212* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
213- new upstream release
214
215* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
216- initial build for Vine Linux
217
Note: See TracBrowser for help on using the repository browser.