source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 12468

Revision 12468, 11.0 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

gnome-session-3.36.0-2

gnome-shell-3.36.5-1

gnome-software-3.36.1-2

gtk3-3.24.22-1

Line 
1%bcond_with systemd
2
3Summary:        Window management and application launching for GNOME
4Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
5Name:           gnome-shell
6Version:        3.36.5
7Release:        1%{?_dist_release}%{?with_systemd:.systemd}
8Group:      desktop-gnome
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPLv2+
13URL:            http://live.gnome.org/GnomeShell
14%global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
15Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
16
17Requires: mutter
18Requires: ca-certificates
19Requires: at-spi2-atk
20Requires: network-manager-applet
21Requires: gnome-tweak-tool
22Requires: xdg-desktop-portal-gtk
23
24BuildRequires: meson
25BuildRequires: pkgconfig
26BuildRequires: python3
27BuildRequires: sassc
28BuildRequires: libxslt
29BuildRequires: gnome-common
30BuildRequires: at-spi2-atk-devel
31BuildRequires: evolution-data-server-devel
32BuildRequires: gcr-devel
33BuildRequires: gtk3-devel
34BuildRequires: gdk-pixbuf-devel
35BuildRequires: gobject-introspection-devel
36BuildRequires: glib2-devel
37BuildRequires: gjs-devel
38BuildRequires: libxml2-devel
39BuildRequires: clutter-devel
40BuildRequires: cogl-devel
41BuildRequires: mutter-devel
42BuildRequires: polkit-devel
43BuildRequires: startup-notification-devel
44BuildRequires: ibus-devel
45BuildRequires: libX11-devel
46BuildRequires: gsettings-desktop-schemas-devel
47BuildRequires: gnome-desktop3-devel
48BuildRequires: gnome-bluetooth-devel
49BuildRequires: gstreamer1-devel
50BuildRequires: NetworkManager-libnm-devel
51BuildRequires: libsecret-devel
52%if %{with systemd}
53BuildRequires: systemd-devel
54%endif
55BuildRequires: pulseaudio-libs-devel
56BuildRequires: gnome-autoar-devel
57BuildRequires: json-glib-devel
58BuildRequires: bash-completion
59BuildRequires: asciidoc
60
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62
63%description
64GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
65It provides core interface functions like switching to windows and launching
66applications. GNOME Shell takes advantage of the capabilities of modern graphics
67hardware and introduces innovative user interface concepts to provide a delightful
68and easy to use experience.
69
70
71%package        docs
72Summary:        Documentation for %{name}
73Summary(ja):    %{name} 用のドキュメント
74Group:          documentation
75Requires:       %{name} = %{version}-%{release}
76BuildArch:              noarch
77
78%description    docs
79This package contains documentation for %{name}.
80
81
82%prep
83%setup -q
84
85
86%build
87export LANG=ja_JP.UTF-8
88%meson \
89%if !%{with systemd}
90  -Dsystemd=false \
91%endif
92  -Dgtk_doc=true
93%meson_build
94
95
96%install
97export LANG=ja_JP.UTF-8
98%{__rm} -rf %{buildroot}
99%meson_install
100
101%find_lang %{name}
102
103
104
105%clean
106%{__rm} -rf ${RPM_BUILD_ROOT}
107
108
109%post
110/sbin/ldconfig
111touch --no-create %{_datadir}/icons/hicolor
112if [ -x /usr/bin/gtk-update-icon-cache ]; then
113  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
114fi
115
116%postun
117/sbin/ldconfig
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x /usr/bin/gtk-update-icon-cache ]; then
120  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
121fi
122glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
123
124%posttrans
125glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
126
127
128%files -f %{name}.lang
129%defattr(-,root,root,-)
130%license COPYING
131%doc NEWS README.md
132%dir %{_sysconfdir}/xdg
133%dir %{_sysconfdir}/xdg/autostart
134%{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
135%{_bindir}/gnome-*
136%{_libdir}/%{name}/*
137%{_libexecdir}/gnome-shell-calendar-server
138%{_libexecdir}/gnome-shell-hotplug-sniffer
139%{_libexecdir}/gnome-shell-overrides-migration.sh
140%{_libexecdir}/gnome-shell-perf-helper
141%{_libexecdir}/gnome-shell-portal-helper
142%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
143%{_datadir}/applications/*.desktop
144%{_datadir}/dbus-1/interfaces/*.xml
145%{_datadir}/dbus-1/services/*.service
146%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
147%{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
148%{_datadir}/%{name}/*
149%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
150%dir %{_datadir}/xdg-desktop-portal
151%dir %{_datadir}/xdg-desktop-portal/portals
152%{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
153%{_mandir}/man1/*.1*
154%dir %{_datadir}/bash-completion
155%dir %{_datadir}/bash-completion/completions
156%{_datadir}/bash-completion/completions/gnome-extensions
157%{_datadir}/icons/hicolor/scalable/apps/*
158%{_datadir}/icons/hicolor/symbolic/apps/*
159%{_datadir}/metainfo/*
160%if %{with systemd}
161%{_userunitdir}/*
162%endif
163
164%files docs
165%defattr(-,root,root,-)
166%{_datadir}/gtk-doc/html/shell
167%{_datadir}/gtk-doc/html/st
168
169
170%changelog
171* Fri Aug 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.5-1
172- new upstream release.
173
174* Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.4-1
175- new upstream release.
176
177* Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.2-1
178- new upstream release.
179- dropped Patch102: session tracker was switched to elogind.
180- added Patch105.
181
182* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-1
183- new upstream release.
184
185* Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
186- new upstream release
187- add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
188
189* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
190- new upstream release
191- update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
192
193* Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
194- new upstream release
195
196* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
197- new upstream release
198
199* Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
200- new upstream release
201- update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
202
203* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
204- new upstream release
205
206* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
207- add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
208
209* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
210- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
211
212* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
213- new upstream release
214
215* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
216- new upstream release
217
218* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
219- new upstream release
220- add BuildRequires: python3-devel
221- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
222
223* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
224- rebuilt with libical 1.0.1
225
226* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
227- new upstream release
228
229* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
230- new upstream release
231
232* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
233- new upstream release
234- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
235- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
236
237* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
238- new upstream release
239
240* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
241- new upstream release
242
243* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
244- new upstream release
245
246* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
247- new upstream release
248
249* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
250- new upstream release
251
252* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
253- new upstream release
254
255* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
256- new upstream release
257
258* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
259- new upstream release
260
261* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
262- new upstream release
263
264* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
265- new upstream release
266- update Patch101 (gnome-shell-vine-settings.patch)
267- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
268- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
269- create %%{name}-docs subpackage
270
271* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
272- new upstream release
273- remove Source102 (gnome-shell.gnome-3-6.ja.po)
274
275* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
276- new upstream release
277- add Source102 (gnome-shell.gnome-3-6.ja.po)
278
279* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
280- new upstream release
281- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
282
283* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
284- rebuild with telepathy-logger-0.6.0
285- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
286
287* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
288- new upstream release
289
290* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
291- new upstream release
292- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
293- update Patch101 (gnome-shell-vine-settings.patch)
294- change BuildRequires: ca-certificates instead of openssl
295- add BuildRequires: libcanberra-gtl3-devel
296
297* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
298- new upstream release
299- remove Patch103 (gnome-shell-ja.po-date.patch)
300
301* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
302- new upstream release
303- update Patch101,103
304- remove Patch0,102
305- add BuildRequires: gcr-devel
306- remove BuildRequires: GConf2-devel
307- add Requires: at-spi2-atk
308
309* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
310- new upstream release
311- remove Patch1
312
313* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
314- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
315- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
316- rename Patch103 (gnome-shell-ja.po-date.patch)
317- drop Patch102
318
319* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
320- new upstream release
321
322* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
323- new upstream release
324
325* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
326- new upstream release
327- update Patch101
328- update Patch102
329- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
330- add BuildRequires: libgudev1-devel, openssl
331
332* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
333- new upstream release
334- add BuildRequires: folks-devel, NetworkManager-glib-devel
335- add Requires: caribou
336- remove Patch0
337- update Patch101
338- update Patch102
339- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
340
341* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
342- rebuild with gnome-menus-3.1.5
343- add Patch0 (gnome-shell-git20110821.patch)
344
345* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
346- new upstream release
347- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
348- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
349- remove BuildRequires: xulrunner-devel
350- add Patch101 (gnome-shell-vine-settings.patch)
351- add Patch102 (gnome-shell-vine-customize.patch)
352- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
353
354* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
355- add Requires: mutter
356
357* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
358- new upstream release
359
360* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
361- initial build for Vine Linux
362
Note: See TracBrowser for help on using the repository browser.