source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 8369

Revision 8369, 8.6 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

RevLine 
[8369]1%define pkg_version 3.12.1
[7119]2%define pkg_release 1%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
[8353]8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.12/%{name}-%{version}.tar.xz
[4616]9
10# settings for Vine
[7474]11Patch101:       gnome-shell-vine-settings.patch
[4616]12
[7474]13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
[521]16
[915]17Requires: mutter
[4704]18Requires: caribou
[6890]19Requires: ca-certificates
[6011]20Requires: at-spi2-atk
[7633]21Requires: telepathy-logger
22Requires: network-manager-applet
23Requires: gnome-tweak-tool
[915]24
[521]25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
[4616]35BuildRequires: gnome-desktop3-devel
[521]36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
[7633]45BuildRequires: control-center-devel
[6011]46BuildRequires: gcr-devel
[521]47BuildRequires: gstreamer-devel
48BuildRequires: dbus-glib-devel
[4616]49BuildRequires: telepathy-logger-devel
50BuildRequires: polkit-devel
51BuildRequires: pulseaudio-libs-devel
52BuildRequires: evolution-data-server-devel
[4704]53BuildRequires: folks-devel
54BuildRequires: NetworkManager-glib-devel
[7633]55BuildRequires: libnm-gtk-devel
[4812]56BuildRequires: libgudev1-devel
[6890]57BuildRequires: libcanberra-gtk3-devel
[7633]58BuildRequires: caribou-devel
[6890]59BuildRequires: ca-certificates
[521]60BuildRequires: intltool
61
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: Takemikaduchi
67
68
69%description
[4616]70GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
71It provides core interface functions like switching to windows and launching
72applications. GNOME Shell takes advantage of the capabilities of modern graphics
73hardware and introduces innovative user interface concepts to provide a delightful
74and easy to use experience.
[521]75
76
[7633]77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:              noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88
[521]89%prep
90%setup -q
[4616]91%patch101 -p1 -b .vine
[521]92
93%build
[7938]94autoreconf -if
[4812]95%configure \
[8353]96        --disable-static \
97        --disable-systemd
[4812]98
[521]99%{__make} %{?_smp_mflags}
100
101
102%install
103%{__rm} -rf ${RPM_BUILD_ROOT}
104%{__make} install DESTDIR=${RPM_BUILD_ROOT}
105
[4616]106find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
107
[521]108%find_lang %{name}
109
110
111
112%clean
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115
116%post
117/sbin/ldconfig
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x /usr/bin/gtk-update-icon-cache ]; then
120  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
121fi
122
123%postun
124/sbin/ldconfig
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
[4616]129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]130
[4616]131%posttrans
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]133
[4616]134
[521]135%files -f %{name}.lang
[7633]136%defattr(-,root,root,-)
[4616]137%doc COPYING NEWS README
[521]138%{_bindir}/gnome-shell
[4616]139%{_bindir}/gnome-shell-extension-tool
[6011]140%{_bindir}/gnome-shell-extension-prefs
[6890]141%{_bindir}/gnome-shell-perf-tool
[7633]142%{_libdir}/%{name}/*
[4812]143%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]144%{_libexecdir}/gnome-shell-calendar-server
145%{_libexecdir}/gnome-shell-hotplug-sniffer
146%{_libexecdir}/gnome-shell-perf-helper
[6011]147%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[4616]148%{_datadir}/applications/gnome-shell.desktop
[6011]149%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]150%{_datadir}/applications/evolution-calendar.desktop
[6011]151%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]152%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]153%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
154%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]155%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
156%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
157%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]158%{_datadir}/%{name}/*
159%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
160%{_mandir}/man1/%{name}.1.gz
161
162%files docs
163%defattr(-,root,root,-)
[6011]164%{_datadir}/gtk-doc/html/shell
165%{_datadir}/gtk-doc/html/st
[521]166
167
168%changelog
[8369]169* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
170- new upstream release
171
[8353]172* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
173- new upstream release
174
[8219]175* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
176- new upstream release
177
[8011]178* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
179- new upstream release
180
[7938]181* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
182- new upstream release
183
[7756]184* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
185- new upstream release
186
[7712]187* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
188- new upstream release
189
[7681]190* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
191- new upstream release
192
[7633]193* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
194- new upstream release
195- update Patch101 (gnome-shell-vine-settings.patch)
196- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
197- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
198- create %%{name}-docs subpackage
199
[7516]200* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
201- new upstream release
202- remove Source102 (gnome-shell.gnome-3-6.ja.po)
203
[7474]204* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
205- new upstream release
206- add Source102 (gnome-shell.gnome-3-6.ja.po)
207
[7119]208* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
209- new upstream release
210- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
211
[7047]212* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
213- rebuild with telepathy-logger-0.6.0
214- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
215
[6951]216* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
217- new upstream release
218
[6890]219* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
220- new upstream release
221- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
222- update Patch101 (gnome-shell-vine-settings.patch)
223- change BuildRequires: ca-certificates instead of openssl
224- add BuildRequires: libcanberra-gtl3-devel
225
[6619]226* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
227- new upstream release
228- remove Patch103 (gnome-shell-ja.po-date.patch)
229
[6011]230* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
231- new upstream release
232- update Patch101,103
233- remove Patch0,102
234- add BuildRequires: gcr-devel
235- remove BuildRequires: GConf2-devel
236- add Requires: at-spi2-atk
237
[5448]238* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
239- new upstream release
240- remove Patch1
241
[5206]242* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
243- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
244- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
245- rename Patch103 (gnome-shell-ja.po-date.patch)
246- drop Patch102
247
[5038]248* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
249- new upstream release
250
[4850]251* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
252- new upstream release
253
[4812]254* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
255- new upstream release
256- update Patch101
257- update Patch102
258- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
259- add BuildRequires: libgudev1-devel, openssl
260
[4704]261* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
262- new upstream release
263- add BuildRequires: folks-devel, NetworkManager-glib-devel
264- add Requires: caribou
265- remove Patch0
266- update Patch101
267- update Patch102
268- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
269
[4650]270* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
271- rebuild with gnome-menus-3.1.5
272- add Patch0 (gnome-shell-git20110821.patch)
273
[4616]274* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
275- new upstream release
276- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
277- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
278- remove BuildRequires: xulrunner-devel
279- add Patch101 (gnome-shell-vine-settings.patch)
280- add Patch102 (gnome-shell-vine-customize.patch)
281- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
282
[915]283* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
284- add Requires: mutter
285
[914]286* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
287- new upstream release
288
[521]289* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
290- initial build for Vine Linux
291
Note: See TracBrowser for help on using the repository browser.