source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 8353

Revision 8353, 8.5 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define pkg_version 3.12.0
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.12/%{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-vine-settings.patch
12
13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
16
17Requires: mutter
18Requires: caribou
19Requires: ca-certificates
20Requires: at-spi2-atk
21Requires: telepathy-logger
22Requires: network-manager-applet
23Requires: gnome-tweak-tool
24
25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
35BuildRequires: gnome-desktop3-devel
36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
45BuildRequires: control-center-devel
46BuildRequires: gcr-devel
47BuildRequires: gstreamer-devel
48BuildRequires: dbus-glib-devel
49BuildRequires: telepathy-logger-devel
50BuildRequires: polkit-devel
51BuildRequires: pulseaudio-libs-devel
52BuildRequires: evolution-data-server-devel
53BuildRequires: folks-devel
54BuildRequires: NetworkManager-glib-devel
55BuildRequires: libnm-gtk-devel
56BuildRequires: libgudev1-devel
57BuildRequires: libcanberra-gtk3-devel
58BuildRequires: caribou-devel
59BuildRequires: ca-certificates
60BuildRequires: intltool
61
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: Takemikaduchi
67
68
69%description
70GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
71It provides core interface functions like switching to windows and launching
72applications. GNOME Shell takes advantage of the capabilities of modern graphics
73hardware and introduces innovative user interface concepts to provide a delightful
74and easy to use experience.
75
76
77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:              noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88
89%prep
90%setup -q
91%patch101 -p1 -b .vine
92
93%build
94autoreconf -if
95%configure \
96        --disable-static \
97        --disable-systemd
98
99%{__make} %{?_smp_mflags}
100
101
102%install
103%{__rm} -rf ${RPM_BUILD_ROOT}
104%{__make} install DESTDIR=${RPM_BUILD_ROOT}
105
106find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
107
108%find_lang %{name}
109
110
111
112%clean
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115
116%post
117/sbin/ldconfig
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x /usr/bin/gtk-update-icon-cache ]; then
120  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
121fi
122
123%postun
124/sbin/ldconfig
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131%posttrans
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
133
134
135%files -f %{name}.lang
136%defattr(-,root,root,-)
137%doc COPYING NEWS README
138%{_bindir}/gnome-shell
139%{_bindir}/gnome-shell-extension-tool
140%{_bindir}/gnome-shell-extension-prefs
141%{_bindir}/gnome-shell-perf-tool
142%{_libdir}/%{name}/*
143%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
144%{_libexecdir}/gnome-shell-calendar-server
145%{_libexecdir}/gnome-shell-hotplug-sniffer
146%{_libexecdir}/gnome-shell-perf-helper
147%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
148%{_datadir}/applications/gnome-shell.desktop
149%{_datadir}/applications/gnome-shell-extension-prefs.desktop
150%{_datadir}/applications/evolution-calendar.desktop
151%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
152%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
153%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
154%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
155%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
156%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
157%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
158%{_datadir}/%{name}/*
159%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
160%{_mandir}/man1/%{name}.1.gz
161
162%files docs
163%defattr(-,root,root,-)
164%{_datadir}/gtk-doc/html/shell
165%{_datadir}/gtk-doc/html/st
166
167
168%changelog
169* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
170- new upstream release
171
172* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
173- new upstream release
174
175* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
176- new upstream release
177
178* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
179- new upstream release
180
181* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
182- new upstream release
183
184* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
185- new upstream release
186
187* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
188- new upstream release
189
190* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
191- new upstream release
192- update Patch101 (gnome-shell-vine-settings.patch)
193- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
194- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
195- create %%{name}-docs subpackage
196
197* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
198- new upstream release
199- remove Source102 (gnome-shell.gnome-3-6.ja.po)
200
201* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
202- new upstream release
203- add Source102 (gnome-shell.gnome-3-6.ja.po)
204
205* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
206- new upstream release
207- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
208
209* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
210- rebuild with telepathy-logger-0.6.0
211- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
212
213* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
214- new upstream release
215
216* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
217- new upstream release
218- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
219- update Patch101 (gnome-shell-vine-settings.patch)
220- change BuildRequires: ca-certificates instead of openssl
221- add BuildRequires: libcanberra-gtl3-devel
222
223* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
224- new upstream release
225- remove Patch103 (gnome-shell-ja.po-date.patch)
226
227* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
228- new upstream release
229- update Patch101,103
230- remove Patch0,102
231- add BuildRequires: gcr-devel
232- remove BuildRequires: GConf2-devel
233- add Requires: at-spi2-atk
234
235* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
236- new upstream release
237- remove Patch1
238
239* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
240- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
241- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
242- rename Patch103 (gnome-shell-ja.po-date.patch)
243- drop Patch102
244
245* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
246- new upstream release
247
248* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
249- new upstream release
250
251* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
252- new upstream release
253- update Patch101
254- update Patch102
255- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
256- add BuildRequires: libgudev1-devel, openssl
257
258* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
259- new upstream release
260- add BuildRequires: folks-devel, NetworkManager-glib-devel
261- add Requires: caribou
262- remove Patch0
263- update Patch101
264- update Patch102
265- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
266
267* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
268- rebuild with gnome-menus-3.1.5
269- add Patch0 (gnome-shell-git20110821.patch)
270
271* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
272- new upstream release
273- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
274- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
275- remove BuildRequires: xulrunner-devel
276- add Patch101 (gnome-shell-vine-settings.patch)
277- add Patch102 (gnome-shell-vine-customize.patch)
278- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
279
280* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
281- add Requires: mutter
282
283* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
284- new upstream release
285
286* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
287- initial build for Vine Linux
288
Note: See TracBrowser for help on using the repository browser.