source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 8219

Revision 8219, 8.4 KB checked in by Takemikaduchi, 10 years ago (diff)

dia: fix bug
others: new upstream release

RevLine 
[8219]1%define pkg_version 3.10.3
[7119]2%define pkg_release 1%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
[7938]8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
[4616]9
10# settings for Vine
[7474]11Patch101:       gnome-shell-vine-settings.patch
[4616]12
[7474]13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
[521]16
[915]17Requires: mutter
[4704]18Requires: caribou
[6890]19Requires: ca-certificates
[6011]20Requires: at-spi2-atk
[7633]21Requires: telepathy-logger
22Requires: network-manager-applet
23Requires: gnome-tweak-tool
[915]24
[521]25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
[4616]35BuildRequires: gnome-desktop3-devel
[521]36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
[7633]45BuildRequires: control-center-devel
[6011]46BuildRequires: gcr-devel
[521]47BuildRequires: gstreamer-devel
48BuildRequires: dbus-glib-devel
[4616]49BuildRequires: telepathy-logger-devel
50BuildRequires: polkit-devel
51BuildRequires: pulseaudio-libs-devel
52BuildRequires: evolution-data-server-devel
[4704]53BuildRequires: folks-devel
54BuildRequires: NetworkManager-glib-devel
[7633]55BuildRequires: libnm-gtk-devel
[4812]56BuildRequires: libgudev1-devel
[6890]57BuildRequires: libcanberra-gtk3-devel
[7633]58BuildRequires: caribou-devel
[6890]59BuildRequires: ca-certificates
[521]60BuildRequires: intltool
61
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: Takemikaduchi
67
68
69%description
[4616]70GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
71It provides core interface functions like switching to windows and launching
72applications. GNOME Shell takes advantage of the capabilities of modern graphics
73hardware and introduces innovative user interface concepts to provide a delightful
74and easy to use experience.
[521]75
76
[7633]77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:              noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88
[521]89%prep
90%setup -q
[4616]91%patch101 -p1 -b .vine
[521]92
93%build
[7938]94autoreconf -if
[4812]95%configure \
[6890]96        --disable-static
[4812]97
[521]98%{__make} %{?_smp_mflags}
99
100
101%install
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%{__make} install DESTDIR=${RPM_BUILD_ROOT}
104
[4616]105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
106
[521]107%find_lang %{name}
108
109
110
111%clean
112%{__rm} -rf ${RPM_BUILD_ROOT}
113
114
115%post
116/sbin/ldconfig
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121
122%postun
123/sbin/ldconfig
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x /usr/bin/gtk-update-icon-cache ]; then
126  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
127fi
[4616]128glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]129
[4616]130%posttrans
131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]132
[4616]133
[521]134%files -f %{name}.lang
[7633]135%defattr(-,root,root,-)
[4616]136%doc COPYING NEWS README
[521]137%{_bindir}/gnome-shell
[4616]138%{_bindir}/gnome-shell-extension-tool
[6011]139%{_bindir}/gnome-shell-extension-prefs
[6890]140%{_bindir}/gnome-shell-perf-tool
[7633]141%{_libdir}/%{name}/*
[4812]142%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]143%{_libexecdir}/gnome-shell-calendar-server
144%{_libexecdir}/gnome-shell-hotplug-sniffer
145%{_libexecdir}/gnome-shell-perf-helper
[6011]146%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[4616]147%{_datadir}/applications/gnome-shell.desktop
[6011]148%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]149%{_datadir}/applications/evolution-calendar.desktop
[6011]150%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]151%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]152%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
153%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]154%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
155%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
156%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]157%{_datadir}/%{name}/*
158%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
159%{_mandir}/man1/%{name}.1.gz
160
161%files docs
162%defattr(-,root,root,-)
[6011]163%{_datadir}/gtk-doc/html/shell
164%{_datadir}/gtk-doc/html/st
[521]165
166
167%changelog
[8219]168* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
169- new upstream release
170
[8011]171* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
172- new upstream release
173
[7938]174* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
175- new upstream release
176
[7756]177* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
178- new upstream release
179
[7712]180* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
181- new upstream release
182
[7681]183* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
184- new upstream release
185
[7633]186* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
187- new upstream release
188- update Patch101 (gnome-shell-vine-settings.patch)
189- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
190- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
191- create %%{name}-docs subpackage
192
[7516]193* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
194- new upstream release
195- remove Source102 (gnome-shell.gnome-3-6.ja.po)
196
[7474]197* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
198- new upstream release
199- add Source102 (gnome-shell.gnome-3-6.ja.po)
200
[7119]201* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
202- new upstream release
203- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
204
[7047]205* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
206- rebuild with telepathy-logger-0.6.0
207- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
208
[6951]209* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
210- new upstream release
211
[6890]212* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
213- new upstream release
214- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
215- update Patch101 (gnome-shell-vine-settings.patch)
216- change BuildRequires: ca-certificates instead of openssl
217- add BuildRequires: libcanberra-gtl3-devel
218
[6619]219* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
220- new upstream release
221- remove Patch103 (gnome-shell-ja.po-date.patch)
222
[6011]223* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
224- new upstream release
225- update Patch101,103
226- remove Patch0,102
227- add BuildRequires: gcr-devel
228- remove BuildRequires: GConf2-devel
229- add Requires: at-spi2-atk
230
[5448]231* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
232- new upstream release
233- remove Patch1
234
[5206]235* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
236- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
237- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
238- rename Patch103 (gnome-shell-ja.po-date.patch)
239- drop Patch102
240
[5038]241* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
242- new upstream release
243
[4850]244* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
245- new upstream release
246
[4812]247* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
248- new upstream release
249- update Patch101
250- update Patch102
251- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
252- add BuildRequires: libgudev1-devel, openssl
253
[4704]254* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
255- new upstream release
256- add BuildRequires: folks-devel, NetworkManager-glib-devel
257- add Requires: caribou
258- remove Patch0
259- update Patch101
260- update Patch102
261- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
262
[4650]263* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
264- rebuild with gnome-menus-3.1.5
265- add Patch0 (gnome-shell-git20110821.patch)
266
[4616]267* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
268- new upstream release
269- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
270- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
271- remove BuildRequires: xulrunner-devel
272- add Patch101 (gnome-shell-vine-settings.patch)
273- add Patch102 (gnome-shell-vine-customize.patch)
274- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
275
[915]276* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
277- add Requires: mutter
278
[914]279* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
280- new upstream release
281
[521]282* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
283- initial build for Vine Linux
284
Note: See TracBrowser for help on using the repository browser.