source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 5038

Revision 5038, 5.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.1

RevLine 
[5038]1%define pkg_version 3.2.1
[4704]2%define pkg_release 1%{?_dist_release}
[521]3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
[4616]8Source0:     %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:    gnome-shell-vine-settings.patch
12Patch102:    gnome-shell-vine-customize.patch
[4812]13Patch103:    gnome-shell-3.1.91.1-ja.po.patch
[4616]14
[521]15License:     GPLv2+
16Group:       User Interface/Desktops
17URL:         http://live.gnome.org/GnomeShell
18
19Requires(post,postun): scrollkeeper >= 0.1.4
20Requires(post,pre,preun): GConf2 >= 2.14
[915]21Requires: mutter
[4704]22Requires: caribou
[4812]23Requires: openssl
[915]24
[521]25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
[4616]35BuildRequires: gnome-desktop3-devel
[521]36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: GConf2-devel
40BuildRequires: startup-notification-devel
41BuildRequires: gnome-doc-utils
42BuildRequires: desktop-file-utils
43BuildRequires: libcroco-devel
44BuildRequires: librsvg2-devel
45BuildRequires: gobject-introspection-devel
46BuildRequires: gstreamer-devel
47BuildRequires: dbus-glib-devel
[4616]48BuildRequires: telepathy-logger-devel
49BuildRequires: polkit-devel
50BuildRequires: pulseaudio-libs-devel
51BuildRequires: evolution-data-server-devel
[4704]52BuildRequires: folks-devel
53BuildRequires: NetworkManager-glib-devel
[4812]54BuildRequires: libgudev1-devel
55BuildRequires: openssl
[521]56BuildRequires: intltool
57
58BuildRoot: %{_tmppath}/%{name}-%{version}-root
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: Takemikaduchi
63
64
65%description
[4616]66GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
67It provides core interface functions like switching to windows and launching
68applications. GNOME Shell takes advantage of the capabilities of modern graphics
69hardware and introduces innovative user interface concepts to provide a delightful
70and easy to use experience.
[521]71
72
73%prep
74%setup -q
[4616]75%patch101 -p1 -b .vine
76%patch102 -p1 -b .vine
77%patch103 -p1 -b .old_po
[521]78
79%build
[4650]80libtoolize --copy --force
81autoreconf
[4812]82%configure \
83        --disable-static \
84        --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
85
[521]86%{__make} %{?_smp_mflags}
87
88
89%install
90%{__rm} -rf ${RPM_BUILD_ROOT}
91%{__make} install DESTDIR=${RPM_BUILD_ROOT}
92
[4616]93find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
94
[521]95%find_lang %{name}
96
97
98
99%clean
100%{__rm} -rf ${RPM_BUILD_ROOT}
101
102
103%post
104/sbin/ldconfig
105export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
106gconftool-2 --makefile-install-rule \
107    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
[4616]108    > /dev/null || :
[521]109touch --no-create %{_datadir}/icons/hicolor
110if [ -x /usr/bin/gtk-update-icon-cache ]; then
111  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
112fi
113
[4616]114%pre
[521]115if [ "$1" -gt 1 ]; then
116  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
117  gconftool-2 --makefile-uninstall-rule \
118    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
119    > /dev/null || :
120fi
121
[4616]122%preun
[521]123if [ "$1" -eq 0 ]; then
124  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125  gconftool-2 --makefile-uninstall-rule \
126    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
127    > /dev/null || :
128fi
129
130%postun
131scrollkeeper-update -q || :
132/sbin/ldconfig
133touch --no-create %{_datadir}/icons/hicolor
134if [ -x /usr/bin/gtk-update-icon-cache ]; then
135  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
136fi
[4616]137glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]138
[4616]139%posttrans
140glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]141
[4616]142
[521]143%files -f %{name}.lang
144%defattr(-,root,root)
[4616]145%doc COPYING NEWS README
146%{_sysconfdir}/gconf/schemas/gnome-shell.schemas
[521]147%{_bindir}/gnome-shell
[4616]148%{_bindir}/gnome-shell-extension-tool
[521]149%{_libdir}/gnome-shell/*
[4812]150%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]151%{_libexecdir}/gnome-shell-calendar-server
152%{_libexecdir}/gnome-shell-hotplug-sniffer
153%{_libexecdir}/gnome-shell-perf-helper
154%{_datadir}/applications/gnome-shell.desktop
155%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
156%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
157%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[521]158%{_datadir}/gnome-shell/*
[915]159%{_datadir}/man/man1/*.1.gz
[521]160
161
162%changelog
[5038]163* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
164- new upstream release
165
[4850]166* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
167- new upstream release
168
[4812]169* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
170- new upstream release
171- update Patch101
172- update Patch102
173- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
174- add BuildRequires: libgudev1-devel, openssl
175
[4704]176* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
177- new upstream release
178- add BuildRequires: folks-devel, NetworkManager-glib-devel
179- add Requires: caribou
180- remove Patch0
181- update Patch101
182- update Patch102
183- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
184
[4650]185* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
186- rebuild with gnome-menus-3.1.5
187- add Patch0 (gnome-shell-git20110821.patch)
188
[4616]189* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
190- new upstream release
191- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
192- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
193- remove BuildRequires: xulrunner-devel
194- add Patch101 (gnome-shell-vine-settings.patch)
195- add Patch102 (gnome-shell-vine-customize.patch)
196- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
197
[915]198* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
199- add Requires: mutter
200
[914]201* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
202- new upstream release
203
[521]204* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
205- initial build for Vine Linux
206
Note: See TracBrowser for help on using the repository browser.