source: projects/specs/trunk/g/gnome-sharp2/gnome-sharp2-vl.spec @ 8068

Revision 8068, 5.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define mono_dir %(/usr/bin/monodir)
2%define _name gnome-sharp
3Summary: .Net Language Bindings for Gnome
4Summary(ja): Mono 用 GNOME バインディング
5Name: gnome-sharp2
6Version: 2.24.1
7Release: 8%{?_dist_release}
8License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
9Group: Development/Libraries
10URL: http://gtk-sharp.sf.net
11Source: %{_name}-%{version}.tar.bz2
12Patch2: gnome-sharp-find_gtkhtml_ver.patch
13Patch3: gnome-sharp-2.24.1-TestXfer.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk-sharp2 gtk-sharp2-gapi
16BuildRequires: librsvg2-devel
17BuildRequires: mono-devel monodoc
18BuildRequires: vte-devel gtkhtml3-devel
19BuildRequires: libSM-devel
20BuildRequires: libgnomeui-devel
21%define env_options export MONO_SHARED_DIR=/tmp
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27This package contains Mono bindings for Gnome.
28
29
30%package -n gnome-sharp2-complete
31Group: Development/Libraries
32Summary: GTK+ and GNOME bindings for Mono (virtual package)
33Requires: art-sharp2 = %{version}-%{release}
34Requires: gconf-sharp2 = %{version}-%{release}
35Requires: gnome-sharp2 = %{version}-%{release}
36Requires: gnome-vfs-sharp2 = %{version}-%{release}
37#Requires: glib-sharp2 >= 2.10.3
38
39%description -n gnome-sharp2-complete
40Gtk# is a library that allows you to build fully native graphical GNOME
41applications using Mono. Gtk# is a binding to GTK+, the cross platform
42user interface toolkit used in GNOME. It includes bindings for Gtk,
43Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas.  (Virtual
44package which depends on all gtk-sharp2 subpackages)
45
46
47%package -n gnome-vfs-sharp2
48Summary: Mono bindings for gnomevfs
49Group: Development/Libraries
50Requires: gnome-vfs2
51
52%description -n gnome-vfs-sharp2
53This package contains Mono bindings gnomevfs.
54
55
56%package -n art-sharp2
57Summary: Mono bindings for libart
58Group: Development/Libraries
59Requires: libart_lgpl
60
61%description -n art-sharp2
62This package contains Mono bindings for libart.
63
64
65%package -n gconf-sharp2
66Summary: Mono bindings for gconf
67Group: Development/Libraries
68
69%description -n gconf-sharp2
70This package contains Mono bindings for gconf and gconf peditors.
71
72
73%prep
74%setup -q -n %{_name}-%{version}
75%patch3 -p1 -b .TestXfer
76autoreconf -f -i
77
78
79%build
80export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
81export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
82%configure \
83        --libexecdir=%{_prefix}/lib \
84        --enable-debug
85make
86
87%install
88export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
89%makeinstall
90
91## remove unuse files
92rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
93rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
94rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99
100%files -n gnome-sharp2-complete
101%defattr(-, root, root)
102## This is the 'base' package so we put the common dirs of all in this package
103# Otherwise, this package doesn't get created!
104%dir %{mono_dir}/gtk-sharp-2.0
105%dir %{_prefix}/lib/gtk-sharp-2.0
106
107%files -n gnome-sharp2
108%defattr(-,root,root)
109%{_libdir}/libgnomesharpglue-2.so
110%{_libdir}/pkgconfig/gnome-sharp-2.0.pc
111%{mono_dir}/gac/*gnome-sharp
112%{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
113%{_datadir}/gapi-2.0/gnome-api.xml
114
115
116%files -n gnome-vfs-sharp2
117%defattr(-,root,root)
118%{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
119%{mono_dir}/gac/*gnome-vfs-sharp
120%{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
121%{_datadir}/gapi-2.0/gnome-vfs-api.xml
122
123
124%files -n art-sharp2
125%defattr(-,root,root)
126%{_libdir}/pkgconfig/art-sharp-2.0.pc
127%{mono_dir}/gac/*art-sharp
128%{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
129%{_datadir}/gapi-2.0/art-api.xml
130
131
132%files -n gconf-sharp2
133%defattr(-, root, root)
134%{_bindir}/gconfsharp2-schemagen
135%{_libdir}/pkgconfig/gconf-sharp-2.0.pc
136%{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
137%{mono_dir}/gac/*gconf-sharp
138%{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
139# Other distros place these in gnome-sharp2??
140%{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
141%{mono_dir}/gac/*gconf-sharp-peditors
142%{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
143
144
145%changelog
146* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-8
147- rebuild with VineSeed environment
148- add BuildRequires: libgnomeui-devel
149
150* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-7
151- add BuildRequires: libSM-devel
152
153* Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
154- added gnome-sharp-2.24.1-TestXfer.patch
155- rebuilt with mono-2.8
156
157* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
158- build with rpm-4.8.1-1 for pkg-config file
159
160* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
161- rebuilt with new environment
162
163* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
164- rebuilt with latest rpm to update mono-dependencies
165- dropt BR: libgnomedb-devel
166
167* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
168- changed Group to Development/Libraries
169
170* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
171- updated to 2.24.1
172
173* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
174- initial build for VineSeed
175        - updated gnome-sharp2 to 2.20.0
176        - added japanese summary
177        - applied vine versioning policy
178        - spec in utf-8
179
180* Thu Apr 24 2008 wberrier@suse.de
181- Update to 2.12.1
182  * Bugfix in GLib ref management for Gnome.Program crash in
183  gnome-sharp
184* Thu Apr  3 2008 wberrier@novell.com
185- Can now build 2.16 and 2.20 from the same spec
186- Update to 2.20.0
187  - Updated bindings to coincide with gtk# 2.12
188  - Removed bindings: gtkhtml#, rsvg#, and vte#
189* Wed Mar 26 2008 wberrier@novell.com
190- Update to 2.16.1
191  - Allow storage of empty lists in gconf
192  - Bug fixes:
193  - [GConf] Impossible to set empty list values (bnc#325516)
194  - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
195* Tue Jul  3 2007 wberrier@suse.de
196- Initial package of gnome-sharp2 2.16.0
197  - (Split from gtk-sharp 2.8.3)
Note: See TracBrowser for help on using the repository browser.